Photoshop CC 2018: Editing video, custom pan & zoom

  • 1
  • Idea
  • Updated 10 months ago
  • (Edited)
I am trying to setup a custom pan & zoom on a still image. It is buggy at best - sometimes it works, sometimes it doesn't create a smooth animation.

I have a still in the timeline. I place the playhead at the end of the still "clip'. I use TRANSFORM and adjust the size & position. Place a keyframe. I then open the drop-down menu and choose ZOOM and deselect RESIZE TO FIT FRAME. I move the playhead to the beginning of the 'clip' and again resize and position. I place a keyframe. And PREVIEW. 

It used to be the step of choosing ZOOM wasn't necessary. In the process of doing this, ZOOM changes to CUSTOM and RESIZE TO FIT FRAME is automatically selected. This sometimes (but not always) creates a jerky motion at the end of the 'clip'. The workaround is to split the 'clip' just before the last frame and then delete the last frame. So there's a workaround, but it's not a very elegant solution. Setting custom animations should work smoothly. I need to be able to deselect RESIZE TO FIT FRAME and have that setting stick.
Photo of Karen Ackoff

Karen Ackoff

  • 10 Posts
  • 0 Reply Likes

Posted 11 months ago

  • 1
Photo of Andrew Sender

Andrew Sender, Employee

  • 65 Posts
  • 32 Reply Likes
Hi Karen,
Can you try enabling Preferences -> Performance -> Legacy Compositing to fix your issue?

Andrew
Photo of Karen Ackoff

Karen Ackoff

  • 10 Posts
  • 0 Reply Likes
I do not see this option.
Photo of David Tristram

David Tristram, Employee

  • 179 Posts
  • 99 Reply Likes
Open Preferences panel with the menu item under *Photoshop CC* in the menu bar (this is for Mac, let me know if you need help bringing up preferences on Windows)
Select *Performance* pane
Toward the bottom of that pane, right above "Description" area there is an "Options" area
In Photoshop CC 2019, there is one checkbox in the Options area, labeled "Legacy Compositing"
Click the checkbox to turn it on, this will disable recent changes made in how layers are combined in Photoshop, and may change the way videos appear to animate.
Photo of Karen Ackoff

Karen Ackoff

  • 10 Posts
  • 0 Reply Likes
I'm using Photoshop CC 2018 (this is the version we run where I teach, so it makes sense for me to use the same version). There is no option for "Legacy Compositing". Above the DESCRIPTION area, I have HISTORY & CACHE (Web/IU Design, Default/Photos, Huge Pixel Dimensions, History States, Cache Levels, Cache Tile Size). There are set with defaults.
Photo of David Tristram

David Tristram, Employee

  • 179 Posts
  • 99 Reply Likes
sure, thanks.  The option is new to CC 2019, so we can't try that to see if it helps your issue.  
Photo of David Tristram

David Tristram, Employee

  • 179 Posts
  • 99 Reply Likes
Karen, Can you tell me 'how' you 'place a keyframe' in the workflow above?

thanks!
Photo of Karen Ackoff

Karen Ackoff

  • 10 Posts
  • 0 Reply Likes
Sure.

I place the end keyframe first. Once I've sized & positioned the still image, I click on the little stopwatch icon just to the left of the TRANSFORM attribute in the Video Group.

I place the start keyframe next. Again, I size & position the still. Used to be a keyframe would be generate automatically when I did this - but it doesn't do this now. But what I do now is click on the little diamond icon (there are arrows on either side) just to the left of the stopwatch icon - next to the Transform attribute in the Video Group.
(Edited)
Photo of David Tristram

David Tristram, Employee

  • 179 Posts
  • 99 Reply Likes
hmm, I do not see "TRANSFORM", maybe you can help me find it.  In my video track I can make keyframes for Position, Opacity, and Style.  
Photo of Karen Ackoff

Karen Ackoff

  • 10 Posts
  • 0 Reply Likes
I may have figured it out. I'll have to do some more tests to see if results are consistent. 

I am using some older JPEG files. I consistently get the little jerky movement at the end. Your having mentioned CC 2019 made me thing about versions. So I ran a test. I did one clip with the original JPEG file and got the little jerky movement. Then I opened the file in Photoshop, did a SAVE AS, saving as a JPEG. Then I made the same clip and and it worked fine.

So perhaps this has something to do with the fact the still image was an older file?
Photo of David Tristram

David Tristram, Employee

  • 179 Posts
  • 99 Reply Likes
I think there may be some differences regarding placed assets, smart objects, and rasterized layers, and perhaps jpeg is treated differently when you bring it in.  I was wondering what your "still" is and how it is "brought in".  I'm still trying a few things too.  
Photo of David Tristram

David Tristram, Employee

  • 179 Posts
  • 99 Reply Likes
I see that dragging and dropping a jpeg into a doc creates a layer, and in the video timeline it gets a 'transform' track automatically so that matches your described workflow a little better.  
Photo of Karen Ackoff

Karen Ackoff

  • 10 Posts
  • 0 Reply Likes
It starts out as POSITION, but as soon as I select ZOOM from the MOTION menu, it changes to TRANSFORM.

Here is the sample file: http://karenackoff.net/z-misc/ackoff-video-test.psd
Photo of Karen Ackoff

Karen Ackoff

  • 10 Posts
  • 0 Reply Likes
If I bring in a still, and change only the position (and do not access the MOTION menu), then it will automatically create a keyframe at the beginning of the clip. But if I resize, rotate, etc. I have to first choose MOTION > Zoom. Then I move to the beginning of the clip, size & reposition, and I have to manually add the keyframe. It works... but it adds the little jerky motion at the end. See the file at the above link.
Photo of David Tristram

David Tristram, Employee

  • 179 Posts
  • 99 Reply Likes
so, one more question.  when you transform the still, how are you doing that?  I can use the move tool to move it, and Edit ==> Transform to scale.  If I use these tools to set the last and first Transform keyframes with a placed jpeg, I do not see your issue.  
Photo of David Tristram

David Tristram, Employee

  • 179 Posts
  • 99 Reply Likes
I think what is happening is when you select zoom in the dropdown, Photoshop is setting a scale value at that keyframe.  The value is probably something just to accomplish the zoom for users who are not doing their own scaling. You can try zoom-in vs zoom-out there to see if you get different results and kind of confirm this idea.  What works for me is setting the transform scale with edit ==> transform and the move tool after creating the keyframe (and with the playhead on the keyframe you want to update).  After I did that, the resulting animation moves to and stops at the desired transformed value.  
Photo of Karen Ackoff

Karen Ackoff

  • 10 Posts
  • 0 Reply Likes
Thank you, David. I've tried this and it seems to work. I just need to see if it works consistently. But I think you've nailed it. Apologies for not responding sooner; things have been a bit hectic.