Photoshop CC 2017: New windows opened behind existing windows

  • 1
  • Problem
  • Updated 1 year ago
  • In Progress
  • (Edited)
If I have a file open in Photoshop, and I open a new blank document, the new document loads beneath the current open document windows. This messes up my workflow, because I'm often creating a new document to use immediately.

Is there a setting that I'm missing? Or is this behaviour intentional for some reason I don't understand?
Photo of Jesse Schoff

Jesse Schoff

  • 6 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14550 Posts
  • 1893 Reply Likes
Hi Jesse, what OS/version are you running on? I cannot reproduce off hand. Can you provide a screenshot or video of your window and app configuration? Might help us to reproduce.
Photo of Jesse Schoff

Jesse Schoff

  • 6 Posts
  • 0 Reply Likes
And one more ping....
Photo of Jesse Schoff

Jesse Schoff

  • 6 Posts
  • 0 Reply Likes
I did some more testing and it appears that this only happens when using keyboard shortcuts.

I'm on Windows 10. Photoshop 2017.0.1 release (20161130.r.29 x64)

Here is a video demo of what I'm experiencing:  https://jes.sc/static/photoshop_window-bug/demo.webm

The first time, I use keyboard shortcuts, and the issue occurs. The second time, I used the mouse and menus, and the issue does not occur.
Photo of Jesse Schoff

Jesse Schoff

  • 6 Posts
  • 0 Reply Likes
The example video has been moved to https://jes.sc/share/photoshop-demo.webm
Photo of Jesse Schoff

Jesse Schoff

  • 6 Posts
  • 0 Reply Likes
Hi Jeffrey, did that video make sense? Can you try reproducing the issue using keyboard shortcuts?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14550 Posts
  • 1893 Reply Likes
Hi Jesse, sorry for the late reply. If you go into Preferences > General... and check "Use Legacy New Document Interface" does it work correctly?
Photo of Jesse Schoff

Jesse Schoff

  • 6 Posts
  • 0 Reply Likes
Yep. Switching to the legacy interface fixes the issue.

Thanks for getting back to me.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14218 Posts
  • 1795 Reply Likes
Thanks for confirming. I have a bug logged for the issue with the new New Document interface. Hopefully we can address this in a forthcoming update.