Photoshop CC 2017 - Locks up on 'New' - FIXED

  • 2
  • Problem
  • Updated 2 years ago
Upon opening Photoshop CC 2017, whenever I tried to open a 'New' document it would hang / lock up.  However, when I tried to 'Open' a recent document I could do that.

To resolve this I carried out these steps (hope this helps others):

Ctrl-K (to get to Preferences).
Selected the 'General' tab.
Ensure the box labelled 'Use Legacy 'New Document' Interface is checked.
Click OK.
Close Photoshop CC 2017.
Then open it back up...

You should now be able to create a New document using the 'legacy' template.

I assume there is an issue with the new template within Photoshop CC 2017.

Hope this helps others.

Photo of Stephen Lalich

Stephen Lalich

  • 1 Post
  • 0 Reply Likes
  • happy I fixed this. Hope it helps others.

Posted 2 years ago

  • 2
Photo of Stacy Bratton

Stacy Bratton

  • 9 Posts
  • 0 Reply Likes
Thanks, going to try that. Mine locked up last night. Took several restarts to the computer , Along with other 'go to' moves that may or may not help. Finally got it back open and only took an hour. Gee wiz- photoshop.
Photo of David

David, Official Rep

  • 3380 Posts
  • 558 Reply Likes
Hi Steve and Stacy,

From what you're describing, Steve, it sounds like the app was getting hung while trying to access the Internet.  The new File > New interface downloads thumbnails of recent files used on other machines, for instance, as well as syncs libraries and profiles, etc.  It could be that some part of this process has collapsed.  I would attempt to uninstall and reinstall the Creative Cloud app to see if that resolves things.

Hope that helps,
Photo of Richard Betchley

Richard Betchley

  • 14 Posts
  • 2 Reply Likes
Thank you, I didn’ like that new update.. This helps a lot Dick B