Photoshop CC 2017: Changes focus to other layer when I try to move selected one

  • 3
  • Problem
  • Updated 4 weeks ago
  • Not a Problem
  • (Edited)
I select a layer, try to move it, but focus in a layer list jumps to different layer and it moves instead of needed. 
Photo of Rodion Revin

Rodion Revin

  • 2 Posts
  • 2 Reply Likes
  • confused

Posted 1 year ago

  • 3
Photo of Jerry Syder

Jerry Syder

  • 205 Posts
  • 100 Reply Likes
I've seen this over the past two versions as well. I thought it was a bug that they were aware of so didn't bring it up. Thanks for that Rodion.
Photo of Max Johnson

Max Johnson, Champion

  • 450 Posts
  • 208 Reply Likes
Make sure that the "Auto-select" option box is unchecked in the move tool properties bar at the top when you have the move tool selected. It was defaulted to "on" in some revision back.
Photo of Rodion Revin

Rodion Revin

  • 2 Posts
  • 2 Reply Likes
Oh, my god. You're absolutely right.
This is not a bug, its a feature I didn't notice.
Thank you so much Max. Issue is closed.
Photo of Max Johnson

Max Johnson, Champion

  • 450 Posts
  • 208 Reply Likes
Fun fact: you can temporarily toggle that auto-select mode if you hold ctrl while using the move tool.
Photo of emdot

emdot

  • 1 Post
  • 1 Reply Like
My. Freaking. Hero!! Thank you!
Photo of Marco Aurelio Almeida Patara

Marco Aurelio Almeida Patara

  • 1 Post
  • 0 Reply Likes
Hy Max, I've tried what you suggested but no success here. But it only happens when the image has 100% of view size. When it's zoomed in it doesn't.
Photo of David Bethell

David Bethell

  • 3 Posts
  • 1 Reply Like
Max, you're a flipping genius. X
Photo of Andrea Odio Tavoletta

Andrea Odio Tavoletta

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled Move tool creates selection box instead of moving Layers.

Very often if I select a layer and want to use the move tool, the cursor creates a selection and the layer is no longer selected. The only way to move the level is to use the arrows on the keyboard or setting a transformation ... this is really boring ... is there a way to fix this type of problem? Do I have to reinstall the software? (and yes i use google translate :))
Photo of Jim Hatch

Jim Hatch

  • 3 Posts
  • 0 Reply Likes
i have done all that you say it still jumps , must be a bug
Photo of mobile tech

mobile tech

  • 1 Post
  • 0 Reply Likes
same problem and but the said solution can't fixed mine :( any help?
Photo of Max Johnson

Max Johnson, Champion

  • 441 Posts
  • 205 Reply Likes
If you hold ctrl and drag, does it still have the problem?