Photoshop CC 2015: the Welcome Screen Strikes Back!

  • 1
  • Problem
  • Updated 3 years ago
Upgraded from CC2014 to CC2015... now I'm getting the "welcome screen" every time I launch PS. It wouldn't be so bad, except that it takes sooooooo long to load and this is really, really annoying.

The "new features", "getting started" and "tips & techniques" tabs have a "don't show welcome screen again" checkbox at the bottom (why it is not at the top is beyond me... also the "create" tab does not have this checkbox). Anyway, I unchecked the box, and the welcome screen still shows up on startup! (with the "don't show welcome screen again" still unchecked--I'm glad it preserved state... I wish it would actually work as indicated)

I tried the fix proposed in various questions for CC2014 with similar issues (https://helpx.adobe.com/photoshop/kb/...), but this did not help.

As a side-note, the upgrade to CC2015 did not copy my preferences from CC2014 over, either. I did this manually, and they are there now, but the welcome screen problem was there before I copied my preferences (keyboard & workspace).

Any ideas? Not sure that it matters, but I'm running Win7 Pro.

Thx.

-ml
Photo of Markus Lankeit

Markus Lankeit

  • 6 Posts
  • 1 Reply Like

Posted 3 years ago

  • 1
Photo of Markus Lankeit

Markus Lankeit

  • 6 Posts
  • 1 Reply Like
So I kept playing with the "don't show welcome screen" checkbox... It was checked before, and the welcome screen kept appearing, so I thought unchecking it would fix it, reading the descriptor again, you want this box checked after all... I re-checked it and now the screen no longer appears (what a relief!). Not sure why it didn't work this way before, but I'm glad it is now working.

Thx.

-ml
Photo of Sam Burnside

Sam Burnside

  • 1 Post
  • 0 Reply Likes
I found that if you go to:
Adobe -> Adobe Photoshop CC 2015 -> Required -> CEP -> Extensions then delete com.adobe.welcome.
that works for me. It might be called something similar for you though.