Photoshop CC 2015 selection bug: white outline when selecting from the border of the canvas (still in 2015.0.1)

  • 1
  • Problem
  • Updated 3 years ago
I have been experiencing this extremely annoying bug since CC 2015 came out. It is still present in 2015.0.1. To reproduce:

1. File > New
Make the width and height something relatively small, like 32x32. Optionally make the background a color other than white so it's easier to see. I chose black. Click OK.

2. Zoom in as much as you can on the image while still being able to see it all without scrolling.

3. With the rectangular marquee too, select the whole image, border to border.

4. THIS happens. Notice the unusual white outline around my image. These pixels are not part of the image and are not selectable. The only way to make it disappear is to change the zoom level.

Photo of Benoît Rouleau

Benoît Rouleau

  • 4 Posts
  • 0 Reply Likes
  • frustrated

Posted 3 years ago

  • 1
Photo of David

David, Official Rep

  • 2800 Posts
  • 387 Reply Likes
Howdy Benoît,

What OS are you running on?  If you go to Preferences > Performance, what are your Graphics Processor Settings?

Thanks,
David
Photo of Benoît Rouleau

Benoît Rouleau

  • 4 Posts
  • 0 Reply Likes
Hi David,

I'm running OS X Yosemite (10.10.5) on a MacBook Pro 15-inch Late 2013. Here's a screenshot of my Performance Preferences.

Photo of David

David, Official Rep

  • 2800 Posts
  • 387 Reply Likes
Hiya Benoît,

Try enabling the Graphics Processor and rebooting.  Does that solve the problem?

I'll be honest, this issue doesn't appear to be what I was suspecting.  I will probably have many more questions...

You don't have gridline enabled by chance, do you?

Thanks,
David
Photo of Benoît Rouleau

Benoît Rouleau

  • 4 Posts
  • 0 Reply Likes
Hello David,

Thank you, that fixed the issue! By curiosity, I went in the Advanced Settings and tried all 3 "drawing modes", checking and unchecking the 3 checkboxes, and they all had the same result (I made sure to restart Photoshop every time I changed the settings). As long as "Use Graphics Processor" is enabled, it works. :)

Benoît
Photo of Benoît Rouleau

Benoît Rouleau

  • 4 Posts
  • 0 Reply Likes
Oh and no, I had the grid disabled (although "pixel grid" seemed to enable itself automatically when I turned on the Graphics Processor). I tried enabling and disabling the "grid" when Graphics Processor was disabled, and it didn't change anything. BUT, interestingly, the "smart guide" (which I always had enabled) does change the behaviour of the bug slightly. When I disable it, the outline doesn't appear until after I click away from the selection (deselect it). I don't how much that helps!

Thank you,

Benoît
Photo of Felix Klein

Felix Klein

  • 1 Post
  • 0 Reply Likes
Hi there, 

I'd just like to point out that I have the same issue with my up-to-date version of Photoshop CC.
Enabling the "Use Graphics Processor" is enabled there is no problem. However in some instances I want to have this option disabled (for instance when recording Photoshop for live streams). So it would be great to fix this issue when not using the graphics processor.

Cheers,

Felix