Photoshop CC 2015: Save for Web - Dithering Confusion

  • 3
  • Problem
  • Updated 2 years ago
  • Acknowledged
  • (Edited)
When using Noise or Pattern algorithm the Dither input filed is disabled. However, under image preview (Optimized tab) on the right hand side the amount of dithering is still shown in %. A displayed number is exactly the same as the one I entered into Dither field the last time I used Diffusion algorithm. When I switch to Diffusion algorithm, change the dither and switch to another algorithm (Noise or Pattern) the amount of dither will still be displayed under the image preview despite the fact that I cannot set a dither for these algorithms. Such behavior is in my opinion confusing and incorrect. Photoshop should display 0% dither (or nothing) in cases when Noise or Pattern algorithm is used.

OS: Win 7 64-bit, Photoshop: CC 2015.1.1
Photo of MilP

MilP

  • 58 Posts
  • 6 Reply Likes

Posted 2 years ago

  • 3
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
There is no "dither input" field, so I'm guessing you mean the dither percentage field? Yes, that should only be enabled for diffusion dithering -- the other dithering styles have no use for that value.

On MacOS it correctly hides the field contents, so it sounds like on Windows we may not be dimming/disabling the field correctly when it is not available. But that should be harmless because the value isn't used by anything other than diffusion dithering.
Photo of MilP

MilP

  • 58 Posts
  • 6 Reply Likes
Hi,
There is no "dither input" field, so I'm guessing you mean the dither percentage field?

Yes, I meant "Dither" percentage field.

On MacOS it correctly hides the field contents...

That's not the problem. The problem is that when I'm using Noise or Pattern algorithm, below image preview, I can still see the setting of Diffusion algorithm (n% dither). Please look at the screenshots below:

Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
That shows the number field working correctly - the value is only visible when you are using the diffusion option that allows for that value, and the field is disabled when you choose a different option that does not use that value.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
Ah, you mean at the bottom of the image preview.
Ok, that needs to be fixed.
Photo of MilP

MilP

  • 58 Posts
  • 6 Reply Likes
Ah, you mean at the bottom of the image preview.

Yes, that's correct.

Ok, that needs to be fixed.

Thanks