Photoshop CC 2015: Crashing on launch with scripting support errors

  • 6
  • Problem
  • Updated 3 years ago
  • Solved
  • (Edited)
Where do we go to report crashing on launch issues? The Photoshop CC 2015 from a few months ago is still working for me, but the new update hits a problem loading the ScriptingSupport plugin, and then crashes, even after having used the Cleaner Tool to remove old versions.

Here is a screen recording, and the crash log:

http://colin.scienceninja.com/pscrash...
http://colin.scienceninja.com/pscrash...

Note: This conversation was created from a reply on: Photoshop CC 2015.1 now available..
Photo of colinholgate

colinholgate

  • 19 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 6
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
You should create a new topic, and include the details of your crashes.

If ScriptingSupport is having a problem, you may need to uninstall and reinstall the application, or remove an errant second copy of Scripting Support you copied over by mistake.
Photo of colinholgate

colinholgate

  • 19 Posts
  • 0 Reply Likes
As an aside, I did create a new "report a problem" post, spent some time filling in the details, found I had to register here, was sent a confirmation code, and the page reloaded but missing all the text I had typed!

But now that we're here, I'll give more details about the problem. I have uninstalled and reinstalled several times in the last day. I have to reinstall the previous version to get work done, then when I have time to try again I install yesterday's version. I have used the Cleaner Tool to remove any reference to Photoshop on my Mac, before trying another fresh install.

I have also run my Mac in safe mode, that didn't help, I still get the same error and crash.

Speaking of the ScriptingSupport plugin, if I replace Photoshop/Contents/Required/Plug-Ins/ScriptingSupport.plugin with the one from CC 2014, Photoshop no longer shows an error, at least not that same error. It does complain about not finding the Javascript plugin, and many features don't work, but there is no crash.

Is there someone here who could make sense of the crash log, enough to suggest what I try next?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
OK, I'm seeing this crash in our crash database - but I can't reproduce it or explain it immediately. Yes, I can make sense of it, mostly, but can't explain why it happens for you and not me.

Basically ScriptingSupport isn't initializing on your system, then things fail because they expect it to be working -- and something about the way it fails causes Photoshop to think it was initialized.

Yes, replacing the plugin with an old version will break all sorts of things.

I've asked some of our QE folks to work with you to get more information about your system and what could be going wrong.
Photo of colinholgate

colinholgate

  • 19 Posts
  • 0 Reply Likes
Thanks. When you say that you see the crash in your database, do you mean literally my crash report, or that someone else had reported the same issue? If it's from me, I imagine you have a lot of them!
Photo of Dominic Battre

Dominic Battre

  • 5 Posts
  • 0 Reply Likes
I think I am experiencing the same issues. Happy to help debugging the problem. Here is a stacktrace:

Here is the stack trace:
Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 ??? 0x00007ffd868d3a60 0 + 140726860855904
1 com.adobe.Photoshop 0x000000010fa3b28d 0x10e05d000 + 27124365
2 com.adobe.PlugPlugOwl 0x000000011529b380 PlugPlugErrorCode boost::_bi::list2, boost::arg >::operator() >(boost::_bi::type, PlugPlugErrorCode (*&)(char const*, PlugPlugExtensionPlayerType), boost::_bi::list2&, long) + 70
3 com.adobe.PlugPlugOwl 0x000000011529b2f3 PlugPlugErrorCode boost::_bi::bind_t, boost::arg > >::operator()(char const*&, PlugPlugExtensionPlayerType&) + 53
4 com.adobe.PlugPlugOwl 0x000000011529b0ef boost::detail::function::function_obj_invoker2, boost::arg > >, PlugPlugErrorCode, char const*, PlugPlugExtensionPlayerType>::invoke(boost::detail::function::function_buffer&, char const*, PlugPlugExtensionPlayerType) + 43
5 com.adobe.PlugPlugOwl 0x000000011528ff04 boost::function2::operator()(char const*, PlugPlugExtensionPlayerType) const + 72
6 com.adobe.PlugPlugOwl 0x000000011528dd8f csxs::services::host::ApplicationCallbacks::AllocateScriptingEngineType(char const*, PlugPlugExtensionPlayerType) + 73
7 com.adobe.PlugPlugOwl 0x000000011528a50c csxs::services::host::ApplicationCallbacksLogger::AllocateScriptingEngineType(char const*, PlugPlugExtensionPlayerType) + 80
8 com.adobe.PlugPlugOwl 0x00000001152591f4 csxs::commands::CmdAsyncEvalRawScriptImpl::AllocateScriptingEngine(Service*) + 92
9 com.adobe.PlugPlugOwl 0x0000000115258f56 csxs::commands::CmdAsyncEvalRawScriptImpl::Execute() + 118
10 com.adobe.PlugPlugOwl 0x0000000115300138 csxs::services::ui::html::EvalScriptCommand::Execute() + 86
11 com.adobe.PlugPlugOwl 0x0000000115285db7 csxs::plugplug::util::JSEvalScriptQueue::ExecuteCommand() + 55
12 com.adobe.PlugPlugOwl 0x00000001152869cb csxs::plugplug::util::DispatchAsyncEvalScriptTask::Execute() + 33
Photo of Dominic Battre

Dominic Battre

  • 5 Posts
  • 0 Reply Likes
Here is another, earlier one that looks related:

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 com.adobe.AdobeExtendScript 0x000000010fd635de ScScript::Engine::getAll(ScCore::TSimpleArray&) + 14
1 com.adobe.PSAutomate 0x00000001464c3639 0x146381000 + 1320505
2 com.adobe.PSAutomate 0x00000001464e8897 0x146381000 + 1472663
3 com.adobe.Photoshop 0x0000000109dd9803 0x108410000 + 27039747
4 com.adobe.Photoshop 0x0000000109dee28d 0x108410000 + 27124365
5 com.adobe.PlugPlugOwl 0x000000010f650380 PlugPlugErrorCode boost::_bi::list2, boost::arg >::operator() >(boost::_bi::type, PlugPlugErrorCode (*&)(char const*, PlugPlugExtensionPlayerType), boost::_bi::list2&, long) + 70
6 com.adobe.PlugPlugOwl 0x000000010f6502f3 PlugPlugErrorCode boost::_bi::bind_t, boost::arg > >::operator()(char const*&, PlugPlugExtensionPlayerType&) + 53
7 com.adobe.PlugPlugOwl 0x000000010f6500ef boost::detail::function::function_obj_invoker2, boost::arg > >, PlugPlugErrorCode, char const*, PlugPlugExtensionPlayerType>::invoke(boost::detail::function::function_buffer&, char const*, PlugPlugExtensionPlayerType) + 43
8 com.adobe.PlugPlugOwl 0x000000010f644f04 boost::function2::operator()(char const*, PlugPlugExtensionPlayerType) const + 72
9 com.adobe.PlugPlugOwl 0x000000010f642d8f csxs::services::host::ApplicationCallbacks::AllocateScriptingEngineType(char const*, PlugPlugExtensionPlayerType) + 73
10 com.adobe.PlugPlugOwl 0x000000010f63f50c csxs::services::host::ApplicationCallbacksLogger::AllocateScriptingEngineType(char const*, PlugPlugExtensionPlayerType) + 80
11 com.adobe.PlugPlugOwl 0x000000010f60e1f4 csxs::commands::CmdAsyncEvalRawScriptImpl::AllocateScriptingEngine(Service*) + 92
12 com.adobe.PlugPlugOwl 0x000000010f60df56 csxs::commands::CmdAsyncEvalRawScriptImpl::Execute() + 118
13 com.adobe.PlugPlugOwl 0x000000010f6b5138 csxs::services::ui::html::EvalScriptCommand::Execute() + 86
14 com.adobe.PlugPlugOwl 0x000000010f63adb7 csxs::plugplug::util::JSEvalScriptQueue::ExecuteCommand() + 55
15 com.adobe.PlugPlugOwl 0x000000010f63b9cb csxs::plugplug::util::DispatchAsyncEvalScriptTask::Execute() + 33
16 com.adobe.PlugPlugOwl 0x000000010f5fec3c -[PlugPlugAsyncEventHandler handleNotificationOnMainThread:] + 93
Photo of colinholgate

colinholgate

  • 19 Posts
  • 0 Reply Likes
Dominic, did you watch my screen recording, and does the same thing happen for you? In another forum someone suggested signing out and in again to CC can fix the issue, but it didn't for me.
Photo of Dominic Battre

Dominic Battre

  • 5 Posts
  • 0 Reply Likes
I see the same as your screen recording, except that I see another popup dialog for a split second. I have recorded it and it reads "There is a problem with Generator. Please quick Photoshop and try again. If the problem persists, remove any third-party plug-ins or try reinstalling Photoshop." I tried removing the plug-ins but that did not help.

Signing out and in to CC does not make a difference for me.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
Yep, same issue (and there are some similar ones which might be related - still trying to figure that out).
And I found your report, along with more than a few others.

Unfortunately this crash isn't simple because apparently the problem (Scripting Support failing to load) occurs quite a while before it crashes (when something tries to use scripting support). To solve it, we'll have to figure out the primary issue, and why it crashes for a few users, but not everyone.
Photo of colinholgate

colinholgate

  • 19 Posts
  • 0 Reply Likes
I've been trying to see what is different in the ScriptingSupport.plugin, between CC 2015 from May, and the new one. The main new additions seems to be support for extra high and extra low icon sizes.

One very odd thing though, the code signing for the two new entries is the same (0BjO/cLl1acrGinuAUdvwOovoDI=). That seems wrong, doesn't it? If there's a code signing check, and one of the two is incorrect, could that explain things?

BTW, I can put the new plugin into the May version and then see the same error message, though it doesn't go on to crash. This means I can carry on working and then if I have a new idea on how to fix the new one, I can try that without having to do a whole new install.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
There are multiple parts to the code signing, and I'm not sure you're seeing the part that changes with the binary.
If the code signing had failed, you would see an error message from the OS.

Please work with Jeanne so we can get more information to figure out why you are getting the error in Scripting Support in Photoshop 2015.1.
Photo of colinholgate

colinholgate

  • 19 Posts
  • 0 Reply Likes
I'm hoping to hear from her again! She got in touch yesterday, and I answered her questions.
Photo of Dominic Battre

Dominic Battre

  • 5 Posts
  • 0 Reply Likes
Jeanne, could you send me the May 2015 version of ScriptingSupport.plugin by email? Having a semi-working version seems like a good first start.
Photo of colinholgate

colinholgate

  • 19 Posts
  • 0 Reply Likes
I think that won't work. Photoshop won't crash, but the welcome screen won't appear, and most useful things will fail. I mean, I did try it!
Photo of Robert Hall

Robert Hall

  • 11 Posts
  • 0 Reply Likes
Hi all - I am getting the exact same errors with 2015.1 Photoshop ad described above by Colin and others. I am having similar problems with Adobe Media Encoder on launch. Please let me know if I can supply any additional crash logs, information, etc. to help nail this down.
Photo of colinholgate

colinholgate

  • 19 Posts
  • 0 Reply Likes
Sure enough, AME doesn't open, but it takes a lot longer to complain, and then it immediate quits after the dialog, there's no crash.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
Adobe Media Encoder?
Photo of colinholgate

colinholgate

  • 19 Posts
  • 0 Reply Likes
It's Adobe's media encoder application.
Photo of Robert Hall

Robert Hall

  • 11 Posts
  • 0 Reply Likes
Yes Adobe Media Encoder - so far all the other updated Apps seems to be OK - just Photoshops and Media Encoder - and I am only seeing this on a 2008 Mac Pro 3,1 Tower (Dual Quad-Core 3.2GHZ CPU's, NVIDIA GeForce GTX680) Every prior version has worked fine for me on this machine - and my Macbook Pro runs smooth. At first I thought it might be an OpenCL issue since both Photoshop and Media Encoder leverage GPU/OpenCL extensively, but doing the swap on the Scripting Additions that Colin and others did, I was able to get it to launch, and I was able to get at least get to the preferences to disable use GPU features, etc. and then swapped back in the correct Scripting Additions plugin, and it was still no go.... so something else weird is going on....
Photo of colinholgate

colinholgate

  • 19 Posts
  • 0 Reply Likes
Elsewhere people have had problem on Yosemite, and on not the latest computer, but I am on the latest MacBook Pro, and 10.11.1. So it's not specifically an old OS version problem.
Photo of Robert Hall

Robert Hall

  • 11 Posts
  • 0 Reply Likes
Forgot to mention, my Macbook Pro install is still running 10.10.5 - the machine I am seeing the problems on is 10.11.1
Photo of colinholgate

colinholgate

  • 19 Posts
  • 0 Reply Likes
Hey Chris, you said "if the code signing had failed you would see an error message from the OS". This is what appears in Console at the time that the error dialog appears:

12/4/15 2:05:35.910 PM amfid[118]: /Applications/Adobe Photoshop CC 2015/Adobe Photoshop CC 2015.app/Contents/Required/Plug-Ins/Extensions/ScriptingSupport.plugin/Contents/MacOS/ScriptingSupport signature not valid: 0xfffefa2a

You'll find that error code all over the place, and sometimes the cure is to change privacy settings to allow apps from anywhere, not just certified developers. But that's more about the application, not a plugin.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
That's odd,but might be related to the problem. I'm not seeing that error on my systems.

Could you zip up the failing Scripting Support plugin and email it to ccox (at) adobe (dot) com ?
Photo of colinholgate

colinholgate

  • 19 Posts
  • 0 Reply Likes
Would you be willing to swap? Email sent.
Photo of Jeanne Rubbo

Jeanne Rubbo, Employee

  • 125 Posts
  • 27 Reply Likes
I'm a Photoshop QE who is trying to track down this crash. If you're running into this, please contact me at jrubbo AT adobe DOT com so I can get more info from you.

Thanks in advance!
Photo of colinholgate

colinholgate

  • 19 Posts
  • 0 Reply Likes
Email sent. Subject is "November PS update crashing".
Photo of Robert Hall

Robert Hall

  • 11 Posts
  • 0 Reply Likes
FYI: Jeanne - just dropped you an email as well on this topic.
Photo of theburr

theburr

  • 8 Posts
  • 2 Reply Likes
Cross posting my issue from other Photoshop forum. https://forums.adobe.com/thread/2020915

After running the update the older version still launches. I did the troubleshooting in the reply by Adobe staff but now am prompted to run the update again. Hesitant to do so if it's not going to get me any further than I am now.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
This is a great conversation that has nothing to do with the one you posted in, so I created a new conversation to continue the discussion.

Please reference the new conversation here: Photoshop CC 2015 - After update, still shows old version
Photo of colinholgate

colinholgate

  • 19 Posts
  • 0 Reply Likes
I have worked with Chris to narrow down this problem. They are close to figuring it out. I don't know of when a fix might appear.
Photo of Robert Hall

Robert Hall

  • 11 Posts
  • 0 Reply Likes
Thanks for the update Colin! I later realized that not only is Adobe Media Encoder also crashing, but After Effects and Premiere too - all other CC 2015 apps appear to be working...
Photo of colinholgate

colinholgate

  • 19 Posts
  • 0 Reply Likes
You're basically an unlucky guy!
Photo of colinholgate

colinholgate

  • 19 Posts
  • 0 Reply Likes
BTW, I think I'm unlucky too. I forwarded to Chris the fact that it's not just a PS issue.
Photo of Robert Hall

Robert Hall

  • 11 Posts
  • 0 Reply Likes
Ha - yeah pretty much my first major problems with a release in I don't know how long... I mentioned it to Chris in an email as well - hopefully it all gets straightened out soon.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
We're testing a Photoshop fix for this now. But the failing library is common to many of the Adobe apps. We've notified the team responsible for that library, and are waiting to hear back.

I still can't reproduce the problem, because it appears to depend on corrupt information in a database file on some systems. But I know the symptom well enough to trap it and prevent it from causing further problems.
Photo of Robert Hall

Robert Hall

  • 11 Posts
  • 0 Reply Likes
Thanks for the update Chris - much obliged for all your hard work in tracking this down!
Photo of Dominic Battre

Dominic Battre

  • 5 Posts
  • 0 Reply Likes
Is there a chance that deleting a database file and reinstalling Photoshop solves the problem? I got an update today that did not fix it.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
There is a chance, but the team responsible hasn't told us which database file is involved.
Reinstalling won't help, and we're still testing the fix/workaround in our code.
Photo of Robert Hall

Robert Hall

  • 11 Posts
  • 0 Reply Likes
Any updates on this or an ETA?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
I can't announce dates. But we're working on it.
Photo of Ray Ives

Ray Ives

  • 4 Posts
  • 0 Reply Likes
Had the same problem. 2015.1 crashes on startup. Windows 10 AMD Radeon HD 6450.

Your support guys had a full go via remote access without success. Not even the latest AMD beta drivers would help.

Best I could achieve is successful launch with limited graphics capability. Not good enough so rolled back to previous version which did and does work w/o issues.

How will I know when Adobe has fixed this bug? Don't want to keep activating the 'Update Available' prompt to simply end up with the same problem!

This is naughty Adobe. At the price you should be doing better!
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
Yeah, the problem is too complex for support to figure out.
We're testing a solution to this now, but it was too risky for the update that came out earlier tonight.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15328 Posts
  • 2222 Reply Likes
Official Response
This should be solved in the 2015.1.2 update released today: http://blogs.adobe.com/crawlspace/201...
Photo of Ray Ives

Ray Ives

  • 4 Posts
  • 0 Reply Likes
Wish it were so!

Still having the same problem introduced in 2015.1 - Photoshop crashes on startup.

“Photoshop has encountered a problem with the display driver and has temporarily disabled enhancements which use the graphics hardware”
Photo of Ray Ives

Ray Ives

  • 4 Posts
  • 0 Reply Likes
Just installed illustrator. Nada. Also crashes on start up. No options to enable/disable - just reports there's a problem and closes.

Pretty useless.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
This topic (and site) is about Photoshop, and this issue was fixed in Photoshop 2015.1.2.
For Illustrator issues, please see their user forums at https://forums.adobe.com/community/illustrator
Photo of Ray Ives

Ray Ives

  • 4 Posts
  • 0 Reply Likes
You are wrong. The issue I'm having has not been fixed. I am only able to use photoshop without graphics processor. The moment I try to use the graphics processor photoshop crashes. See my original post from 2 months ago. Obviously the same issue is preventing Illustrator from loading.

The least you guys should do is suspend subscriptions until you've resolved the issues. $500pa - for what!

If it sounds like I'm annoyed, believe it!
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
The issue discussed in this topic, about Photoshop CC 2015 crashing on launch after getting an error from Scripting Support -- was definitely fixed in the 2015.1.2 update.

You have a very different issue, and should post the details of your issue in another topic so we can help you solve that issue.

And it sounds like all you have is a bug in your video card driver, and updating the driver from the GPU maker's website should solve it.
(Edited)
Photo of colinholgate

colinholgate

  • 19 Posts
  • 0 Reply Likes
Thanks. Were only Photoshop and Illustrator updated today? I still have three other end of November updated apps that are crashing. Photoshop is ok now!
Photo of Robert Hall

Robert Hall

  • 11 Posts
  • 0 Reply Likes
Yep - that fixed Photoshop for me - but like Colin mentioned, I still have 3 apps that are still crashing on launch: After Effects, Premiere and Media Encoder. They are all still borked... :(
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
Probably due to the same library that was causing problems for Photoshop.
Contact those teams on their user forums and let them know (and they know how to reach me :-) ).
Photo of colinholgate

colinholgate

  • 19 Posts
  • 0 Reply Likes
Same three for me, and I've had bugs logged against them for a month or so. All three have different symptoms to each other, and different to Photoshop.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
Yep, but the corrupt database on your disk (which is triggering the library bug) is the same and the library is shared among the applications. Until the library is fixed (or workarounds placed around the library calls), it'll cause slightly different problems in each application.
Photo of Robert Hall

Robert Hall

  • 11 Posts
  • 0 Reply Likes
Chris - can you share which database file that is part of this equation - I am happy to tinker with the database while the other apps are being worked on to also account for this condition.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
I'm not sure - the library with the problem uses several database files on the local disk.
Photo of Robert Hall

Robert Hall

  • 11 Posts
  • 0 Reply Likes
Hi Chris - I am still having problems with After Effects, Premier and Media Encoder - can I get some extra info from you on what the core of this problem is and some assistance in getting it to the right teams? I had not had a chance to follow up on this in about the other apps and had hoped they would get similar patches - so I had set this issue aside for a bit and just used another machine - but now no longer have that luxury and would really like to get this resolved. Thanks for any additional assistance you can provide.