Photoshop CC 2015 Color Picker errors while running on a Cintiq Companion 1

  • 1
  • Problem
  • Updated 2 years ago
I'm using Photoshop CC 2015 on a Cintiq Companion 1 running Windows 10. Whenever I try to select a color via the color picker or swatches I get the message "Could not complete your request because of a program error". Interestingly after I select "ok" in the error message box I can continue working with the color I have selected, I just get the error message. If I haven't got a project open I can't duplicate the error, it only appears if a canvas is open. The error occurs if I'm using a stylus, mouse, or touch. All of my drivers for the Cintiq are updated as is Windows 10. Anyone else seeing this or have any ideas?
Photo of David Gomes

David Gomes

  • 12 Posts
  • 0 Reply Likes
  • Frustrated

Posted 2 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 769 Reply Likes
Can you post the last 20 lines from the file PSErrorLog.txt in your Photoshop preferences folder?
Photo of David Gomes

David Gomes

  • 12 Posts
  • 0 Reply Likes

The first two lines in this file had repeated at least 20 lines before this file starts.

*************

2016:01:31 14:58:02 : ..\..\sources\USheet.cpp : 460 : REQUIRE failed

2016:01:31 15:00:35 : ..\..\sources\USheet.cpp : 460 : REQUIRE failed

2016:01:31 15:00:46 : tracked key 00000000000001D8 of type struct _ADsc * __ptr64 not found : 1 : REQUIRE failed

2016:01:31 15:00:46 : e:\ps15\ps_15_win_x64_daily_retail\20150529.r.88\photoshop\main\photoshop\interfaces\UTrackResourceImp.h : 137 : REQUIRE failed

2016:01:31 15:00:46 : tracked key 0000000000000068 of type struct _ARef * __ptr64 not found : 1 : REQUIRE failed

2016:01:31 15:00:46 : e:\ps15\ps_15_win_x64_daily_retail\20150529.r.88\photoshop\main\photoshop\interfaces\UTrackResourceImp.h : 137 : REQUIRE failed

2016:01:31 15:00:46 : tracked key 00000000000001D0 of type struct _ADsc * __ptr64 not found : 1 : REQUIRE failed

2016:01:31 15:00:46 : e:\ps15\ps_15_win_x64_daily_retail\20150529.r.88\photoshop\main\photoshop\interfaces\UTrackResourceImp.h : 137 : REQUIRE failed

2016:01:31 20:55:41 : ..\..\sources\USheet.cpp : 460 : REQUIRE failed

2016:01:31 21:13:06 : ..\..\sources\USheet.cpp : 460 : REQUIRE failed


************


Hope that helps, and thanks!

DG

Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 766 Reply Likes
Just launch with command-option-shift (control-alt-shift) held down to reset the prefs, or use the "reset on next launch" button in preferences.
Photo of David Gomes

David Gomes

  • 12 Posts
  • 0 Reply Likes
Bingo!  Resetting the preferences (which I didn't think of) solved the problem!  You sir, are a rock star.

Thanks Chris!
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 766 Reply Likes
Sigh. That still leaves some mystery part of the preferences corrupted to cause the error - and  I'd really like to know what it was (so we can prevent the error in the future).
Photo of David Gomes

David Gomes

  • 12 Posts
  • 0 Reply Likes
 I'll see if I can replicate the problem via regular use on my side.  I can't help but wonder if either a recent DL of Photoshop CC corrupted the preference file, or if the move to Windows 10 somehow did the same.  The only other change that happened around the same time I noticed this problem was an install of   Airparrot that facilitates communication between my Cintiq and our networked Apple TVs. 

Its hard for me to believe that a regular update to Photoshop via CC would be a problem, now Windows 10 is possible but not likely since I'm sure you all are running  Cintiq/Win 10 configurations.  What about Airparrot?  A possibility?
Photo of David Gomes

David Gomes

  • 12 Posts
  • 0 Reply Likes
I'm happy to do anything I can to help you all sleuth this out.