Photoshop CC 2015: CMD H - "Hide Extras" re-enables itself when using the Pen tool. Press it during a path creation and you lose the path.

  • 1
  • Problem
  • Updated 3 years ago
  • (Edited)
OSX Yosemite - 10.10.3 - Brand New Mac Pro.

Just upgraded Photoshop CC to the 2015 version and went to use the path tool. Zoomed into 800% to path an object, went to turn off "extras" and began pathing. As soon as I make the first click with the path, "extras" re-enables itself. Okay. So I thought maybe I'll keep extras on and try pathing and then turn it off. Made it halfway through the path and went to turn off "extras" and it removed the path I was working on.

If I go to view>show>pixel grid and turn that off manually everything is fine. I just didn't have to do that in the past.
Photo of David Ziebart

David Ziebart

  • 2 Posts
  • 0 Reply Likes
  • meh.

Posted 3 years ago

  • 1
Photo of David

David, Official Rep

  • 2800 Posts
  • 390 Reply Likes
Hi David,

First, to get your path "back" have you tried looking in the Path panel?  When I tried to reproduce what you're describing, although my path was deselected when I hid extras, when I looked in the Path panel, I found my all my efforts saved under Work Path.

More concerning, however, is that extras re-enabled themselves.  My first guess is that you have a tablet or some other input device connected to you machine.  My second guess would be a screen-capture app or something else that monitors and/or supplies keyboard input.  Either way, it sounds like a conflict -- the other things is sending a command to the OS that you didn't intend.

If you'd like, I'm happy to setup a web-hosted screenshare to get to the bottom of this problem with you.  Just let me know.

Thanks,
David
Photo of David Ziebart

David Ziebart

  • 2 Posts
  • 0 Reply Likes
Hey David,

Thanks for the reply.

The only way the path allows completion is by having extras turned on. If I turn extras off mid path, I can see the progress of the current path in the gray box of work path panel, but the path points disappear on the main image. If I try to click the pen tool back on the image, extras re-enables and the current path clears and disappears from the gray box work path area in the paths panel, as if a new path is being created.

As for my computer, there's no tablet or input device at all. The only things plugged in are my monitors, ethernet cable and keyboard and I don't use screen capture apps at all or third party programs that monitor keyboard inputs(to my knowledge).

A screen share could be good. Plus it gets me out of working on a wonderful(read terrible) project : )
Photo of David

David, Official Rep

  • 2800 Posts
  • 389 Reply Likes
Howdy David,

Hmmm.  Have you tried turning the extras off and then starting the path?  Or, do extras just turn back on on their own during the process?

I've a strong hunch you have some other software active which is triggering all this, but I can check that out when we do a screenshare.  How is tomorrow for you?  I'll follow up with an email.

Thanks,
David
Photo of jack h

jack h

  • 1 Post
  • 0 Reply Likes
Hey David,

This is the original guy with the problem. I didn't realize I was signed into my co-workers cloud account so any further interactions will be through this account/email.

Anyways, I'm game for a screenshare whenever you are.

Jack
Photo of David

David, Official Rep

  • 2800 Posts
  • 389 Reply Likes
Hi Jack,

What does your afternoon look like?  If not today, how about on Monday?  Please respond to the email I just sent.

Let me know,
Thanks,
David
Photo of Steve Archer

Steve Archer

  • 1 Post
  • 0 Reply Likes
Was there ever a resolution to this issue?
Photo of David

David, Official Rep

  • 2800 Posts
  • 387 Reply Likes
Unfortunately, Steve, but no.  I could never get a reproducible case of this problem.  Are you having it?  Can you reproduce it consistently?  Can you share those steps?

Thanks,
David