Photoshop CC 2015.5: Select and Mask does not work

  • 5
  • Problem
  • Updated 4 months ago
  • (Edited)
When I first installed PS 2015.5, the select and mask feature worked just fine.  Then, I went to utilize it this evening, and every time I tried to open an image in the select and mask window, the entire image would already be selected upon opening, and nothing could be subtracted or changed in the selection.  The select tools work outside of the select and mask window, as they did in previous versions, but this new feature doesn't seem to be working at all.  Help!
Photo of Marti Timple

Marti Timple

  • 2 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 5
Photo of Stefan Klein

Stefan Klein

  • 119 Posts
  • 65 Reply Likes
Did the layer maybe already have a white mask? If so, invert it (in or outside of Select and Mask).
Photo of Marti Timple

Marti Timple

  • 2 Posts
  • 0 Reply Likes
No... I tried multiple images.. None had anything selected before opening in select and mask. None of the actions available inside select and mask, including invert, did anything. The entire image just shows the overlay in red.
Photo of Jeremy Newman

Jeremy Newman

  • 3 Posts
  • 1 Reply Like
Hi -Same issue here in NYC... were you ever able to resolve it? I also just updated to the 2017 version and it's still happening. So. Frustrating. 
Photo of Elizabeth Taylor

Elizabeth Taylor

  • 1 Post
  • 0 Reply Likes
I have the same problem. Were you able to resolve it? If so, how?
Photo of John Maguire

John Maguire

  • 397 Posts
  • 82 Reply Likes
Another solution is to use the old refine edge which is still in 2017! First make your selection than go to the select menu, hold shift and choose Select and mask. the old refine edge will open.
Photo of John Maguire

John Maguire

  • 398 Posts
  • 83 Reply Likes
Select and mask is still buggy on a lot of systems. Under preferences of Photoshop, under he gpu settings, turn of Opencl. fixes a few select and mask quirks...
Photo of Jeremy Newman

Jeremy Newman

  • 3 Posts
  • 1 Reply Like
Thanks John and Tanja... 
John I am unable to find it in version 2017. Where is it located?
Photo of John Maguire

John Maguire

  • 398 Posts
  • 83 Reply Likes
OK, make your selection as usual. go to the select menu, not the button. Hold shift and click on select and mask. The old refine edge tool will open instead.
Photo of Jeremy Newman

Jeremy Newman

  • 3 Posts
  • 1 Reply Like
That's killer. Thanks so much. 
Photo of John Emmanuel Gipolan

John Emmanuel Gipolan

  • 1 Post
  • 0 Reply Likes
You can just delete the while layer mask in channels. Mine already worked and fixed. 

1.) Use any selection tool, when satisfied with the selection
2.) Open channels tab, "make sure to delete the flat white layer mask located at the bottom of the layers."
3.) Select and mask is up and running again. Not grayed out anymore.
(Edited)
Photo of Tina Carnelli

Tina Carnelli

  • 1 Post
  • 0 Reply Likes

This is the best solution I found.  Thank you, John!!!