Photoshop CC 2015.1.1 delayed response over time

  • 1
  • Problem
  • Updated 3 years ago
I recently upgraded my Photoshop CC 2015 to version 2015.1.1. Besides that annoying tool reset bug upon start (yes, I disabled that start screen, it still happens), my Photoshop is getting worse and worse response time the longer it's opened. I constantly have to restart the program for it to run smoothly again. The lag is noticeable with the polygonal lasso tool or the space bar drag scrolling, which doesn't seem to work at all at some point.
It's getting really really frustrating, having to save your progress and re-open everything to work efficiently again.
Between the last version (2015.1.0?) and 2015.1.1, I don't recall changing anything else in the mean time, so I mostly can exclude any plugins or third party programs being the issue. The only plugin installed is the Nvidia one.

Here are my system specs, in case you worry the PC can't actually handle it:
OS: Windows 10 Pro 64 bit (10.0, Build 10240)
CPU: Intel Core i7-4790 @ 3.60 GHz
RAM: 16 GB
Graphics: Nvidia GeForce GTX 960

Allocated RAM for Photoshop: 13113 MB (90%)
It's installed on the SSD as well

I tried optimizing the performance, but it always ends up like this. I am at my wits end and wish I could revert the upgrade to 1.1 ... has taught me to not update the program (as such major bugs like the tool reset get into the release as well...)

Thanks for your time and sorry for my tone, getting really frustrated here. Hope there's anything that could be done about it.
Photo of Foofaraw

Foofaraw

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 3 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
That could be due to a video driver bug, or a third party plugin or extension panel.