Photoshop CC 2014: Save For Web dialog scaling problems

  • 3
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
Photoshop CC 2014.2 still has UI problems even on the Surface Pro 3 (which was given to everyone at Adobe MAX today). Here's a picture of the "Save for Web" dialog after turning on 200% UI scaling in the Photoshop Experimental Features preference.

See where the "Save", "Cancel", and "Done" buttons are? You can't press them because they're under the task bar. That window is not resizable either.

Note: This topic was created from a reply on the Photoshop: Support scalable user interface UI for high resolution monitors topic.
Photo of Adam

Adam

  • 17 Posts
  • 3 Reply Likes

Posted 5 years ago

  • 3
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 842 Reply Likes
Do the Enter and Escape keys still commit or cancel SaveForWeb?
Photo of Adam

Adam

  • 17 Posts
  • 3 Reply Likes
Yes, the keyboard shortcuts still work, thankfully! Also, using the tab key to move the caret to the buttons will work, but that does not work if I want to access the "Preview in Browser" listing button on the bottom left. That menu is not included in the sequence of button selection when using tab.

Another problem with that work around is that it requires a keyboard! The Surface Pro 3 is a tablet that is not sold with a keyboard (though any can be attached.) The default on-screen keyboard does not have a tab key for navigating buttons that aren't visible on the screen, nor does it have an escape key.

However, I can turn on the "Standard Keyboard layout" option in the PC Settings > PC and Devices > Typing area and that will have tab and Esc keys. (That's what I usually use for typing keyboard shortcuts in PS before it started having a partially tablet-friendly UI).
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 842 Reply Likes
OK, that was just as a temporary workaround.
We'll investigate why the layout isn't working correctly.
Photo of Jeanne Rubbo

Jeanne Rubbo, Employee

  • 125 Posts
  • 27 Reply Likes
Thanks for the report!

What should happen when Photoshop is running in 200% is that it checks to see if there is enough screen real estate to display the 2x version of the Save For Web dialog. If there isn't, the 1x version will display instead. It looks like Photoshop thinks there is enough room to display the 2x version on your screen, even though there isn't.

I'll investigate this on the Surface Pro 3 and log a bug for this and any other problem dialogs.
Photo of Adam

Adam

  • 17 Posts
  • 3 Reply Likes
Thanks! Yeah, it's probably not taking into account the height of the task bar, which is also variable depending on the system's scaling level in the display settings.
Photo of Patrik Rederer

Patrik Rederer

  • 49 Posts
  • 10 Reply Likes
Dear Jeanne,

this problem not only appears on Surface Pro 3. I am using Windows 7 Pro, 64 Bit and see what happens with this menu there:

Photo of Robert Frost

Robert Frost

  • 426 Posts
  • 73 Reply Likes
Put the taskbar on Autohide. Then you can see what is underneath!

Bob frost
Photo of Patrik Rederer

Patrik Rederer

  • 49 Posts
  • 10 Reply Likes
Nice work around :-) It ́s funny that we now start to discuss about workarounds instead of having the right software.
But it ́s a good input anyway. Thank you.
Photo of Jeanne Rubbo

Jeanne Rubbo, Employee

  • 125 Posts
  • 27 Reply Likes
Hi Patrik,

What is your screen resolution?
Photo of Patrik Rederer

Patrik Rederer

  • 49 Posts
  • 10 Reply Likes
Hi,

It ́s: 2560 x 1440
Photo of Ed Sparks

Ed Sparks

  • 5 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled How to Turn Off Tool Tips : Photoshop CC 2014.

Photoshop CC 2014: Pressing ctrl alt shift s

Tool tips pushing buttons down and off the screen when using short cuts. How to turn off the tool tips which are source of the problem. Going file > save for web does not have the tool tip but who is going to do that ?

I need this fixed and out of my hair.

Troubleshot. I changed the res and resized the window: no dice. tech support took preferences out and reload. no dice. I need this out of the popup window so i can go back to dominating the earth.

Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15462 Posts
  • 2292 Reply Likes
We're looking into this issue. You can use [Esc] to dismiss the dialog or [Return/Enter] to accept the dialog.
Photo of ScaryFast

ScaryFast

  • 2 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Save for Web dialog is too tall for Surface Pro 3 tablet with 200% scaled UI.

Adobe Photoshop CC (2014) has some windows that are too large and cannot be resized. This is a problem on my Microsoft Surface Pro 3 with the UI scaled to 200%. The Save for Web dialog is too tall and I cannot actually click the save or cancel buttons at the bottom. I am forced to either rotate the entire tablet (which moves other windows around that I had positioned a certain way), or connect my keyboard so I can tab to the button I want and hit enter. I draw without a keyboard so this is quite annoying.

That window and others that are tall need to be resized or let us resize them (with a scroll bar if things overflow) so they fit properly. Please!!!
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15462 Posts
  • 2292 Reply Likes
Official Response
This should be solved 2015.1 update that was release today: https://blogs.adobe.com/photoshop/201...