Photoshop CC 2014 keyboard shortcuts suddenly stop working on Mac 10.10

  • 2
  • Question
  • Updated 3 years ago
Photoshop CC 2014 keyboard shortcuts suddenly stop working on Mac 10.10.2.
I reboot and they start working again for a short time, then they stop. Any solutions?
Photo of Randy Galligan

Randy Galligan

  • 4 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 2
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14046 Posts
  • 1734 Reply Likes
Is Mouse Keys inadvertently enabled?

Photo of Randy Galligan

Randy Galligan

  • 4 Posts
  • 0 Reply Likes
No, mouse keys is unchecked
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14046 Posts
  • 1734 Reply Likes
Is it all shortcuts? (e.g. single keys for tools, specifically the spacebar, F-keys, multi-key shortcuts for commands)

Is Photoshop and Mac OS X 10.10 up to date? (2014.2.2 and 10.10.2)

Are you running any system extensions? They usually show up here in System Preferences:

Photo of Randy Galligan

Randy Galligan

  • 4 Posts
  • 0 Reply Likes
I notice it most when I go to zoom using command-spacebar. I just get the move tool. Also the hand tool becomes the move tool.

Both PS and Yosemite are up to date.

Here is a screenshot of my system prefs:

Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14004 Posts
  • 1718 Reply Likes
So it sounds like it's primarily the spacebar not working?

Try solution two here: https://helpx.adobe.com/photoshop/kb/...
Photo of Randy Galligan

Randy Galligan

  • 4 Posts
  • 0 Reply Likes
Will do.
Thanks!
Photo of Matt Lloyd

Matt Lloyd

  • 3 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Intermittent Shortcut Failure.

Hi there, forgive me if this issue has already been raised but I did search and haven't been able to find anything.

Im running OS X 10.10.2 on:

MacBook Pro (Retina, 15-inch, Late 2013)
2 GHz Intel Core i7
16 GB 1600 MHz DDR3
Intel Iris Pro 1536 MB

I have (according to my CC account) the most up to date version of Photoshop CC 2014

and I'm using a Wacom Intuos 4 with the most up to date drivers.

I have uninstalled my older version of Photoshop CC.

My problem is that when I use shortcut keys (usually swapping between brush and eraser with 'B' and 'E') they intermittently do not work. Sometimes they work as expected but more often than not nothing happens. What I have noticed, which I find very unusual, is that if I hold down the key sometimes after a few seconds the tool will change (but also sometimes it won't!).

My keyboard works perfectly in all other software and even when inputting type into photoshop fields/using the text tool.

I would really appreciate a swift solution as this is massively slowing down my workflow and becoming very frustrating.
Photo of David

David, Official Rep

  • 2716 Posts
  • 373 Reply Likes
Hi Matt,

My gut reaction would be to ask you to try again with your Intuos completely disabled and disconnected.  I'm fairly certain that you'll find the problem gone.  We've heard many reports of the tablet hijacking keyboard input.

I'm not suggesting this as a "solution" but rather as a way to definitively narrow down the troubleshooting process.  I'm also available for a web-hosted screenshare if that'd be helpful.

Thanks,
David
Photo of Matt Lloyd

Matt Lloyd

  • 3 Posts
  • 0 Reply Likes
Thanks David, that sounds like it could be helpful.

I've tried with the Wacom completely disconnected and the problem persists.

One thing I've discovered is that I can sort of force the problem to occur by interacting with the 'Libraries' window, however, closing the window/not interacting with it doesn't seem to solve it.

How would we go about doing a screenshare?
Photo of David

David, Official Rep

  • 2701 Posts
  • 371 Reply Likes
Howdy Matt,

Are you free after 4pm today?  I have a
meeting until then.  I’ll follow up with an email to start the ball rolling...

If today doesn’t work, I should be free a good chunk of tomorrow
as well.

Thanks,
David