Photoshop CC 2014: Must hit Cmd-H TWICE to work on MacOS 10.10 Yosemite

  • 4
  • Problem
  • Updated 5 years ago
  • Solved
  • (Edited)
Photoshop CC 2014 Bug: Must hit Cmd-H TWICE to work.
Make a selection, Cmd-H to hide it. Click off and make a NEW selection. Cmd-H to hide it again and it will NOT hide it, but you have to hit Cmd-H twice to hide it. You'll see the "View" menu light up when you hit it the first time (as though it's turning the "Extras" on and then you have to hit Cmd-H again for it to actually work. This is a HUGE stall when you are working... a real downer when using key strokes as much as I do. ;-) I worked with "Sritama" through tech support so she could finally see what it was doing and it does it on both her PC and Mac Yosemite.
Photo of Sarah Prye

Sarah Prye

  • 4 Posts
  • 2 Reply Likes
  • frustrated

Posted 5 years ago

  • 4
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16849 Posts
  • 2819 Reply Likes
Thanks. I'll have the team look into it.
Photo of Carlos Oliveras

Carlos Oliveras

  • 149 Posts
  • 40 Reply Likes
Same here, still, it's not a new problem for me. For some reason, the Ctrl+H shortcut (I'm using Windows) sometimes works as it should (you press it, and it works), but most of the times I have to hit it twice. I've been experiencing this issue for so long that I've almost grown used to it, but tonight it's annoying me so much that I googled for it and I ended up here.

I'm on Windows 8.1 using PS CC 2014 latest version (2014.2.2).
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 859 Reply Likes
This topic is about an issue on MacOS 10.10, not Windows.
Photo of Sarah Prye

Sarah Prye

  • 4 Posts
  • 2 Reply Likes
Actually, it was confirmed by tech support "Sritama" that it did happen on both her Mac and Windows systems at Adobe. And Carlos is saying he's Windows and it's happening to him, as well. So yes, apparently both.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 859 Reply Likes
Um, no, it doesn't happen on most systems.
So far I can't reproduce this at all, on any system.
Photo of Sarah Prye

Sarah Prye

  • 4 Posts
  • 2 Reply Likes
I didn't say "most".
I said both. That it was been confirmed by Adobe tech support (who I spent about an hour with) that, yes, it did the same thing on "both" her windows machine and mac yosemite. I don't know what she was running... was so overjoyed that she was able to reproduce it that I forgot to ask.
Photo of Carlos Oliveras

Carlos Oliveras

  • 149 Posts
  • 40 Reply Likes
Chris Cox: Yes I see this topic is about Mac, so I stated I'm using Windows. And since sometimes Adobe staff merge topics dealing with the same issue in different threads, I thought it was the right thing to do to post here.

My apologies if that was the wrong thing to do. I would open a separate thread for the same issue under Windows, but since you say you're unable to reproduce the issue, I don't know it it's worth it, so I guess I won't for now.

Thanks for answering and checking both on Win and Mac.
Photo of David

David, Official Rep

  • 3568 Posts
  • 607 Reply Likes
Hiya Carlos,

Hey, what other devices are you using on your Windows machine?  Non-standard mouse?  Tablet?  

Are you running any apps that might co-opt keyboard commands (this is actually WAAAY more common than you might think!)?  What language is your keyboard set to?

I'm happy to help you out; these questions can help point us in the right direction.

Thanks,
David
Photo of Carlos Oliveras

Carlos Oliveras

  • 149 Posts
  • 40 Reply Likes
David: Sorry I did not reply earlier, I don't know how to get notifications from this.

I am not sure what accounts for a non standard mouse, but mine is a Logitech G9X. My keyboard is a Logitech G19. And I use a Wacom Intuos Pro tablet.

My keyboard is an spanish keyboard set to spanish.

I can't think of any running apps that could interfere with ctrl+h - I try to keep running apps to a minimum and remove garbage from start-up.

Anyway, not a huge problem for me (I've gone through much worse). Thanks for your interest.
Photo of David

David, Official Rep

  • 3568 Posts
  • 607 Reply Likes
Hiya Sarah,

I know I'm chiming in late to this conversation, but I've been on vacation.

I'm doing the following steps:

1) launch PS (latest version)
2) click File > New and choose US Paper Size > Ok
3) activate the Lasso tool (L) and make some selection
4) press CMD (Mac) / CNTRL (Win) + H

On Windows, I see ABSOLUTELY no problem.  Only press makes the selection disappear and another press brings it back.

On Mac, the first time I get this dialog, and if I choose Hide Extras, then Mac behaves exactly like Windows.


If you've already dismissed this dialog, you can again gain access to it by trashing your preferences file (hold down CMD+SHIFT+OPT while launching PS) and the next time you try CMD+H, you'll be presented with the dialog again.

Please let me know if this doesn't solve your problem.

Thanks,
David
Photo of Brandon Chandler

Brandon Chandler

  • 1 Post
  • 0 Reply Likes
Hi David,

Even after resetting the preferences and insuring that dialog is set to "Hide Extras" (per your instructions above), I'm still frequently experiencing the issue of having to press Command-H twice, thought it doesn't happen every time. As far as I'm aware, I have no other apps installed that affect keyboard input.

Thanks,
Brandon
Photo of David

David, Official Rep

  • 3568 Posts
  • 607 Reply Likes
Howdy Brandon,

I looked at this at length yesterday and today. Running a clean install of the latest version of Photoshop on Mac 10.10.2 I cannot reproduce the problem at all. I've tried having multiple docs open, different kinds, different kinds of extras.

So, this makes me immediately question if you have some other utility or device that's co-opting the keyboard input. Do you have a tablet connected? What kind of keyboard are you running?

Also, if you're willing, I'd be happy to schedule a web-hosted screenshare. If this is a software issue, I should be able to trigger it via remote-controlling your machine that way. All you need is an internet connection and a phone -- the call is toll free for most countries.

Thanks,
David
Photo of robert patterson

robert patterson

  • 1 Post
  • 0 Reply Likes
Same issue here. With or without tablet. Running macbook pro 10.9.5
Small problem but gets super frustrating after the billionth time...
Photo of heysluggo

heysluggo

  • 1 Post
  • 0 Reply Likes
Same problem here. OS X 10.10.2, Photoshop CC. Always have to hit command-H twice for it to work.
Photo of David

David, Official Rep

  • 3568 Posts
  • 607 Reply Likes
We are now aware of the problem and working on a solution.  Hopefully, we'll know more soon.

Thanks,
David
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16849 Posts
  • 2819 Reply Likes
Official Response
This should be fixed in the Photoshop CC (2015) update.