Photoshop: Can't repeat Liquify (cmd+F) on multiple layers since the new update

  • 6
  • Problem
  • Updated 2 months ago
  • Acknowledged
Since the update I haven't been able to use Liquify as fluently in my line of work as before. The thing is that when I use Liquify on an image I also have to reload it on the mask and several other layers linked to that image. But now when I do so, those layers doesn't respond to "the last used filter (cmd+F)" as they did before.

It do affect the layers but the changes just go half the way. I hope someone understands my problem and that there's a solution to this. At this point I've tried to reset preferences and of course some other things like restarting computer..
Photo of Joakim Sommar

Joakim Sommar

  • 7 Posts
  • 0 Reply Likes
  • frustrated

Posted 7 months ago

  • 6
Photo of Aurica Crudu

Aurica Crudu

  • 32 Posts
  • 7 Reply Likes
In photshop 2017 last version for sure for repeat last filter was shortcut Ctrl+Alt+F. Try this. But press Ctrl first, after Alt and F. (alt works buggy for now)
Photo of Joakim Sommar

Joakim Sommar

  • 7 Posts
  • 0 Reply Likes
Thanks, but it's not the shortcut that's my issue. I can see on the filter tab that the shortcut is still Cmd+F (using a mac).

I'm still having problems with repeating Liquify on other layers, and with the new update I mean 2018 CC.
Photo of Charles Cronley

Charles Cronley

  • 14 Posts
  • 3 Reply Likes
It is worse than that for me, in addition to repeat last filter not working AND load last mesh within the filter not working, saving liquify meshes does not actually save the mesh. Back to Ps 2017 for me too.
Photo of Pete Green

Pete Green, Customer Advocate

  • 687 Posts
  • 115 Reply Likes
Repeat last filter does not seem to be working for me as well, we will investigate this further.

The default keyboard command for repeat last filter is as Aurica mentioned, now CMD+Option+F, since CMD+F brings up the inapp search.

Regarding the other issues, meshes seem to be saving for me as well as load last mesh, what happened when you tried to save a mesh or load last mesh?
Photo of Joakim Sommar

Joakim Sommar

  • 7 Posts
  • 0 Reply Likes
I just reinstalled 2017 and it works fine and I'll keep using 2017 until this is fixed. Hopefully Adobe can find a solution for this in the near future, because I do enjoy the new features in 2018 CC.
Photo of Cy

Cy

  • 4 Posts
  • 3 Reply Likes
Yes I have the same issue too, it's liquefying based on layer content size regardless your selection area(Select whole canvas). That means saving liquified mesh are basically useless for anything but that specific layer only. 
The problem here we're no longer able to apply liquify to multiple layers without merging them together.
Photo of Charles Cronley

Charles Cronley

  • 14 Posts
  • 3 Reply Likes
I see how some of that is true, but save mesh actually saves no mesh at all. And a duplicate layer of the same size will not get liquified if you go into the dialog and click load last mesh. Even the same layer will not get liquified if you go into the dialog and click load last mesh. It does work on the same layer if cmd-f is used and I do see how cmd-f will apply the last mesh to the whole image/layer incorrectly proportioned.

The whole thing is basically jacked. Can't wait for the inevitable Mea Culpa CC 19.0.1!
(Edited)
Photo of Antonio León

Antonio León

  • 4 Posts
  • 0 Reply Likes
This is precisely the issue. Applying the filter based on the layer contents boundary is not crazy per-se, but is inconsistent with the previous versions behaviour.

An obvious advantage of the old method is that it allowed to apply the very same liquify filter to several layers using Ctrl+F.  In version 19.0 this functionality was lost.
Photo of Pete Green

Pete Green, Customer Advocate

  • 699 Posts
  • 126 Reply Likes
Sorry for the liquify issues several of you are seeing. Curious which operating systems you're using?
Would anybody be able to record a video showing this issue as they see it?

Thanks!
Pete
Photo of Joakim Sommar

Joakim Sommar

  • 7 Posts
  • 0 Reply Likes


Okay so this video shows my problem with Liquify and how repeat last filter doesn't affect the "retouch" layer. I've also tried the other thing "CMD+OPT+CTRL+F" and it did nothing, or perhaps it was just another shortcut for doing the same thing as CMD+F. 

Note: the image is just randomly selected from Unsplash (https://unsplash.com/photos/tyJPvPBD89U)

Edit: I'm on macOS Sierra 10.12.26
MacBook Pro (Retina, 15-inch, Mid 2015)
Processor: 2,5 GHz Intel Core i7
Memory: 16 GB 1600 MHz DDR3
Graphics: AMD Radeon R9 M370X 2048 MB
Intel Iris Pro 1536 MB
(Edited)
Photo of Pete Green

Pete Green, Customer Advocate

  • 699 Posts
  • 126 Reply Likes
Thanks Joakim, It looked like even after you used the menu item for Filter > Repeat Liquify it still didn't do anything, is that correct?
Is the command repeat not working at all for you? Menu command nor Keyboart shortcut?

Regards
Pete
Photo of Joakim Sommar

Joakim Sommar

  • 7 Posts
  • 0 Reply Likes
That's correct. Yeah, neither works. Or, actually it do work on for example layers whereas only brush has been used, but as some others have mentioned here the Liquify doesn't resize correctly.

Somehow it doesn't affect my layer where I've only used clone stamp/healing brush, but when I've used normal brush it works but not all the way.
(Edited)
Photo of Antonio León

Antonio León

  • 4 Posts
  • 0 Reply Likes
Problem is completely solved, at least for me, on 19.0.1
Photo of Pete Green

Pete Green, Customer Advocate

  • 699 Posts
  • 126 Reply Likes
Another thing to test as well -- Does CMD+OPT+CTRL+F work?
Photo of Charles Cronley

Charles Cronley

  • 14 Posts
  • 3 Reply Likes
Ok. I tried to screencap, but by messing around in photoshop, I somehow triggered saving meshes back to working. Still have the issue of it resizing the mesh warp to the layer. Also, CMD-F started working, albeit still resizing the mesh. CMD+OPT+CTRL+F did nothing. I hope I can trigger liquify mesh saving correctly on my work computer. A workaround, and a not very good one, is to add a one pixel stroke to every layer if you want to repeat a liquify on different sized layers.
Photo of Charles Cronley

Charles Cronley

  • 14 Posts
  • 3 Reply Likes
I am on Mac OS 10.12.6. I managed to cut down a rambling screencapture from before I was able to save meshes. It shows me doing a warp, saving the mesh, loading last mesh to reset, then loading saved mesh and no mesh loaded.
Photo of Pete Green

Pete Green, Customer Advocate

  • 687 Posts
  • 115 Reply Likes
Hi Charles, 

Thanks for providing the video, it is very helpful in our investigations of this. 

Does it help at all if you reset the liquify preferences?
Try moving these two files to your desktop.

<username>/Library/Application Support/Preferences/Adobe Photoshop CC 2018 Settings/Liquify Last Mesh.psp
(deleting this file removes any meshes the user has done and they will have to recreate them)

<username>/Library/Application Support/Preferences/Adobe Photoshop CC 2018 Settings/Liquify Prefs.psp
(deleting this resets all the tool options to factory settings)

Regards
Pete
Photo of Charles Cronley

Charles Cronley

  • 14 Posts
  • 3 Reply Likes
Whatever accidental"fix" that previously gave me some of the functionality is gone. I tried them all, cmd-f, pull down the filter menu, go back to liquify and click on load last mesh, even saving a mesh and then loading saved mesh was not working.

Then I trashed the two prefs you suggested and... nothing happened either.

Sorry, it was a bust.
(Edited)
Photo of Carlos Correia

Carlos Correia

  • 3 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled "Load Last Mesh" in Liquify issues CC2018.

When I use "Load Last Mesh" in Liquify on CC2018, the result is not correct. The first time I use the command it works, but when I use this again, it results in something bizarre. Has anyone had this problem or do you know how to resolve this issue?
Photo of Dan Riley

Dan Riley

  • 1 Post
  • 0 Reply Likes
This is still a huge problem. Can someone at adobe please fix this or revert update to when it was working? This is a huge pain in the butt. It basically forces you to merge everything then liquify which is a nightmare as that's not what you want to to do in many situations. 
(Edited)
Photo of Joakim Sommar

Joakim Sommar

  • 7 Posts
  • 0 Reply Likes
I suggest you download CC2017's version as well to avoid further rage eruptions – or that's what I've done. I'm using both, mostly CC2017 because I need to use liquify daily though.