Photoshop bug: wrong shortcuts (after installation)

  • 1
  • Problem
  • Updated 9 months ago
Hello,

after several hours of chatting with the Adobe support in Germany, I decided to report this as a bug. Even via remote control they couldn't fix my problem...

Problem/bug
The shortcuts in Photoshop are not the ones they should be!

Here is a link where you can see the official default Photoshop shortcuts for the German version:
https://helpx.adobe.com/at/photoshop/using/default-keyboard-shortcuts.html

Next you can see two screenshots with the shortcuts that Photoshop uses without any changes on my side. I installed the program and that is what they look like. As you can see in this example the first, third and fourth shortcut are wrong. Some others like the second are correct.

iMac (2017)



Windows 10 PC



What I did before

My system is the iMac from the first screenshot. My system was originally set to English and I installed Photoshop in English, too. Furthermore I am using a German keyboard.
But since the shortcuts are not based on the keyboard, but on the Photoshop language, I uninstalled the English version and installed the German one.


What I tried so far

1) I set my system language to German.
2) I tried different keyboard languages.
3) I removed everything, used the official Adobe cleaning tool for the creative cloud apps before installing them again.
4) Setting the the shortcuts to an old version in the window of the screenshot above. It had no effect at all.
4) I uninstalled Chrome and disabled Siri for now, because I read about problems.

After every step I uninstalled Photoshop and installed it again. The only thing that had an effect on the default shortcuts was changing the language of Photoshop itself in the creative cloud app before installing it again.


Additional information

1) I looked into the "Default Keyboard Shortcuts.kys". They matched the ones in Photoshop.
2) The wrong shortcuts work.
3) I am not using a Wacom tablet or display by now. But I will.
4) I just installed Photoshop on two completely different Windows 10 PCs for reference. Different hardware and different language. Sadly I have no second Mac system for testing. The shortcuts on both Windows 10 systems seemed identical, but were both not matching the official list.


My current system

Keyboard language: German 
System language: German

Keyboard: extended version, incl. the number pad

OS: macOS Sierra 10.12.6
CPU: 3,4 GHz Intel Core i5
RAM: 16 GB 2400 MHz DDR4
GPU: Radeon Pro 560 4096 MB
Photo of Samira

Samira

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 10 months ago

  • 1
Photo of Alan Harper

Alan Harper

  • 404 Posts
  • 78 Reply Likes
Hi

I am having a similar problem in Lightroom. I haven't figured it out yet, but my next step will be to make a new user account, and see if the problem is still seen there.

There are so many ways to change your shortcuts on Macintosh, and such anarchy in the ways that they work, that it is very easy to make a change and forget that (and how) you have done it.

My advice is to check this out with a new user account. If the behavior continues, point it out here and hopefully Adobe staff will look into it with renewed vigor.

A
Photo of Samira

Samira

  • 2 Posts
  • 0 Reply Likes
Hello,

I just bought my iMac. So there is no big history of changes. I only tried a few things "after" the problem appeared, like using the f-keys as normal f-keys, with no effect at all. So I set everything back to default.

During this week I had the opportunity to use a Windows PC with a completely different Adobe account. The shortcuts were identical to those above!

By the way Adobe support already agreed that this is indeed a bug that needs to be fixed. So I really hope that some developer will read this. Sadly there is no direct way to report a bug...

Kind regards,
Samira