Photoshop - I can't change the font

  • 2
  • Problem
  • Updated 10 months ago
  • (Edited)
Screencast here: https://youtu.be/YzBG4C_AwKo
CC 2015.0.1
Photo of Jaroslav Bereza

Jaroslav Bereza

  • 763 Posts
  • 150 Reply Likes
  • sad

Posted 3 years ago

  • 2
Photo of David

David, Official Rep

  • 2701 Posts
  • 361 Reply Likes
Howdy Jaroslav,

What you're running into is font substitution.  The string of text that you have selected contains one or more glyphs/symbols that do not appear in the font that you've chosen, so Photoshop automatically swaps the font for another that DOES have those missing glyphs/symbols in order to avoid displaying "tofu" or missing glyph icons.  Whenever you have an indeterminant state, Photoshop will present you with a blank field to indicate that to you, which is what you're seeing.  If you were to select individual letters, you'd see that they have the font you've set, except those which are not found in that font.

If you don't want automatic font substitution, you can turn it off by clicking (Windows) Edit > Preferences > Type or (Mac) Photoshop > Preferences > Type and then uncheck Enable Missing Glyph Protection on the upper left of the dialog.

Hope that helps.  Please feel free to ping me back if you have questions or comments on this feature.

Thanks,
David
Photo of Jaroslav Bereza

Jaroslav Bereza

  • 763 Posts
  • 150 Reply Likes
Thanks for answer. I know font substitution. But there was something wrong.

As you can see. I am trying to choose "Exo Regular Italic". Despite the name of the font that did not work, but over the selection of the style in a field beside it works without problems. I'm pretty sure the font can all characters that I need. Indeed, at the end of the video it is visible.
Photo of David

David, Official Rep

  • 2701 Posts
  • 361 Reply Likes
You can test this easily enough by removing the glyphs that are uncommon -- the accented ones found in Latin B -- and then trying again.  Or, use a Pro font, which would contain the full range of glyphs.  Or use the Glyph Panel to verify that the glyph is part of the font.

Hope that helps,
David
Photo of Martin Lombana

Martin Lombana

  • 23 Posts
  • 3 Reply Likes
I am having this problem as well.
Latest version.
THIS IS A BUG. Very annoying one.

More and more photoshop is becoming UNUSABLE. And Adobe is really slow for fixing things. But they never forget to charge me at the start of the month for my subscription.

Someone from adobe looking into this?
Photo of David

David, Official Rep

  • 2494 Posts
  • 308 Reply Likes
Hi Martin,

What exactly is happening?  Jaroslav is describing a problem involving characters from other languages.  I suspect that what he encountered (which is a feature, actually) is different.

When you try to set the font of existing text to one which does not contain all the characters you've typed, we automatically substitute for you the individual, missing glyphs using a similar font.  And because you now have more than one font applied in the run of text, we blank the name to communicate this information to you.

So, what are you seeing?  If you select a single letter, does the problem go away?  If you arrow through the string of text, does the font change?  If yes to both, then that's not at all a bug -- it's the feature Font Substitution, which you can turn off by clicking (Windows) Edit > Preferences > Type or (Mac) Photoshop > Preferences > Type and then uncheck Enable Missing Glyph Protection on the upper left of the dialog.

If you're seeing something else, then let's talk.

Thanks,
David
Photo of Martin Lombana

Martin Lombana

  • 23 Posts
  • 3 Reply Likes
This is the main problem. If you have characters that are not in the font that you are selecting, it should be the designer's problem to check it. Photoshop should apply the font that I am telling him to apply, regardless of the result. There are a lot of situations where there are glyphs or other caracters that are not even visible to start with in the text that you pasted (because no font can render them), and then you have to go checking every single space in your text to see if there is something (like a reference to a web icon) that should not be there).
The way this works, for applying the font, is very intrussive and it does not worrespond to good UI.

Photoshop should just apply the font that you are selecting, regardless of the result. And, to complete my argument... every time this happens, the font that gets selected is Myriad Pro (at least on windows). And there is no indication whatsoever to the user that there may be some glyphs missing etc.

Please, reuse the popup that tells me everytime that I can not select something out the canvas (ahem!) and put an indication on what is happening here. Or a "toaster", or something non-intrussive. You can not expect that we discover that photoshop is applying the font of his choosing because there are some glyphs he can not render using the font that we want.

This, as I said, is UX 101. Put an advice, but let the user select whatever he wants at his own risk. This, among other 20 bugs in Photoshop that are already reported since a long time ago, is driving people away from your software. And I love photoshop, but please, CS4 worked 10 times better. And I regret purchasing the new CC, for this. I thought that there would be constant updates, but there are none. And people are getting angry. Which is natural.

Thanks,
Photo of David

David, Official Rep

  • 2494 Posts
  • 308 Reply Likes
Hi Martin,

Well, as I've mentioned in this thread twice, you can disable this feature simply by changing the preference.  It's on by default because many users ASKED for it.

While you may not appreciate this feature, it's a huge life-saver for others.  Photoshop supports MANY MANY workflows and further accommodates users by being customizable.  On person's garbage is another's treasure.

If you have other bugs, you should report them on this forum.  A number of us read it every day.  We do have a few long-standing issues, but most have a solution...

Thanks,
David
Photo of Martin Lombana

Martin Lombana

  • 23 Posts
  • 3 Reply Likes
I apologize.

I totally missed the part when you explain it because I was focused on the second reply of this comment.

I am a bit frustrated by other UX problems (that have no solution as of now...).

So again, I totally missed something and, therefore, my comment was totally wrong. Sorry about it.

I disabled it, as you said, and it seems to work for me this way.

Only, the thing I would suggest is that you add, when this happens for the first time, a dialog telling you that this is happening this way for that reason, and telling you how to disable it... It never poped out for me and I've been retyping text sometimes without knowing why I had to do that...

Thanks,
Martín.
Photo of Jaroslav Bereza

Jaroslav Bereza

  • 763 Posts
  • 150 Reply Likes
Still Issue no matter if missing glyph protection is enabled.
This bug appers in these conditions
1) text has two or more font-weights
2) no matter if text has special characters
3) target font is Open Sans Regular (one from most heavily used fonts worldwide)
4) no matter which font is before font change
Photo of David

David, Official Rep

  • 2701 Posts
  • 361 Reply Likes
I can't repro this, Jaroslav.  Do you get this with all files?  Could you send me a sample file with this problem?  My email is David dot Mohr at Adobe dot Com.

Thanks,
David
Photo of Jaroslav Bereza

Jaroslav Bereza

  • 763 Posts
  • 150 Reply Likes
Is missing glyph protection bundled with a document and permanently stored and can not be changed? I can't repro in new document with this feature off. But I am sure that I sometimes see this issue and I have this feature off. Maybe because is it stored in document?

Most strange thing is that Open Sans has all glyphs which I am using.
Photo of Kelly Rose

Kelly Rose

  • 1 Post
  • 0 Reply Likes
I have a similar issue. I find the font I want, click it and then it defaults back to whatever the original font was. I have found one (really annoying) way around it. I type the font I want – EXACTLY LIKE IT APPEARS IN THE LIST – every single letter and that seems to work. It's really tedious, but I don't know what else to do.
Photo of David

David, Official Rep

  • 2682 Posts
  • 359 Reply Likes
Hi Kelly,

If the font is changing, then missing glyph protection is probably involved.  The way this feature works, if you type in some glyphs that do not exist in the font you've selected, then Photoshop automatically switches the font to one with the glyphs so you do not have missing glyphs or boxes or other bogus entries.  You can turn this feature off by going to Preferences > Type and unchecking the Enable Missing Glyph Protection box (2nd from the top on the left).

Now, just to explain why this feature is there.  Let's say that you were doing working in Japanese and English or Arabic and French or whatever.  If you change the font of the text run, it's quite possible that the font you choose will NOT be able to correctly display both languages and (historically) many users were confused with this.  So we added this feature to make sure things run smoothly.  Another way to check for glyph substitution would be to select the run of text and look in the Options Bar.  If the font name is blank, then there are more than one font face there, probably due to substitution.

Make sense?

Please let me know if you need further help.

Thanks,
David
(Edited)