Photoshop: adjustment layer not affecting layer effect

  • 1
  • Question
  • Updated 3 years ago
hello,

i am experiencing strange behaviour when using clipping mask adjustment layer over a layer with effect (bevel as example). and i'm almost sure in previous versions wasn't like that.

i'm attaching two images explaining the problem.

basicaly i want to partialy darken an object with bevel on it. i want tu use a curves layer clipped with the object layer. in this case the adjustment layer is affecting only the object but not the bevel effect. i want to achieve the result of the non clipped version.

maybe i'm missing something?

thanks for any advise.

Photo of laden m

laden m

  • 168 Posts
  • 17 Reply Likes

Posted 3 years ago

  • 1
Photo of Jaroslav Bereza

Jaroslav Bereza

  • 779 Posts
  • 166 Reply Likes
This is what's really going on. The effect is above the clipping mask layer.



This workaround can solve the problem:
Photo of laden m

laden m

  • 168 Posts
  • 17 Reply Likes
thanks jaroslav,

actually the work around works!

i have a bunch of layers in the group and the layer effect is on the group itself, but when i put everything in another group and clip the adjustment layer with the second group it works.

thanks again!
Photo of laden m

laden m

  • 168 Posts
  • 17 Reply Likes
still it;s strange why it's not working straight on the object and group.
i'm almost sure it worked before?

there should be a blending option for that.
Photo of Jaroslav Bereza

Jaroslav Bereza

  • 779 Posts
  • 166 Reply Likes
It's weird. But sometimes there are cases where this strange behavior might be good. But without the workaround it would be better.