Photoshop: Acting all weird these days

  • 2
  • Problem
  • Updated 3 weeks ago
  • Solved
  • (Edited)
Since the update to PS CC 20.0.1, there is a lot of weird things happening that I haven't. experienced before. Its like my computer is having huge problems with certain tasks that was no problem before. I also have this green outline around all my tools. The other image under is spots that appeared after using liquify-tool. They are embedded in the smart-filter.

When drawing on a mask layer, the adjustment layer sometimes become invisible so its impossible to draw because I don't see the effect.

I'm on a macbook pro 2015 running mac os 10.14.2



 
Photo of St.James

St.James

  • 3 Posts
  • 1 Reply Like

Posted 3 weeks ago

  • 2
Photo of christoph pfaffenbichler

christoph pfaffenbichler, Champion

  • 1239 Posts
  • 180 Reply Likes
Concerning: 
The other image under is spots that appeared after using liquify-tool. 
please check out the work-around presented here: 
https://feedback.photoshop.com/photoshop_family/topics/liquify-tool-black-pixels-after-mojave-os

When drawing on a mask layer, the adjustment layer sometimes become invisible so its impossible to draw because I don't see the effect.
Does checking 
Photoshop > Preferences > Performance > Legacy Compositing
and restarting Photoshop have an effect on this? 
Photo of St.James

St.James

  • 3 Posts
  • 1 Reply Like
This fixed all my problems! Thanks, you are truely a champion.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15025 Posts
  • 2099 Reply Likes
I've never seen the green toolbar thing happening. Is that also working correctly for you now?
Photo of St.James

St.James

  • 3 Posts
  • 1 Reply Like
Its working correctly. I tried to re-check Legacy Compositing and restarting PS just for test, but the toolbar is still fine now.
Photo of Julie Stiltner

Julie Stiltner

  • 31 Posts
  • 6 Reply Likes
I have a lot of problems since the update as well.  I have the same problem you do with the mask.  I can't see what I am doing, it is as though nothing is happening.  Also when trying to select a subject with edit/select/subject it keeps telling me "not enough memory"  when I know there is.   
Photo of christoph pfaffenbichler

christoph pfaffenbichler, Champion

  • 1239 Posts
  • 180 Reply Likes
Have you checked Photoshop > Preferences > Performance > Legacy Compositing and restarted Photoshop yet? 
Photo of Julie Stiltner

Julie Stiltner

  • 31 Posts
  • 6 Reply Likes
Yes, I saw your comment and did that. It fixed the mask issue, but not the memory issue
Photo of christoph pfaffenbichler

christoph pfaffenbichler, Champion

  • 1239 Posts
  • 180 Reply Likes

What have you done for trouble-shooting so far? 

Restoring Preferences after making sure all customized presets like Actions, Patterns, Brushes etc. have been saved might be a good starting point:

https://helpx.adobe.com/photoshop/kb/basic-trouble-shooting-steps.html

And what have you done about Photoshop-performance in particular? 
https://helpx.adobe.com/photoshop/kb/optimize-photoshop-cc-performance.html