Photoshop "accidental" flattening

  • 1
  • Idea
  • Updated 3 months ago
After all the updates and new versions of the Adobe Suite, I am still very disappointed that shortcuts and functionalities have not bee streamlined between applications - specifically Photoshop, Illustrator and InDesign. I often use the Command-E shortcut is export files in InDesign but that same shortcut is used to toggle between preview style in Illustrator, and most concerningly, this shortcut FLATTENS PSDs in Photoshop. So when by automatic memory I clicked on Command-E in Photoshop, it flattened the PSD and I've just lost a days worth of work because I didn't realize what had happened until much later. 

Adobe, if you can't figure out a way to standardize your apps, then add additional warning pop-ups for such crucial actions like flattening a PSD. I've read about SO many people having this same issue and nothing has been done about it. 

FIX IT. 
Photo of Maya Voss

Maya Voss

  • 3 Posts
  • 0 Reply Likes
  • Frustrated

Posted 3 months ago

  • 1
Photo of Erik Heyninck

Erik Heyninck

  • 8 Posts
  • 5 Reply Likes
Cmd-E merges layers in Photoshop. You can remove this easily

Cmd-Opt-Shift K to open the shortcut settings

chose Application Menuus > Layer
scroll down and at the bottom you find this merge layers and its shortcut. select the shortcut and delete it

Now go to File Menu, scroll to export, choose Export as, click add shortcut and enter your Cmd-E

===================================

I understand your frustration, but I guess that changing shortcuts to match other software is always a problem for many long-time users.
 Let's be happy it can easily be changed.
Photo of Maya Voss

Maya Voss

  • 3 Posts
  • 0 Reply Likes
Thats the best solution I've found so far on the net. Very helpful!
Still, Adobe should have these things sorted right out of the box. 
Thanks Erik :)
Photo of Jaroslav Bereza

Jaroslav Bereza

  • 761 Posts
  • 149 Reply Likes
I don't want new popup messages. There already is too much warning dialog. I always must check never show again if an option is present. This happens when I don't have PS with my settings.
Photo of Maya Voss

Maya Voss

  • 3 Posts
  • 0 Reply Likes
The warning dialogue would be necessary if Adobe doesn't make changes to streamline all the apps. If that shortcut does not affect you, then selecting "never show again" once is not a huge deal but it could save hours of work for some. 
Photo of Brett Mead

Brett Mead

  • 1 Post
  • 0 Reply Likes
I am also having a similar issue with Photoshop CS4. Doing a 'Save As' pdf, once I close the file then reopen, the file is flat. Can't see any changes I would have made to preferences, but have recently upgraded to High Sierra OS. Anyone know how to change the preference back to not flattening?