Photoshop 2019: Problem rendering images with 3DLUTs

  • 2
  • Problem
  • Updated 9 months ago
  • (Edited)
Since the update some of the 3DLUTs are just black.
- Soft_warming.look
- fallColors.look
-Crisp-Winter.look
- Bleach Bypass.look
- 2Strip.look
- 3Strip.look

After the first time I saw this, a restart of PS helped, but know they don't want to work.

OSX Sierra, MacPro late 2013
Photo of Armin Staudt

Armin Staudt

  • 60 Posts
  • 28 Reply Likes

Posted 12 months ago

  • 2
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15640 Posts
  • 2373 Reply Likes
If you go to Performance > Performance... and check "Legacy Composting" - restart Photoshop - and try again, do your LUTs work?
Photo of Armin Staudt

Armin Staudt

  • 60 Posts
  • 28 Reply Likes
hm, funny thing. Legacy Compositing on or off doesn't help. But I played with Performance: Cache Steps and Cache Tiles. After a restart it works again and now it works also with my old preferences. I can't explain it to myself. Also sometimes the pallets doe's not react to clicks and so on. There is something wrong, but sometimes and sometimes not.

    (Edited)
    Photo of Armin Staudt

    Armin Staudt

    • 60 Posts
    • 28 Reply Likes
    OK, after a few minutes and work the same as before. I switched back to PS 2018, there are to many bugs in 2019. First time I do so since 1992 :)
    Photo of Armin Staudt

    Armin Staudt

    • 60 Posts
    • 28 Reply Likes
    I think I found a hint what the problem is.
    The bug with black lut's appears if you change something in the preset-folder 3dLUTs.
    i.e you want to clear you PS-LUT-Popup of useless lut's, jut make a new folder in your preset-3dLUTs folder starting with "~" (tilde) and move there the luts you don't want to see anymore. If you sometimes decide to see them again just move them back. Now the bug starts. If you open the next time PS with i.e an tiff file all luts with the ending ".look" are just black (ecxept cripswarm.look)
    But if just first open PS with an RAW or DNG file it works also for later opened tiff files.
    So I have to open now PS all the time first with an DNG file and then I can open tiff-files and using color look ups.
    I think it has something to to with opening the raw-converter in the background. Don#t know...