Photoshop 2017.1.1: Corrupting images & layers

  • 3
  • Problem
  • Updated 10 months ago
  • (Edited)
Photoshop CC 2017.1.1 has started to corrupt my images / layers. I don't believe this is an isolated incident as others seem to having the same issue in cc 2018 - https://forums.adobe.com/thread/2403593

This is the second time it's happened now.


I'm using an iMac running Sierra. The files I'm working on are all stored locally, are not being shared to any sort of cloud service and I have background save enabled.

The most recent incident happened when I was using the Gaussian blur filter on a smart object (the first time seemed to happen when I was saving the document). At first when I zoomed out it would show the image was fine, but when you zoomed into it 100% it looked corrupted. I then saw on the forum post (in the link above) someone mentioned turning the GPU off, I did this, closed the file and when I opened it again, it was completely corrupted (like the image above). I'm now scared to open any of my files. On a side note, it seems to be running REALLY slowly, this could be due to the file size, however.

I'm going to update my adobe software, however, if there is any way someone could help, it would be appreciated as I'm going to have some unhappy clients soon. I'm paying for this software so would like it to work.

Let me know if there is any other information you need.

Thanks
Photo of laura price

laura price

  • 4 Posts
  • 0 Reply Likes
  • Frustrated and very unhappy

Posted 10 months ago

  • 3
Photo of Stephen Newport

Stephen Newport

  • 264 Posts
  • 69 Reply Likes
I've had this happen on multiple occasions as well
Photo of laura price

laura price

  • 4 Posts
  • 0 Reply Likes
Doesn’t seem like we’re the only ones. I was speaking to someone who said he thought it was linked to some clashing plugins. So he uninstalled everything, reinstalled everything and all the plugins he used and it seemed to work. Figure it’s worth a try
Photo of eartho

eartho

  • 814 Posts
  • 198 Reply Likes
Ouch. I remember this bug from back in cc2015, but haven't yet run into it in cc2018.
Photo of Warren Heaton

Warren Heaton

  • 99 Posts
  • 34 Reply Likes
Are you running Time Machine?  Or are you running another backup utility?  If not, I'd immediately take the time to set something up.  At the very least, copy any file that you open to another drive or cloud storage before opening it so that you have a version of that document that hopefully is fine.

Have you run Disk Utility on your hard drive?  While this could be Photoshop, it sounds more like a drive issue.  In addition to Apple Disk Utility, I'd recommend Micromat TechTool Pro (about $99, https://www.micromat.com) allowing it to run a Surface Scan test, Volume Structures test and File Structures test.  The have a free utility called MacCheck that will do the Volume Structures test, but it doesn't do a Surface Scan test nor a File Structures test.  If you run a Surface Scan (which I highly recommend), know that that can take a very long time.
(Edited)
Photo of laura price

laura price

  • 4 Posts
  • 0 Reply Likes
No but I have manually backed up my files to another drive.

I’ve run disk utility on my machine but no errors came back and I simply can’t afford any other software right now. I appreciate your suggestions though.

Since updating it seems to be ok so far, but still seems to be struggling, which seems odd as it’s running on a brand new machine.

I’m tempted to uninstall and reinstall everything. Will let everyone know how I get on with this as I’ve heard it’s worked for others.

Thanks again for your suggestions.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14149 Posts
  • 1765 Reply Likes
Hi Laura,

Sorry you're having trouble. I've been monitoring the other thread for additional clues that may lead us to reproducible steps and what might be causing this.

It may help if we could see your Photoshop System Info. Launch Photoshop, and select Help > System Info... and copy/paste the text in a reply.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14149 Posts
  • 1765 Reply Likes
It may also help to get a copy of the original file and the corrupted file (if you have both) so we can examine the files and try your steps.
Photo of laura price

laura price

  • 4 Posts
  • 0 Reply Likes
Hey thanks for getting back to me. I’ve since uninstalled photoshop and reinstalled it and so far it seems to be working better, fingers crossed no corrupted images as yet. I’d be happy to send some files though if it would be of use, just let me know where to send them :)
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14149 Posts
  • 1765 Reply Likes
Sent you an email
Photo of Adam Jerugim

Adam Jerugim, Employee

  • 196 Posts
  • 86 Reply Likes
If you're still seeing this issue, try disabling the Halide Bottlenecks plug-in.  You can do so by doing the following:

1.  Cntrl or right-click on the Adobe Photoshop CC 2018 application package and choose Show Package Contents

2.  navigate to Contents\Required\Plug-Ins\Extensions\

3.  rename the HalideBottlenecks.plugin by adding a '~' at the beginning of the plugin name (it should be ~HalideBottlenecks.plugin when you're done)

4.  Quit and re-launch PS

Please let me know if you're still seeing the corruption after this change.

Thanks,

Adam

PS - if the issue is also occurring on Windows, go to the app folder and navigate to Required\Plug-Ins\Extensions then follow steps 3 & 4 above.

(Edited)
Photo of Michael Held

Michael Held

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled Photoshop 19.0: Error: Smart Objects have weird cutouts / transparent areas. Nest....

Smart-Object gets weird cut-out. The Object has a smart-filter (gaussian blur) applied. The cut-out is not blurred. Screenshot of said smart-object:



Without smart-filter:


Content of the smart-object:



i am using:

win 10 pro 64bit
intel i7-4720Q
NVIDIA GeForce GTX 950M
PS 19.0