Photoshop 2015 glitching - bright red bars on images

  • 2
  • Problem
  • Updated 3 years ago
I am having issues with color glitches with Photoshop 2015. It happens most often after I have rendered an image in another program, JWildfire, which is a Java based portable fractal flame generator and editor. The glitch is bright red bars of color that will cover all or part of my image I am working on. It does not have to be a fractal, it can be any image. This started happening at the end of last week after a driver update from nVidia for my Gforce gtx 650 card. It can occur randomly but changing color settings seems to trigger it most often. If I close a layer and reopen the glitch is gone, only to return as soon as I touch the color again, or add a style,.
I am on Windows 10 64 bit 8 gigs of ram and subscribe to Creative Cloud so my Photoshop version is 2015. I have been working with both Photoshop 2015 and JWildfire on this system with no issues at all until now. I have talked to nVidia several times and they have no idea of what this problem could be. I have tried virus scans, both with my onboard virus software and with a couple of the more reliable online scans. Nothing. ANY suggestions you might offer would be greatly appreciated.I have uploaded screenshots to Dropbox here: https://www.dropbox.com/s/b9uqfbth6xv...
Photo of Jane Spaulding

Jane Spaulding

  • 6 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 2
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
First, make sure you have the 2015.0.1 update installed.
But it sounds like something is corrupting the GPU state, or corrupting memory on the video card.
Photo of Jane Spaulding

Jane Spaulding

  • 6 Posts
  • 0 Reply Likes
Chris, I do have the 2015.0.1 update. As for the GPU state, I have messaged the person who wrote JWildfire but since it is a JAVA application and uses only the CPU to render, I am not sure how it could be causing this. I think it may have more to do with the driver update because That is the first day I saw this issue and I have been using JWildfire and Photoshop together for over a year with no problems. I thank yu for the thoughts, I will ask Andreas (JWild) about this possibility.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
I'm not sure either. On a modern OS, one application shouldn't be able to corrupt another's memory. But somehow that is corrupting main memory, video memory, or the state of the GPU (which would make GPU operations show bad results).

You can try disabling GPU drawing in Photoshop and restarting the application. If the problem is with the GPU state, that should solve it.
Photo of Jane Spaulding

Jane Spaulding

  • 6 Posts
  • 0 Reply Likes
I will give that a try, Chris. I remember that this is part of the troubleshooting process. Thanks.
Photo of Hali Sowle

Hali Sowle

  • 1 Post
  • 0 Reply Likes
I'm having this problem as well, and I am only opening the image from lightroom, it isn't being rendered by any other program (other than LR CC). I'm also getting more frequent photoshop crashes.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
That sounds like an issue with Camera Raw and the GPU (which the ACR team is working on).
Photo of Jane Spaulding

Jane Spaulding

  • 6 Posts
  • 0 Reply Likes
Chris, I am curious if you think this is also part of my issue at all since I am not using camera raw or Lightroom. I seem to have solved the issue by resetting Photoshop as I mentioned below, but I have only worked on a few projects since then so I am not 100% positive. I was also having many issues with Photoshop crashing which seems better since resetting to default. What I really do not understand about this is I have not really changed the settings other than to assign scratch disk space so I have no idea of why resetting made any difference.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
"opening the image from lightroom", and that reply was not to you.
Photo of Jane Spaulding

Jane Spaulding

  • 6 Posts
  • 0 Reply Likes
Chris, I thought as much, but I do use the camera raw filter from Photoshop some so I thought I would ask.
Photo of Jane Spaulding

Jane Spaulding

  • 6 Posts
  • 0 Reply Likes
Hali I reset all my PS settings to default and this seems to have corrected the issue. I hope it helps for you too. I was opening my images from Photoshop so it sounds like we were having similar issues. My images are png format when I start but I do not think that makes a big difference as far as what I was seeing, it happened when I made adjustments to layers.