Photoshop 2015.5: Lighting effects filter bug

  • 1
  • Problem
  • Updated 1 year ago
Hi 
In PS 2015.5 ,the picture  bcomes illegible after using  Lighting effects filter.And I had asked some friends,they all have the same problem.But there is no problem with  Lighting effects filter in PS CS6.
Waiting for your solution,THX.
Photo of 柏 童

柏 童

  • 7 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Cristen Gillespie

Cristen Gillespie

  • 1269 Posts
  • 325 Reply Likes
What do you mean by the picture becomes illegible? Can you post a screen capture of what happens? And what OS are you using? I've been using the Render Lighting filter since the release with no problem.
Photo of 柏 童

柏 童

  • 7 Posts
  • 0 Reply Likes

Thank you so much for your reply!
I try to show the difference between PS CC2015.5 and PS CS6 after I enlarge the Image.
And I am using  OS X 10.10.2 ,but I ask some two friends who are using Win10,they  have the same problem with PS CC2015.5.
Sincere thanks for your help!
Photo of Stefan Klein

Stefan Klein

  • 119 Posts
  • 65 Reply Likes
I can repro it. The image is getting blurry in CC 2015.5 affter using lighting effects.
Photo of 柏 童

柏 童

  • 7 Posts
  • 0 Reply Likes
THX for your reply!
So I think it may be a bug.
Photo of Cristen Gillespie

Cristen Gillespie

  • 1269 Posts
  • 325 Reply Likes
It's clearly a problem with your image, and if Stefan says he can repro it, no doubt but it's there.  Since I normally use LE on heavily textured photo-art, a slight blurring like in my screenshots here wouldn't even be noticeable. I tried this image with a lot of lines. In this image, I'm seeing the light remove contrast, but some of it does appear to be softer, as well. I don't think it's quite as obvious as in your example, but it's there if I look for it.



Photo of 柏 童

柏 童

  • 7 Posts
  • 0 Reply Likes
Cristen,
Thank you for your  prompt reply!
I  have tested your image,and there is no problem then.
I feel very puzzled with it,then I try another image(7360 × 4912,6.5 MB)the problem is still there.
Then I try to compress the image to (1400*934,1.4M).There is no problem then.
So maybe the problem is just with the large image?
Would you like to test a large image please?
Photo of 柏 童

柏 童

  • 7 Posts
  • 0 Reply Likes
Here is my image for testing ,but I have to compress the image to upload it.

 
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14149 Posts
  • 1765 Reply Likes
I'm not able to reproduce off hand. Could you provide a file where you've applied Lighting Effects to a layer a Smart Filter? That might help us troubleshoot/trackdown
 
Photo of 柏 童

柏 童

  • 7 Posts
  • 0 Reply Likes
 Jeffrey ,
THX!
Here is the image I have tested,but I have to compress the image to upload it.
Photo of Stefan Klein

Stefan Klein

  • 119 Posts
  • 65 Reply Likes

Jeffrey,

I have tested it with an RGB, 8bit, 4096 x 2732px file. I also get the same kind of bluriness, if I make a 3D postcard! Since lighting effects may also use a postcard internally, this problem is related.

BTW, the postcard blurriness is also there in CS6. The lighting effect bluriness is not in CS6. So maybe it ́s not related, as I thought before.

(Edited)
Photo of 柏 童

柏 童

  • 7 Posts
  • 0 Reply Likes
Stefan,
THX!
I have tested more images,there is no problem when I test a little picture(1400*934,1.4M.
But when the picture is large enough,like my image (7360 × 4912,6.5 MB),the problem arises.
Photo of Stefan Klein

Stefan Klein

  • 119 Posts
  • 65 Reply Likes
So let ́s hope for a fix!
Photo of Cristen Gillespie

Cristen Gillespie

  • 1269 Posts
  • 325 Reply Likes
My camera is only the D750, so not large enough to match. I'll show the screenshots at 100%. I'm still not sure if the blur is from the lighting effects washing out the contrast or not, but it's still visible at 100%. I tried in the last sample to add back contrast with Curves. Since I tend to shoot close and with shallow DOF, here are two samples from an unedited, unsharpened NEF.






Photo of Stefan Klein

Stefan Klein

  • 119 Posts
  • 65 Reply Likes
Regarding the last 2 samples: It ́s not only blurry, it looks jagged. Like upsampled from a lower resolution.
Photo of Cristen Gillespie

Cristen Gillespie

  • 1269 Posts
  • 325 Reply Likes
It wasn't upsampled, though. Where the leaves are striated, shows this odd antialiasing, and it's even more obvious with the Curves layer increasing contrast. So before lighting, but with curves to increase contrast;
after lighting, with curves; and after lighting, but without curves. This area is within the hotspot. The other was just outside the hotspot, but within the cone of the spot light.  I switched to a Point light, keeping all the settings the same. First shot is no light with curves. 2nd is Point light, but no curves (the curves were too strong).

And can someone please tell me why Smart Filters STILL has no obvious "well" for the visibility icon? I'm tired of stabbing at it when I want to turn it on and off. Even in this dim UI I can make out a square for layers visibility.





Photo of Cristen Gillespie

Cristen Gillespie

  • 1269 Posts
  • 325 Reply Likes
Okay, here is an image that's pretty significant. I tried a couple with large simple detail and didn't see much of a difference with or without lighting. Here's one with a lot of finer detail, and even if it isn't tack sharp to start with, it's certainly obviously degraded after.




Photo of Jan Gonzales

Jan Gonzales

  • 2 Posts
  • 0 Reply Likes
PHOTOSHOP 2017.  Blurring is still there.  Check fingers.

Photo of Stefan Klein

Stefan Klein

  • 119 Posts
  • 65 Reply Likes

Same here :(

Still blurry.

Photo of David Krizek

David Krizek

  • 1 Post
  • 1 Reply Like
Guys, I just found a solution! If you follow this method, you will be able to apply lighting effects to any image without compromising its sharpness!

  1. Duplicate the layer to which you want to add lighting effects (ctrl+J)
  2. Go to the lighting effects filter (Filter > Render > Lighting Effects...)
  3. Apply lighting effects as desired, like you would normally do. Click OK when finished.
    Lighting effects will be applied (albeit reducing image sharpness, but bear with me!)
  4. Toggle the top layer's visibility to off, hiding the lighting effects layer.
  5. Create a new layer (ctrl+shift+N)
  6. Press [shift+F5] to open the Fill dialogue box.
  7. Click the topmost dropdown menu labeled "Contents:" and select "50% Gray."
    Make sure the blending mode is set to "Normal," opacity is at 100%, and "Preserve Transparency" is unchecked. Click OK. You should now have a medium-gray top layer.
  8. Press [alt+ctrl+F] to apply the last filter (in this case, Lighting Effects).
    The same lighting effects settings you had applied in step 3 will be applied to the top gray layer.
  9. Finally, change the blend mode to either Overlay or Vivid Light, whichever one looks more appealing. This will blend the gray layer with the underlying visible layer, creating the same effect lighting effects normally would—except while retaining all of the original sharpness!

So there you have it. You may wish to compare the difference by toggling the visibility of the hidden lighting effects layer (alt-click the eye icon slot). If you zoom in to pixel level (ctrl+1), you will be able to see the stark difference between the two methods, and how this modified lighting effects method truly retained the image's original sharpness.

Enjoy!

-David