Photoshop 2015.5: Smart Objects Transform/Scale

  • 2
  • Problem
  • Updated 2 years ago
  • (Edited)
I noticed while working for the first time in 2015.5 today that smart objects aren't doing what they used to. For instance, I often convert vector layers pasted into PS into smart objects so I can warp/transform them, but I found when I went to adjust the transformation I had already applied, the bounds were no longer representative of the previous warp, despite it being a smart object. They seemed to revert back to a flat rectangle instead of the proper custom perspective that I had already established. I also noticed an oddity when I relinked to a different linked .ai file. Despite the two sources I was swapping between being the same dimensions, the replaced smart object became heavily non-proportionally scaled when I updated it. I know with certainty that this was never a problem in the past because I do the same workflow every single day and this caught me by surprise.

I've noticed general performance increase, which is great, but this is a huge problem for me. I hope it's indeed a bug that can be fixed, or perhaps some new setting that I'm not aware of.
Photo of Colin Brain

Colin Brain

  • 4 Posts
  • 5 Reply Likes
  • disappointed

Posted 2 years ago

  • 2
Photo of Colin Brain

Colin Brain

  • 4 Posts
  • 5 Reply Likes
Update: The first problem I mentioned occurs when there is a mask on the layer
Photo of John

John

  • 2 Posts
  • 2 Reply Likes
Having the same issue without any mask applied...
Photo of Jaroslav Bereza

Jaroslav Bereza

  • 809 Posts
  • 187 Reply Likes
Did you pasted something from clibboard? I noticed that after layer move... was my layer reverted back to original position. It happened 2 times in prerelease testing, but in current build I haven't problem. I am not sure if my bug is related.
Photo of John

John

  • 2 Posts
  • 2 Reply Likes
It happens on anything i paste from AI.I reverted back to PS2015 and now all my bounding boxes are bigger than the element.
NIghtmare update...
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14551 Posts
  • 1894 Reply Likes
Hi guys,

I can't reproduce off hand. Could you provide step by step details to reproduce this issue? (and/or provide files to reproduce the problem)
Photo of Jaroslav Bereza

Jaroslav Bereza

  • 809 Posts
  • 187 Reply Likes
1) I used FastStone Capture to make screenshot of selected area.
2) Then I pasted bitmaps as layer into PSD document
3) When I tried move layer on intended coordinates,after drop layer position was reseted on original position.
4) When I copied bitmap I had to copied everthing 2x which is not usually. Otherwise, I don't have in the clipboard required data.
5) After that I saved my PSD file with option "As copy" for debuging
6) After that I couldn't save or open anything.
7) I restarted Photoshop and I still couldn't open anything
8) This was ok after PC restart

m.73

Noel Carboni had similar issue without FastStone program.