Photoshop: Is it safe to update to macOS 10.15 (Catalina) with the 20.0.7 update?

  • 1
  • Question
  • Updated 1 month ago
  • (Edited)
Is it safe to update to OS 10.15 (Catalina) now that Photoshop has the 20.0.7 update?
Photo of Patti Argoff

Patti Argoff

  • 11 Posts
  • 0 Reply Likes

Posted 2 months ago

  • 1
Photo of Paddy Boocock

Paddy Boocock

  • 49 Posts
  • 13 Reply Likes
I haven't experienced any problems using it, although there are some reported bugs/anomalous behaviours. But that may vary depending on configuration.
The only issue I have experienced is with the cursor repeatedly turning to a crosshair by itself - this can be corrected by turning the keyboard on and off - it seems to have something to do with using Bluetooth and multiple keyboards. 
(iMac and MacBook Pro both OK for me)

Photo of Mick Loxley

Mick Loxley

  • 3 Posts
  • 0 Reply Likes
This update didn't seem to fix all the issues I have seen. I still cannot edit (erase parts) of an adjustment brush or grad layer, nor can I generate a new brush without having to deselect adjustment brush and select it again.  I've also found that I cannot change panorama merging modes.  I hope it is fixed soon, as these issues are very frustrating!
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15643 Posts
  • 2374 Reply Likes
Fixes for Camera Raw will be in its next update.
Photo of Mick Loxley

Mick Loxley

  • 3 Posts
  • 0 Reply Likes
Thanks Jeffrey, hope it’s soon, it’s very frustrating not having those options when image processing.
Photo of Jim Hatch

Jim Hatch

  • 25 Posts
  • 3 Reply Likes
i have updated and there seems to be no problem . i did update cc first though
Photo of Mick Loxley

Mick Loxley

  • 3 Posts
  • 0 Reply Likes
Ok, mine was the other way around, Catalina first.  Looking at the fixes that are contained in 20.0.7, it doesn't mention the adjustment brush, and it also highlights this as still known compatibility issues: https://helpx.adobe.com/photoshop/kb/photoshop-and-macos-catalina.html#FixedIssues
Photo of Henning Persson

Henning Persson

  • 4 Posts
  • 0 Reply Likes
Got a probem with the "save for web" is not working. Use it for animation gif for banner. 

Its working with "old" files - but not with new one. 
(Edited)
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15868 Posts
  • 2460 Reply Likes
Can you provide more steps to reproduce to reproduce your issue? I created a frame based animation, exported via Export > Save For Web... 

Open the gif file in a browser and it played.

What's not specifically working? Are you getting an error?
Photo of Henning Persson

Henning Persson

  • 4 Posts
  • 0 Reply Likes
Hi
It's only a problem when I use a new document. Then I have no chance for "save for web" - is grey. If I use an old document from before update it's no problem. See screen dump off a new document. Im using a Danish version - but I hope you can se it anyhow. Thanks. 
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15868 Posts
  • 2460 Reply Likes
I can't see the document tab, or the status bar, but I suspect you have a file that is in a bit depth or color mode that isn't supported by Save For Web (32-bit file for example). Make sure your file is RGB/8-bit or 16-bit.
Photo of Henning Persson

Henning Persson

  • 4 Posts
  • 0 Reply Likes
Thank you. It works. YES!!!
Photo of Travis

Travis

  • 1 Post
  • 0 Reply Likes
Safe for Web (Legacy) erases the filename extension, so now I am constantly exporting files that have no extension.

I'm in 20.0.7

I believe it used to highlight the word before the . like...

[default].png and you could just start typing

Now when you type the ".png" gets erased so you have to meticulously scalple the filename just to save, or you get files called "default"