Photoshop 20.0.5: Transform Controls and Extras Won't Stay OFF

  • 1
  • Problem
  • Updated 4 days ago
  • (Edited)
I have extras unchecked but when I click on a smart object and go into free transform mode the controls are back. I have to hit Ctrl-H TWICE to get them to go away, do my transformation, and then exit transform. Every time I do a transform they come back. I've turned off everything. Show is set to none. The extras options have everything unchecked. The program is just not following these settings whatsoever. Of course I have the selection tool set to not show transform controls as well. But the damn extras keep coming back, like a persistent rash.
Photo of Russ1642

Russ1642

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 5 days ago

  • 1
Photo of David

David, Official Rep

  • 3188 Posts
  • 504 Reply Likes
Hi Russ,

Well, if you mean the bounding box on the smart object that you're transforming, that's as designed.  We want users to be reminded of the boundaries of the smart object that they're transforming.  Indeed, you need the bounding box to actually do the transformation, so I'm not quite understanding the issue that you're facing.  Perhaps a screenshot?

Thanks,
David
Photo of Russ1642

Russ1642

  • 3 Posts
  • 0 Reply Likes


Whenever I go into transform mode for my smart object I get this crap. While in transform mode if I go to View and uncheck Extras then they'll go away. These lines and dots are there even if Extras is already off, so you have to turn it on and then back off again for them to go away. It's not always a good thing to plaster stuff all over your objects when you're trying to place them. I want to be able to see what it'll actually look like, not what it'll look like with a big X and white dots all around it. The setting for this exists it's just not working properly. I used to use it all the time.