Photoshop 19.1: In fullscreen mode, canvas moves to upper left corner and 3/4 of the canvas is unusable

  • 16
  • Question
  • Updated 2 years ago
  • Answered
Hej Hannah,

thank you guy for your support & the solution today. I think it solved the issue with the floating Screen somehow, but... something new is happening :-/
I think it depends if I work “with“ or “without“ the graphic-card-support and/or the Application-Frame On/Off (just on MAC).
I am using PS on a MacBookPro here with a Nvidacard on 2screens. I always work in PS on the bigger 2nd screen which is a Wacom-Cintiq:

1. I open a PSD-file here (a test-file orange/yellow)
2. it opens in the upper-left corner – ok so far!
3. i changed the screen-mode (F), and...
4. the the hole canvas appears in a small rectangle in the upper-left corner and the other 3/4 of the canvas is just black and not useable?!! (see screenshot)



...thats absolutely useless here. When i switch OFF the graphic-card-support is seams to work fine in the frameless PS. Or i have to switch the PS-Application-Frame ON to use the graphic-card-support again. But use “graphic“ and “frameless“ at the same time it cause this new issue?!

This was not an issue in CC2017!
 
– help?!

Note: This conversation was created from a reply on: Photoshop CC 2018: Floating document windows in fullscreen w/menu bar causes wind....
Photo of Cyprian Lothringer

Cyprian Lothringer

  • 5 Posts
  • 7 Reply Likes

Posted 2 years ago

  • 16
Photo of Elderoy

Elderoy

  • 7 Posts
  • 5 Reply Likes
Same problem here...
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 725 Posts
  • 330 Reply Likes
Thanks for the detailed report, Cyprian.  

Elderoy, do you also use a Wacom-Cintiq too? I'm not seeing the same behavior but I'd love to know what you two have in common on your systems. 
Photo of Morris Leoni

Morris Leoni

  • 8 Posts
  • 1 Reply Like
Hi,
Below, I posted a video to better understand the issue.
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 725 Posts
  • 330 Reply Likes
That's so helpful Morris. Thank you :) 
Photo of Elderoy

Elderoy

  • 7 Posts
  • 5 Reply Likes
Hello Hannah, thanks for your investment :)

Nope, I'm using an external display and a first generation Wacom Bamboo.

It does seem to appear only on the external screen though

Macbook pro 15" retina late 2013
- GPU Nvidia GeForce GT 750m 2Gb
- External display: Eizo S2433W, res 1920*1200 (HDMI, working as extended workspace)
- Mac Os 10.13.2
(Edited)
Photo of Cyprian Lothringer

Cyprian Lothringer

  • 5 Posts
  • 7 Reply Likes
Hej Hannah,

this are my setting here:

MacBook Pro (Retina, 2012) 15inch (2880 x 1800)
with macOS High Sierra (10.13.2)
2,7 GHz i7 with 16GB Ram
graphic-hardware:
Intel HD Graphics 4000 1536 MB

and a NVIDIA GeForce GT 650M 1 GB with the latest drivers:
CUDA Driver Version: 387.99
NIVIDIA Web Driver: 378.10.10.10.25.104

(https://support.apple.com/kb/SP653?locale=de_DE&viewlocale=de_DE)

the 2nd Display is a WACOM Cintiq 27GHDT (2560 x 1440)
It is connected via an elgato Thunderbold 2 Dock to my MacBookPro.



Let me know if you need more info – thanks!
Photo of Morris Leoni

Morris Leoni

  • 8 Posts
  • 1 Reply Like
I have the same issue on my Mac after the latest update (Photoshop CC 19.1.0). As you said, if I turn the GPU off in my PS settings (preferences/performance), the issue goes away. As soon as I tick the "Use Graphic Processor" back on, the issue comes back!
Photo of Morris Leoni

Morris Leoni

  • 8 Posts
  • 1 Reply Like
This reply was created from a merged topic originally titled Photoshop CC 19.1.0: Full screen refresh bug.

Since the latest update (v 19.1.0) if you toggle (w/ the F key) between screen modes, the content of your window doesn't refresh. In Photoshop I use floating windows (not tabbed) and when I want to put a window in full screen for example, the windows gets bigger but the content itself gets smaller and cropped (like a window-in-a-window)... Even if you zoom in, your content still cropped, it doesn't update the window size... Very bothering for my daily workflow...

https://drive.google.com/file/d/1ArQdvTSfjYhx1SD1oL-vf5ZJ64rp5siz/view?usp=drivesdk

macOS 10.11.6
Macbook Pro Retina 15-inch Mid 2014
2,8 Ghz Intel Core i7
16 Gb 1600 Mhz DD3
NVIDIA GeForce GT 750M 2048 MB
(Edited)
Photo of Jesse Mellon

Jesse Mellon

  • 3 Posts
  • 1 Reply Like
This reply was created from a merged topic originally titled Photoshop 19.1: Secondary display issues with "Use Graphics Processor" selected i....

Delighted to see Adobe has fixed the real-time text-adjustment issue with version 19.1.0, but suddenly any image viewed in "Full Screen Mode With Menu Bar" mode on my secondary display is much reduced in size, and slammed into the upper right corner, with black bars below and to the right (which I assume is the result of an incorrect resolution value being passed somehow).

Unchecking "Use Graphics Processor" rectifies the problem, but I'd rather not lose this functionality (it's all or nothing; toggling off individual items within the graphics processor prefs and restarting Photoshop doesn't fix the problem).

Have system requirements changed in 19.1.0? Assume it's related to the new Photoshop build and not a random video card quirk, given the timing.
Photo of David

David

  • 7 Posts
  • 4 Reply Likes
Hi Hannah, that glitch seems better with the 2019 update.
But unfortunately, with frustration and dissapointment a new problem.
I'm working with a MacBook pro and an apple thunderbolt 27in display. When in 'full screen mode with menu bar' the image is displayed very small with a large space of black.
When zoomed the image enlarges up behind the black space.
What seems to be happening is that in 'full screen mode with menu bar' it sizes the image for the MacBook screen not the thunderbolt screen.
Not a problem in 'standard mode' or 'full screen mode' without menu bar. I still have the previous version of photoshop and there is no problem there with screen mode displaying of images.
But that version glitches over the panels and does the very annoying snapping of image to centre when working.
Are we going to get past this era of frustration with photoshops glitches and unreliability? Or is it time to look at the alternatives?
After all this is a paid for service and it doesn't work as it should.
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 725 Posts
  • 330 Reply Likes
Hi David,

It appears that this bug is only encountered where there is a 1x display combined with a 2x, with the 1x as primary. Is this your situation? If it is, would it interfere with your workflow for you to make your 2x monitor primary as a temporary workaround?

Thanks,
Hannah
(Edited)
Photo of Morris Leoni

Morris Leoni

  • 8 Posts
  • 1 Reply Like
I prefer to temporarily deactivate the GPU acceleration rather than move my primary screen to the 2x monitor (my laptop)... — this workaround is acceptable so far...
(Edited)
Photo of Hayden Wood Photography

Hayden Wood Photography

  • 8 Posts
  • 4 Reply Likes
Haha, awesome! Aiyaiyai, what's going on Adobe?
Photo of Cyprian Lothringer

Cyprian Lothringer

  • 5 Posts
  • 7 Reply Likes
Thats funny somehow:
the workaround for this issue is indeed to press onece or twotimes the TAB-button!

But why this issue happening anyway? Adobe, please fix this issue some how – thanks!
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 725 Posts
  • 329 Reply Likes
Did you discover that Cyprian?
Photo of Elderoy

Elderoy

  • 7 Posts
  • 5 Reply Likes
I confirm that this workaround is working
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 725 Posts
  • 329 Reply Likes
Obviously it's already being investigated for a fix, but thanks so much for sharing that workaround.
Photo of Cyprian Lothringer

Cyprian Lothringer

  • 5 Posts
  • 7 Reply Likes
... my pleasure!
Photo of Alexander Efremov

Alexander Efremov

  • 3 Posts
  • 2 Reply Likes
Thanks! This workaround is working
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 725 Posts
  • 330 Reply Likes
While we investigate the fix for this issue, the workaround is to press tab once or twice. 

*** Thank you Cyprian ***
(Edited)
Photo of christoph pfaffenbichler

christoph pfaffenbichler, Champion

  • 1327 Posts
  • 209 Reply Likes
The 19.1.1 update seems to have fixed the issue. 
I am pretty impressed with the reaction speed ... 
Photo of Kathryn Rathke

Kathryn Rathke

  • 2 Posts
  • 2 Reply Likes
IT'S FIXED! YAYYYYY! Thanks, Hannah & co, one less little headache :)
Photo of Scott Fassett

Scott Fassett

  • 2 Posts
  • 2 Reply Likes
THANK YOU ADOBE! Everything seems to be working again, just like the good old days. That was a pretty quick fix. Thanks for addressing this annoying problem. I'm running a Cintiq 21UX with Macbook Pro Retina 2010 on High Sierra. Great job guys!
Photo of Scott Fassett

Scott Fassett

  • 2 Posts
  • 2 Reply Likes

I’d like to clarify this workaround as having two options. First, let me identify the three screen modes: 

OPTION 1

[With Tabs unchecked in Preferences]  Press the “F” key to cycle through these modes.

A - Floating windows WITH palettes, menus, or option bar (This is the mode with the bug - cropped image in the upper left hand corner)

B - Isolates one image file WITH palettes, menus, BUT NO OPTION BAR. (The cropping bug may also appear in this mode)

C - Full Screen Mode - isolates one image file WITHOUT any palettes, menus, or option bar (Unless you press Tab, then you will get palettes and menus, BUT NO OPTION BAR)

OPTION 2

If tabs are employed, then it’s a more preferred way to work, because you get the palettes, menus AND options bar. Let me explain:

Go to Preferences>Workspace. Turn on “Open Documents as Tabs” and “Enable Floating Document Window Docking”. 

Now by pressing the F key, the screen modes are as follows: 

A - Single image file WITH tabs for other open files at the top (just below the options bar), along with palettes, menus, and option bar. I don’t like this view because when the image is zoomed out enough to see the whole thing, I can’t move it around - it’s locked in the center, sometimes behind a palette.

B - Single image file WITHOUT tabs - along with palettes, menus, AND OPTION BAR (This is the mode I prefer to work in, because I can isolate one image, I get all my palettes, menus AND the option bar - very important, because here I can change all the attributes of the tool I’m currently using. 

C - Full Screen Mode - isolate one image file WITHOUT any palettes, menus, or option bar (Unless you press Tab, then you will get palettes and menus, but NO OPTION BAR)

I’ve been a digital painter in Photoshop for about 18 years, so I’m approaching this from a painting perspective with a primary painting image on my Cintiq and reference images on my MacBook Pro monitor. Some people don’t like tabs and they want to see multiple windows open all at once. I like that too. Any window can always be undocked and then it’s a floating window again. But then when you cycle through the screen modes, the cropping bug will show up again. 

For now, Tabs seems to be the best workaround for me. I hope this helps! 

-Scott 
Photo of Tristan Dwyer

Tristan Dwyer

  • 2 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Photoshop 19.1.0 Full screen bug.

I just upgraded to Photoshop 2018 (release 19.1.0) and there is a major bug with full screen mode on a retina macbook pro hooked up to an external monitor in dual-display mode. When entering full screen mode on the external monitor the "usable" area seems to only be 25% of the screen size as illustrated in the attached screenshots. Trying to use the hand tool (space) to pan works, but moving it outside the bounds of the usable area crops it off.

Specs of my setup:

  • Macbook pro (15-inch 2016)
  • MacOS Sierra (v. 10.12.6)
  • Radeon Pro 450 2048mb graphics card
  • Built in display - 15.4 inch (2880x1800)
  • External display - Dell U2717D - 27 inch (2560x1440)



Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 725 Posts
  • 330 Reply Likes
Hi Tristan,

I merged your post with a duplicate thread that contains workarounds. This is a known issue and the work around while we work on getting out the fix is to press tab once or twice.

Thanks,
Hannah
Photo of Michael Dialynas

Michael Dialynas

  • 4 Posts
  • 3 Reply Likes
Same problem here!
I can't work at all like this.

Gonna have to roll back to 2017.

Macbook Pro mid 2015
High Sierra 10.13.2
2,2 GHz i7
16GB
Intel Iris Pro 1536 MB
working with external screen and Wacom Intuos Pro.
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 725 Posts
  • 330 Reply Likes
Hi Michael, 

Sorry for the frustration. Just wanted to see how you felt about the workaround. Is pressing tab once or twice unacceptable for your workflow? Did it work for you?

Thanks,
Hannah
Photo of Michael Dialynas

Michael Dialynas

  • 4 Posts
  • 3 Reply Likes
Hey Hannah,

I've already rolled back to 19.0 since I've gotten used to the center snap these past months.

I couldnt stay using 19.1 cause I toggle through Fullscreen a lot while working so adding the fact of pressing TAB a few times would have frustrated me.

The only thing that worked while I had 19.1 was turning off the Use Graphic Processor but I couldnt work properly cause it made things choppy and slow. 
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 725 Posts
  • 330 Reply Likes
Understandable. The other workaround option fyi is that from what we can tell it only happens when you have a 1x monitor and a 2x monitor with the 1x as primary.  If you make the 2x primary it stops. So no extra keys, but not always feasible either. Does that describe your setup?
Photo of carlo favero

carlo favero

  • 2 Posts
  • 0 Reply Likes
Hello!
Just updated yesterday to 19.1 and I have the same issue. I work with a 2015 macbook Pro with 10.11.6 osx and an Eizo as primary screen. Hitting tab a couple times fixes the weird image position, but I often switch between full screen modes and hide/show the panels in my workflow. Every time I switch I have to hide / show the panels once more by hitting tab few times to view the image I'm working on normally. Hope this will be fixed soon, it's frustrating.
Thank you!

Carlo Favero
Photo of SimoneM

SimoneM

  • 2 Posts
  • 1 Reply Like
So happy you solved the bug of version 19.0, but now I also have this new bug. ... But the workaround helps so far. 
Photo of Manja Zore

Manja Zore

  • 2 Posts
  • 1 Reply Like
I have the same issue with full screen... I'm working with a 2015 Macbook Pro, 10.13.3, and Eizo primary screen. Please just fix this, I'm not turning off my Graphic processor.
Thank you in advance!
manja
(Edited)
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 725 Posts
  • 330 Reply Likes
Hi Manja,

The two known workarounds are:

1. press tab once or twice
2. set your 2x monitor to primary

Thanks,
Hannah
Photo of Manja Zore

Manja Zore

  • 2 Posts
  • 1 Reply Like
Thanks Hannah! Yeah, pressing tab works. But making my Macbook pro monitor the primary screen doesn't work so well for me, so I'll wait for the update and a more permanent fix to the issue. Thank you!
Photo of Claude Jenkins

Claude Jenkins

  • 7 Posts
  • 1 Reply Like
Hello, with 19.01 can't use the pointer to make the work tab appear when set in full screen with the tab. Works only when graphic processor is disabled thats lead to another issues ! I rolled back to 19.0 but do you think this problem will be fixed in a reasonable future ? Using Imac 27,5" with last Sierra. Thanks
Photo of Peter Villevoye

Peter Villevoye

  • 26 Posts
  • 14 Reply Likes
This reply was created from a merged topic originally titled Full screen bug in Photoshop CC 2018 (19.1).

I have Mac OS Sierra, Photoshop CC 2018 and since this latest 19.1 update (not in 19.0) my full screen suffers from a strange problem when I'm NOT using an application frame. If I hit the f-key to switch to full-screen mode, it initially looks like the enclosed image: the screen seems split in 4 areas, and I can only work in the upper left quadrant. When I temporarily switch to another document (Cmd-tilde) and back again, everything seems alright again.

I guess it might have something to do with the fact I'm using multiple screens: two Cinema Displays and the screen of my MacBook Pro with a retina screen. One of the Cinema Displays is my main screen. When I work on my MacBook Pro without any extra screens attached, the bug doesn't occur.
Photo of Peter Villevoye

Peter Villevoye

  • 26 Posts
  • 14 Reply Likes
Thanks for merging my question/problem with this thread !
I looked for earlier messages, but as I typed my title and received the results from the automated query, it said: "We found 34368 similar conversations". This thread wasn't in the top 10, and I wasn't in the mood for looking through 34358 other ones... Lazy me !

Seems that my problem has been reported by other users as well (good to know), and has been acknowledged by Adobe, so we'll just sit back and wait for 19.2, while hitting the tab key for now. ;-)
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 725 Posts
  • 330 Reply Likes
It's not you, Peter! Finding what you need takes some getting used to here. Happy to help! 

The other option is to switch your 2x monitor to primary.

Regards,
Hannah
Photo of Peter Villevoye

Peter Villevoye

  • 26 Posts
  • 14 Reply Likes
NOOOO !! That's sooo small...
Why focus on a retina car window while I can stare at two panoramic slates ?
Yeah, a Surface Studio would maybe be better option, but that's not portable. ;-)
Photo of carlo favero

carlo favero

  • 2 Posts
  • 0 Reply Likes
Hi Hanna, as I mentioned in my reply I have an external monitor set as primary and I keep having the issue we're talking about. What do you mean with "2x monitor"?
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 725 Posts
  • 330 Reply Likes
Sorry I mean what you have your scaling set to - are you on Win?
Photo of Jim Campbell

Jim Campbell

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled Photoshop CC 19.1.0 full screen doesn't work properly.

Photoshop CC 19.1.0 on a MBP running OSX 12.6. When you have a floating document window and hit 'F' for fullscreen, you get the result below. The grey area is the work area, the black area is completely fixed. Zooming in and out only magnifies/shrinks the image in the grey area. Somewhat defeats the point of having a 24" monitor.
Also: I would much prefer to have a proper bug report page but fifteen minutes of googling only turns up this option. I don't want to have "a conversation", I want to file a bug report with the company that's charging me £600 a year and allows a brain-meltingly stupid bug like this to go out in a release version.
EDIT: Fixed it. Had to turn off the "Use Graphics Processor" option in preferences under the 'Performance" section. (This is also the only way to get acceptable performance out of InDesign, BTW, and I think rather defeats the point of buying a MBP with a decent graphics card.)


Photo of David

David

  • 7 Posts
  • 4 Reply Likes
Has anyone else been approached by a legal firm inviting to participate in a class action for a refund on subscription fees due to the app not working as per contract?
Photo of Peter Villevoye

Peter Villevoye

  • 26 Posts
  • 14 Reply Likes
Nope, but I'm not an American citizen or business.
However, I do think there's no need to take any action, because:
  • software bugs are an integral aspect of software development;
  • the issue can easily be circumvented without further sacrifice;
  • the developer has the clear intention to solve the matter asap;
  • the Adobe EULA probably waives any bug-related damage or loss.
It's like suing parents for less genetic resistance against catching a cold.
You can send me a $15 check, for time spent on this legal consultation...
(Edited)
Photo of Claude Jenkins

Claude Jenkins

  • 7 Posts
  • 1 Reply Like
Hello, nope either, I totally agree with your position Peter however you can't say :"the issue can easily be circumvented without further sacrifice" as disabling the graphic processor lead to another big problems with brushes etc...
More, I can hardly accept that a big one like Adobe could put on the air a version with such a big bug affecting so many users !
Let's hope for a swift (!) solution ...
Photo of Peter Villevoye

Peter Villevoye

  • 26 Posts
  • 14 Reply Likes
In stead of disabling the GPU or working with the application window switched on (to prevent it from happening) you can temporarily solve it by pressing the tab twice, to change views and let the GPU performance and screen arrangement behave again. No big problem...
Photo of Claude Jenkins

Claude Jenkins

  • 7 Posts
  • 1 Reply Like
Ok, this is a well known trick but my issue is : when working a picture you want a larger view press the tab the pic become fullsceen the working tabs disappears from the right side, before 19.01 you approach the pointer to the right side making workingtab appears again to allow correction or wahtever... Now, nothing but a jump of my canvas to the left... I did ask the users service got an answer to disable GPU, wrote my problem to PS family no answer after a week...Sure if I use a second hit on the tab the picture come again but if I roll back to CS6 I will get the service as well !
Photo of Peter Villevoye

Peter Villevoye

  • 26 Posts
  • 14 Reply Likes
I can perfectly mimic the behaviour of the appearing panels in the edges of the screen after applying any reshuffle of the windows, together with the GPU running, and proper view on my screen. Press tab twice. After this trick, everything behaves as usual. Or maybe I'm misunderstanding or confusing your method ?
Photo of Claude Jenkins

Claude Jenkins

  • 7 Posts
  • 1 Reply Like
No, if you press tab you got a proper view that's ok but with previous version you don't have to press tab but put the pointer to the right edge (where the worktab was before wiped by the tab) and tabs appears. Press tabulation worktabs disappears, pointer to the right edge worktabs comes again without changing the zoom level.I was used to this very swift way to work and really upset to return to the ages....I am using an Imac 27,5" 3,5 Ghz, Intel 7with 32M Ram and Nividia GPU
(Edited)