Photos distorted when I Import into Lightroom 5.7.1

  • 1
  • Problem
  • Updated 2 years ago
I'm using the Lightroom version 5.7.1 on my Macbook Pro 2014 model.  The last two times i downloaded my images they are completely distorted with multi coloured lines and patches all over the picture.  All my photos are downloading perfectly into iPhoto on my laptop but not on Lightroom.                             
Photo of Vickram Murthy

Vickram Murthy

  • 13 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Jim Wilde

Jim Wilde, Champion

  • 260 Posts
  • 75 Reply Likes
Without seeing the files, it's difficult to be definite, but it does sound like the raw files are corrupted (I'm assuming you're shooting raw, yes?). Perhaps you could post a screenshot of what you see in Lightroom, or better still upload one of the original files, e.g. to Dropbox or similar, so that we can download and inspect it.

iPhoto is probably showing you the embedded jpeg preview, which is often OK even if the raw data is corrupted.
Photo of Vickram Murthy

Vickram Murthy

  • 13 Posts
  • 0 Reply Likes
Photo of Vickram Murthy

Vickram Murthy

  • 13 Posts
  • 0 Reply Likes
Photo of Vickram Murthy

Vickram Murthy

  • 13 Posts
  • 0 Reply Likes
Photo of Vickram Murthy

Vickram Murthy

  • 13 Posts
  • 0 Reply Likes
Thanks for looking into this Jim :) 
Photo of Jim Wilde

Jim Wilde, Champion

  • 260 Posts
  • 75 Reply Likes
That's almost certainly corrupted raw files. However, I can't access either of the two files that you've uploaded, as I'm getting 404 errors when I try. Could you check the link again?

You said the last two times you downloaded, was that using the same camera card, or a different one. The corruption could be anywhere along the chain from camera to card to cable or card reader to computer hard drive (and can be caused by a faulty RAM card). That's why it would be good to be able to look at one of the original files that are uploaded straight from the original card.
Photo of Vickram Murthy

Vickram Murthy

  • 13 Posts
  • 0 Reply Likes
Photo of Vickram Murthy

Vickram Murthy

  • 13 Posts
  • 0 Reply Likes
Photo of Vickram Murthy

Vickram Murthy

  • 13 Posts
  • 0 Reply Likes
The last time it was a different SD card.
Photo of Jim Wilde

Jim Wilde, Champion

  • 260 Posts
  • 75 Reply Likes
OK, I've download both of the files, and they are both corrupted. Did you upload them to Dropbox directly from the SD card, or were they copied to a hard drive first?
Photo of Vickram Murthy

Vickram Murthy

  • 13 Posts
  • 0 Reply Likes
Photo of Vickram Murthy

Vickram Murthy

  • 13 Posts
  • 0 Reply Likes
Photo of Vickram Murthy

Vickram Murthy

  • 13 Posts
  • 0 Reply Likes
The ones that I previously uploaded were copied to the Hard disk and then uploaded, the ones I just uploaded are taken straight from the SD card. 
Photo of Vickram Murthy

Vickram Murthy

  • 13 Posts
  • 0 Reply Likes
Is this a problem with the camera or the memory cards? I'm guessing not the memory cards I don't think all of them can be corrupted at the same time.  Thanks for your help.
Photo of Jim Wilde

Jim Wilde, Champion

  • 260 Posts
  • 75 Reply Likes
I don't think it's a problem with either the camera or the card, as after downloading the last two files (straight off the SD card) they imported into Lightroom just fine, no corruption.

So that suggests the problem is local to your computer, maybe the hard drive going bad. Do you have another drive that you could copy the files to (from the SD card), then try importing into Lightroom from there?

If it's not the hard drive that's going bad, and assuming you're using the built-in SD card reader (so no cable to worry about), the only other likely possibility would be faulty RAM. Try a different hard drive first....
Photo of Vickram Murthy

Vickram Murthy

  • 13 Posts
  • 0 Reply Likes
I think I identified the problem, it was my SD card reader :( I bought a new one since my Mac just won't read SD cards from the SD card slot, i tried troubleshooting many times but it never worked so I got myself a SD card reader, I guess it worked fine couple of times until it got bad. I used the cable this time to import straight from the camera and the pics are fine.  Thanks for the help, I just hope I figure out working the SD card slot on my Mac.