Photoshop: Photomerge "error 19, bad argument: invalid source format" on Win7

  • 3
  • Problem
  • Updated 8 years ago
  • (Edited)
I just installed the new CS5.1 trial version on my new lap top (windows 7, i-7, 6 gig ram, 2 gig video). Everything seems to work except photomerge. When I press, file, automate, photomerge. I get this error 19, bad argument: invalid source format. I don't get this since I have no photo open whatsover.

Do you have any idea what the problem might be?
Photo of SjoerdT

SjoerdT

  • 13 Posts
  • 0 Reply Likes

Posted 8 years ago

  • 3
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14678 Posts
  • 1957 Reply Likes
Does this happen with all image files? Can you try it with the sample images in the Photoshop application folder>Photomerge?
Photo of SjoerdT

SjoerdT

  • 13 Posts
  • 0 Reply Likes
yes! I opened the three photos of the city, went to automate and then photomerge, then it comes with a screen with the described error. Unfortunately I cannot post pictures. Or can I?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13996 Posts
  • 1700 Reply Likes
You can post images to this site. I've asked a QE to look into it.

Couple of thing to try in the meantime. Can you try restoring your prefs and running it again? http://adobe.ly/PS_Prefs

Are you running Photoshop as an Administrator?
Photo of SjoerdT

SjoerdT

  • 13 Posts
  • 0 Reply Likes
I used adobe extend script and opened the photomerge.jsx file

I found errors at these lines:

$.evalFile(g_StackScriptFolderPath + "LatteUI.jsx");

$.evalFile(g_StackScriptFolderPath + "StackSupport.jsx");

$.evalFile(g_StackScriptFolderPath + "CreateImageStack.jsx");

$.evalFile(g_StackScriptFolderPath + "Geometry.jsx");

$.evalFile(g_StackScriptFolderPath + "PolyClip.jsx");

it tells me it cannot find file or folder does not exist.

Does this help? I will try resetting the presets
Photo of SjoerdT

SjoerdT

  • 13 Posts
  • 0 Reply Likes
used cntrl alt shift deleted the prefs...alas that didn't work....could you tell me how to post a photo of the error?

BTW thank you kindly for your help.
Photo of SjoerdT

SjoerdT

  • 13 Posts
  • 0 Reply Likes
downloaded photoshop elements too...tried to make a panorama with elements and got the same error. Should it have something to do with Java or Flash???
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13996 Posts
  • 1700 Reply Likes
No. Nothing to do with Java or Flash. It's something to do with the Javascript files (.jsx) files.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13996 Posts
  • 1700 Reply Likes
I'm thinking that those files are locked or missing. Can you search for them on your harddrive to make sure they're there?
Photo of SjoerdT

SjoerdT

  • 13 Posts
  • 0 Reply Likes
I found them in the installed directory
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13996 Posts
  • 1700 Reply Likes
Are the permissions correct for those files?

http://kb2.adobe.com/cps/895/cpsid_89...
Photo of SjoerdT

SjoerdT

  • 13 Posts
  • 0 Reply Likes
Those files are available for reading and/or writing. I assume that with those files you mean the ones I mentioned earlier?
Photo of SjoerdT

SjoerdT

  • 13 Posts
  • 0 Reply Likes
I decided to reinstall the software, this time I placed it in the program files directory. I hoped that this would solve the error. Alas.

When I try to open automate - photomerge now. It tells me photoshop stopped working and it crashes. It must have something to do with not finding the scripts. But I cannot think of an idea, why it would not work. I am an admin on this computer.

I tried it on my backup pc and there everything is allright. Except for the fact, that that pc doesn't even come close to the specs of this one.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13996 Posts
  • 1700 Reply Likes
Hmm Maybe try restoring the prefs again. http://adobe.ly/PS_Prefs
Photo of SjoerdT

SjoerdT

  • 13 Posts
  • 0 Reply Likes
didn't do anything
Photo of SjoerdT

SjoerdT

  • 13 Posts
  • 0 Reply Likes
I foun something weird. I thought that the directories were available for writing too. But after the re-installation I found out that the directory of adobe is locked onto read-only. When I try to change this. Windows tells me I need to be an admin. I am, so I find this really strange. After clicking the read only button it starts to do all kinds of thins. Afterwards it is still checked onto read only. I don't get it.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13996 Posts
  • 1700 Reply Likes
That's really strange. What happens if you create a new (temp) admin account and try running?
Photo of SjoerdT

SjoerdT

  • 13 Posts
  • 0 Reply Likes
Sorry it is just a check for the directory not in front of the file. It is a windows thingy. I can change files from read-only to writeable. Could it be something with the virusscanner? Hard to disable...
Photo of SjoerdT

SjoerdT

  • 13 Posts
  • 0 Reply Likes
Sorry it is just a check for the directory not in front of the file. It is a windows thingy. I can change files from read-only to writeable. Could it be something with the virusscanner? Hard to disable...
Photo of SjoerdT

SjoerdT

  • 13 Posts
  • 0 Reply Likes
any new ideas?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14678 Posts
  • 1957 Reply Likes
Is your volume named anything unique or using special characters? Maybe related to this topic?

http://kb2.adobe.com/cps/852/cpsid_85... (I know it's a Mac problem but seeing if there's something there that might be related)
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14678 Posts
  • 1957 Reply Likes
Hi SjoerdT,

Can you try a couple of things for me:

1. Launch Photoshop by itself (vs. launching it by double-clicking a document or from Bridge, etc.) then launch Bridge.

If that doesn't work:

2. Turn on "Open Documents in Tabs"

Let me know if either of those work.
Photo of Meredith Payne Stotzner

Meredith Payne Stotzner, Employee

  • 68 Posts
  • 11 Reply Likes
Hi,
I'm going to add a few more things in addition to Jeff's 2 requests above.

1. After the reinstall, was updating successful?

2. For the crash - any text/screenshot you can post would be helpful.

3. Also, if you could post/send your system info (Photoshop: Help > System Info...)

4. Jeff has already covered:
Drive Naming
Edit > Preferences > Interface... Open Documents as Tabs = ON
Clearing Preferences & Restart

5. Now this one is a long-shot, but bad fonts can do bad things: http://kb2.adobe.com/cps/328/328607.html

Looking forward to the System Info and Crash reports
Thanks for your patience,
Meredith