Photomerge - Add open docs ... Documents must be saved before they can be merged.

  • 1
  • Problem
  • Updated 3 months ago
I am getting this error "Documents must be saved before they can be merged" when trying to use Photomerge - Add Open Documents. Files are off-the-camera jpegs in Adobe 1998. Color space in photoshop is Adobe 98. Warnings for profile mistmatches are all on, and none came up when opening. I can't see anything that would be making any changes during the opening process. There is an asterisk in the tab with the filename.

Here are the system highlights:
Adobe Photoshop Version: 20.0.4 20190227.r.76 2019/02/27: 1205725  x64
Number of Launches: 123
Operating System: Windows 7 64-bit
Version: 7 SP1 6.1.7601.24408
System architecture: Intel CPU Family:6, Model:13, Stepping:7 with MMX, SSE Integer, SSE FP, SSE2, SSE3, SSE4.1, SSE4.2, AVX, AVX2, HyperThreading

Please let me know if I am missing something that should be obvious. Many thanks in advance.


Photo of Matt Greenslade

Matt Greenslade

  • 36 Posts
  • 5 Reply Likes

Posted 1 year ago

  • 1
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 2914 Posts
  • 1251 Reply Likes
An asterisk in the file name tab means that Photoshop did make some changes. Do you perhaps have some kind of script being applied via the Script Events Manager? 

Also check your color management settings and Photoshop file handling preferences. JPEG's coming out of the camera usually do not have an embedded profile, but instead a naming convention is used. AdobeRGB files have an underscore as first character of the file name. If Photoshop embeds an AdobeRGB profile on opening, that could be your change.
(Edited)
Photo of Matt Greenslade

Matt Greenslade

  • 36 Posts
  • 5 Reply Likes
Hi Johan,

I don't have any scripts being applied. When I close the jpegs there is no prompt to save changes, which makes me think it's not a problem with actual changes to a file.

I checked the settings. The files have the underscore, are recognized in Photomechanic and Photoshop as being Adobe98. My photoshop color settings have Adobe98 as default, and the warnings are set to alert for missing / mismatched profiles. I'm pretty sure your're right about the cause being the way Photoshop is handling the profile.
Photo of Bryd Wynn

Bryd Wynn

  • 1 Post
  • 0 Reply Likes
I'm using PSE14 and get this error. I simply saved all the files in psd format and it works brilliantly.