Lightroom Classic: Photo Edited and saved in Photoshop fails to show in Library

  • 1
  • Problem
  • Updated 7 months ago
  • (Edited)
When I open a photo from Lightroom Classic in Photoshop for editing it works fine until I save it. With the old version of Lightroom the photo saved in Photoshop automatically shows up in the library in Lightroom. Since upgrading to Classic periodically the photo fails to show until I close Classic and restart it. It does not happen all the time but often enough to be a bother. I am using a Macbook Pro computer.
Photo of Terry Alexander

Terry Alexander

  • 11 Posts
  • 0 Reply Likes

Posted 7 months ago

  • 1
Photo of Rick Spaulding

Rick Spaulding, Champion

  • 564 Posts
  • 216 Reply Likes
That's strange! It's hard to find a solution for intermittent problems. Is there anything you can think of to reproduce this consistently?
Photo of Terry Alexander

Terry Alexander

  • 11 Posts
  • 0 Reply Likes
I’ve tried to identify a common thread but there really does not seem to be any. Before the upgrade the process worked very smoothly. Now I might do two or three edits with no problem and then it pops up - I restart Classic and it clears. I’ve even gone back into Photoshop and resaved the image thinking it might have failed, but it always tells me the image exists and gives me the option to overwrite it.
Photo of Rick Spaulding

Rick Spaulding, Champion

  • 564 Posts
  • 216 Reply Likes
I mentioned this on your other post but does restarting your computer help? I don't mean to be overly simplistic. I'm just backing up to square one, so to speak.
Photo of Terry Alexander

Terry Alexander

  • 11 Posts
  • 0 Reply Likes
not sure - I have been on and off the computer several times since upgrading and it still occurs everytime I’m in Classic.
Photo of Kathleen Johnston

Kathleen Johnston

  • 1 Post
  • 0 Reply Likes
I am having a similar problem.  I edit a photo in LR, send it to Photoshop for further editing, then save and close it.  It shows up in the Develop Module as before as 1of 2, but if I switch to the library to do an export it shows 2 copies, but neither shows my Photoshop edits.  I cannot export an edited version of my photo now.