Performance improvements ? Seriously ?

  • 2
  • Problem
  • Updated 7 months ago
LR 7.2 update : Slow, unresponsive, freezing

I'm using LR Classic CC on the following (weird) configuration Mac Book Pro mid-2012 (i7 8 cores, 16 Gb RAM, 1 Tb Samsung SSD) running Windows 7 .

The first catalog I tried contains around 15000 pictures, it's stored locally on a SSD Samsung EVO PRO  but my files are stored on a Synology NAS connected to my personal network (which is connected in 1 Gbits/sec).

.XMP files are activated.

when opening the catalog for the first time after upgrade, I had to store some pics shot during the week-end, it was very weird.

The pictures didn't show in the library, only grey boxes.

I had to regenerate the whole (15000) set of standard previews and then optimize the catalog, I was then only able to browse my picures with far much less performance than before. A real nightmare.....

Edition was even worse. I experienced a lot of problems.

- In Edit mode, impossible to switch from one picture to the other.
- Pressing F to switch to full screen works but it was impossible to switch bac to normal screen, had to close LR via the task bar

And so on and so forth.....

This release is a piece of crap.....
Photo of Roland Houziaux

Roland Houziaux

  • 4 Posts
  • 1 Reply Like
  • furious

Posted 7 months ago

  • 2
Photo of Robert Frost

Robert Frost

  • 393 Posts
  • 52 Reply Likes

On the contrary, it's great using a modern desktop and the latest version of Win10. My suggestion would be to update your computer and OS.


Bob Frost

Photo of Roland Houziaux

Roland Houziaux

  • 4 Posts
  • 1 Reply Like
I had no problem at all so far, your comment is completely useless.....
Photo of Christian Fürst

Christian Fürst

  • 94 Posts
  • 27 Reply Likes
I wouldn't call it completely useless, since the remarks may indicate, that improvements may be connected to latest and most powerful equioment!
Photo of Christian Fürst

Christian Fürst

  • 94 Posts
  • 27 Reply Likes
I can see limited performance improvements in export and imports while I can also see problems during imports not showing imported pics till the completion of imports. My system i7, 32 GB RAM, Win 10, LR installed on 1 TB Samsung SSD M II.
Photo of Paul

Paul

  • 26 Posts
  • 12 Reply Likes
There seem to be lots of problems with LR performance on network drives.  I have a Synology NAS too and LR 7.5.1 is awful over gigabit LAN

I'm not sure whether this would work in your weird set up.  But if you install Synology Drive from Package centre, and set your image folder on the NAS as a drive enabled team folder, you will then be able to install the Drive client on your computer and create a sync task to the NAS.

This will copy the images to you local drive.  LR will then see them as local files because they are.  But changes will be auto synced to your DiskStation where they can be RAIDed, backed up etc, and viewed through the web on Photo Station or Moments (although the latter requires some more work.).

The downside is that you have the images your local hard drive and if you have a huge collection, disc space becomes an issue.  But local HDD's are as cheap as chips these days.