People Recognition not working properly in Elements 11 organizer

  • 2
  • Question
  • Updated 4 years ago
I recently imported a huge photo collection into Elements 11 organizer. I am patiently working through all the photos to add tags. I noticed that the people recognition is not working properly in my catalog. Initially when I clicked "Add People" - elements organizer would run the people recognition and ask me to name the faces it found and then automatically tag every occurrence of that face with the name. Now when I run the people recognition, I receive a message saying "No new people found in your selection" (which is not at all true). How can I fix this problem? I can manually tag people but considering I have thousands of photos to work through it is not a viable option. Thanks for your help.

I have set the Media Analysis preferences to default settings thus "Analyze photos for People Automatically" is selected. Additionally, under the "View" tab - "people recognition" is also selected.
Photo of Meenal Deshmukh

Meenal Deshmukh

  • 1 Post
  • 0 Reply Likes

Posted 5 years ago

  • 2
Photo of Andromeda14

Andromeda14, Employee

  • 105 Posts
  • 7 Reply Likes
Some answers to query:
1. 'No new people found in your selection': To avoid this, please select a small set (which you want to name) and try 'add people'.
2. How to add people manually? Just select the image of a person, right click it and select 'Add a Person' and tag this image. To see people tags in right panel, click 'View->Show people in tag panel'.
3. "Analyze photos for People Automatically" preference option: This option run face recognition in background. That is it wil try to detect faces in images. To see the detected faces click on 'View->People recognition' and double click the image to view in SIV.
Please let me know if you need more info on any item.

~Andromeda
Photo of Shane Goodman

Shane Goodman

  • 18 Posts
  • 0 Reply Likes
I have the same problem with PSE12. I haven't been able to get any help in the forum, which is the only official form of support. Am I totally screwed?

Shane.
Photo of vaishali ahuja

vaishali ahuja, Employee

  • 69 Posts
  • 0 Reply Likes
Shane,
You may try the workarounds shared at: http://helpx.adobe.com/photoshop-elem...

Regards,
vaishali
Photo of Shane Goodman

Shane Goodman

  • 18 Posts
  • 0 Reply Likes
I tried those workarounds. I started a new topic.