Lightroom: Pentax Lens profiles not detected

  • 1
  • Problem
  • Updated 6 years ago
  • Solved
  • (Edited)
Hello,

I still experience some problem with lightroom(since 3.x) camera lens correction.

With my Pentax K-5 only 2 of my 4 lens are detected automaticaly.
For those I have to manualy chose "pentax" in supplier name to force the detection.

Bad detection :
smc PENTAX-D FA MACRO 100mm F2.8 WR
smc PENTAX-DA 50-200mm F4-5.6 ED WR

good detection :
smc PENTAX-DA 18-55mm F3.5-5.6 AL WR
smc PENTAX-DA* 16-50mm F2.8 ED AL [IF] SDM

Could you please fix it for DNG and PEF

Thanks in advance
Photo of Benoit Malrat

Benoit Malrat

  • 9 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 1
Photo of Lee Jay

Lee Jay

  • 990 Posts
  • 131 Reply Likes
You can fix it yourself.

That's what "Save new lens profile defaults" does in the Setup area of the Profile section.
Photo of Benoit Malrat

Benoit Malrat

  • 9 Posts
  • 0 Reply Likes
This is not a real patch from adobe, but it does the trick.

Thanks a lot
Photo of Lee Jay

Lee Jay

  • 990 Posts
  • 131 Reply Likes
There probably won't be a real patch.

The problem is, several lenses can have the same lens ID code and not all cameras and manufacturers provide the necessary information to deal with the conflicts. So Adobe has provided this avenue for you to set your own.

For example, if two lenses have the ID code 123, it might guess neither or it might guess the wrong one. This is a way for you to choose which 123 you are actually using.