Photoshop: CC Pen Tool drawing incorrectly on Windows

  • 1
  • Problem
  • Updated 4 years ago
  • (Edited)
All of this begun after this update
http://blogs.adobe.com/photoshopdotco...

So after this:
"Notable Windows specific bugs fixed
...
Pen tool input doesn’t draw correctly
"
What was that bug? I dont know about it. All day long i work with pen tool.
And know the bug even on PS 14.2.1 incorrect pen output when GPU is off and "constrain path draggig" if off.


Note: This topic was created from a reply on the Photoshop: CC pen tool lags topic.
Photo of r-bin

r-bin

  • 28 Posts
  • 4 Reply Likes

Posted 4 years ago

  • 1
Photo of Andy McGinnis

Andy McGinnis

  • 33 Posts
  • 0 Reply Likes
??

I'm sorry Vladimir, I didn't understand your post at all..
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
That is showing the effect of a video card driver bug -- it is not blending the values correctly and leaving artifacts.

Update your video card driver from the GPU maker's website (not Microsoft, and not the system builder).
Photo of r-bin

r-bin

  • 28 Posts
  • 4 Reply Likes
Ok. I have the latest video drivers installed on all PCs to which i have access. As you see i said that this bug is when the GPU support in preferences if OFF. I specially turn it off because the path`s lines are very thin and have low contrast when useing GPU support. I absolutle sure than you, Chris, can reproduce this bug on your own PC with GPU OFF. Draw such path with 4 points. Then drag the middle with left mouse button and holding ctrl-key. Drag the line up and down. You will see all yourself.

P.S. sorry for my poor english (
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
Yes, it isn't an OpenGL bug, but a very general bug in the driver code.
No, I cannot reproduce this bug -- it is most likely driver/GPU specific.

Did you update the drivers from the GPU maker (good), or Microsoft (bad) ?
Photo of r-bin

r-bin

  • 28 Posts
  • 4 Reply Likes
The drivers are from NVIDIA site for expamle for NVIDIA cards. On ATI it is also perpoduced. If You give me an access to you PC via TeawViewer I can show how to get such bug.

But this bug is not so seriously for me as a pen tool delay on putting points when path is drowing with pentool, what was discussed in another topic here.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
If you're seeing it on different GPU brands, then there is something else going on. Do you have any other utilities on those systems that might change the way things are drawn to the screen? (we had problems a while back with LogMeIn drivers causing odd errors)
Photo of r-bin

r-bin

  • 28 Posts
  • 4 Reply Likes
The LogMeIn Hamachi presents butnot so long as i see this bug.

You can see similar bug with ruller.
Turn OpenGL off. May be it importamnt - set win7 theme to no aero (simple) before. Then in photoshop create any doc. Zoom it in so it become larger then screen size. Turn on rulers (Ctrl-R).
Then with handtool move canvas quicky left-rigth up-down in current tab.
You wil see
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
We know about drawing problems with the ruler. But I haven't seen other people reporting problems drawing splines, nor have I seen such problems myself.
Photo of r-bin

r-bin

  • 28 Posts
  • 4 Reply Likes
Do you set the constarain path dragging to OFF in path selection tool?

Path to test must be created in such style:
Make line with two poins with pen by mouse clicking.
Then with pen tool add two additional points at aprox 1/4 and 3/4 position of line length. Then try to drag up-down the middle of the line with mouse when pressing Ctrl-key.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
Yes, and that option has nothing to do with the way the splines are drawn.
Whatever you are seeing is most likely specific to your systems.
Photo of Alexander Kireev

Alexander Kireev

  • 1 Post
  • 0 Reply Likes
I have the same problem.