Photoshop: Patch Tool Functionality Issue with recent updates

  • 2
  • Problem
  • Updated 2 years ago
  • Solved
  • (Edited)
Previously this was a common technique I used and taught in many of my workshops. But since the recent updates, possibly 16.1, the functionality/process no longer works the same.

Here is a common sequence that is now missing.

1) Make active selection on a layer with a full image on it. (start with a lasso, marquee, whatever)
2) Using the move tool, hold option and drag a floating copy of that selected area 
3) While it's in this temporary state, "floating", Transform, distort, flip, etc, of that floating set of pixels 
4) Apply transformation (don't deselect), but while still floating switch to the patch tool. 
5) Set to destination, and push floating selection to area you wish to composite/blend into. 

Traditionally at this point, it would act like a patch tool push of pixels and blend into the target area as a nice composite but with the alterations it would apply with the modified appearance. This was great for taking one tree and making it many trees, clouds, street lights, etc...

But now, it just disappears...
No blend, no result, nothing.
Photo of Mark Heaps

Mark Heaps, Champion

  • 62 Posts
  • 24 Reply Likes
  • blargh

Posted 3 years ago

  • 2
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15632 Posts
  • 2368 Reply Likes
Official Response
This issue should be fixed by the Photoshop CC 2018 (19.1) update that was released today.
Photo of photoshopguru_GER


  • 38 Posts
  • 9 Reply Likes
hi jeffrey, hi marc,

no it isn't. the content ist is still disappearing, the behavior is still different and not of any use.  i reported this first time oct 2015 (!). please watch the video linked here:

the technique is slightly different but the effect is the same.
i was in contact with:
russel brown
yuko kagita

and a lot of people from the german support which were not even able to reproduce the error. and the patch tool functionality issue is still not fixed three years later.

to be honest – i've given up hope. the alternate technique using the content aware move tool in copy mode does not allow all kinds of transformation.

fixing this would make me very happy.

thanks a lot
Photo of Serah Sauser

Serah Sauser

  • 1 Post
  • 0 Reply Likes
Im having the same problem even with the update
Photo of photoshopguru_GER


  • 38 Posts
  • 9 Reply Likes
sadly, no answers or solutions. as i said – first appearance for me was october 2015, nothing changed.