Paste Develop Settings Slow

  • 1
  • Problem
  • Updated 4 months ago
Hi All,
Since roughly LR Classic 8.3 pasting develop settings became very slow. I have finally stumbled into a fix for it - by disconnecting my hard drive which stores my RAW files the speed is back to where it used to be. 

It's an external raid box and when its connected and I paste develop settings all the activity lights light up and it appears that LR Classic becomes slow as a result of HDD bottleneck. I do have "Use Smart Previews instead of Originals for image editing" selected but I wonder if somehow this setting is being ignore for copy/paste?

I am running an iMac Pro, 18 core, 64GB ram and can repeat this issue 100% of the time.

Happy to provide more information.



Photo of Peter Bendevis

Peter Bendevis

  • 3 Posts
  • 0 Reply Likes
  • We can fix this

Posted 4 months ago

  • 1
Photo of Bill

Bill

  • 298 Posts
  • 56 Reply Likes
On Windows I replaced an external drive with an internal drive and some functions sped up by a factor of ten. Fortunately I have a tower case and not a laptop (yes, an iMac is a laptop inside a monitor) so have much more expansion capability. By using a SSD on a PCIe adapter card on the PCIe bus, I've removed all I/O bottlenecks from my system. This drive also uses RAPID mode. I had the Lightroom cache on a separate SATA SSD and moving it to the SSD on the PCIe bus with RAPID mode was a significant performance improvement. 
Photo of Peter Bendevis

Peter Bendevis

  • 3 Posts
  • 0 Reply Likes
I store my catalog (and previews etc.) all locally on the internal flash storage.

My point was more so that I believe there to be a bug in Lightroom as the speed should be the same under both scenarios since I have "Use Smart Previews" selected. By removing my external storage (which is on Thunderbolt which essentially is the PCIe bus) I can force LR to only use the smart previews and the expected performance bump of using smart previews returns.

Under both scenarios the Catalog and Preview files are on the same internal drive so I'm thinking a quick bug fix should resolve this. :)
Photo of Paul Manuel

Paul Manuel

  • 12 Posts
  • 1 Reply Like
Peter

You are assuming that the problem you are having is the result of a bug in Lightroom.

I have a similar setup (iMac Pro 10  core, 64GB Ram, external RAID). I keep the Lightroom catalog, previews and current year's raw files (Nikon NEFs) on the iMac Pro's internal drive and and the remainder, dating back to 2000, on the external RAID connected via Thunderbolt 3.

Most of my day to day editing is on files that are on the internal SSD. However when I (frequently) re-visit raw files that live on the external RAID, I am not experiencing any issues when I copy and paste develop setting between. I have just tried a few to confirm this.

While I do not have any suggestions to specifically address your problem, it may be worth troubleshooting your setup:
  • Check System Information - Thunderbolt to find out the speed at which your external drive is connected. If it is a Thunderbolt 3 device you should see "Up to 40 Gb/s x1".
  • Try another cable between your drive and the iMac (make sure that it is a genuine Thunderbolt 3 cable).
  • Try another Thunderbolt port on your Mac.
Photo of Olivier MULLIE

Olivier MULLIE

  • 61 Posts
  • 26 Reply Likes
Hello peter

Do you have automatically write modifications in xmp checked in your catalog preferences ? This setting slows Lightroom because it writes every change in the DNG (or sidecar).
If you plug out your external drive, LR uses the smart preview for all the process. Very fast !
It synchronizes when you plug in this drive.

Unchecked this and save your changes in your raw at the end of your work (if you want to synchronize with an other soft)

Excusez-moi pour mon pauvre Anglais...
(Edited)
Photo of Peter Bendevis

Peter Bendevis

  • 3 Posts
  • 0 Reply Likes
Olivier - Your comment seems like it is on the right path. However, my xmp setting was already correct and enabling or disabling it causes no change in performance. I wonder if perhaps this checkbox is not functioning properly. I also tried a new catalog and see the same results.

Paul - Thanks for your comment. I can transfer at >600MB/s off the Thunderbolt raid so bandwidth is not an issue. However I believe you have missed the crux of the issue as since I have told LR Classic to use the Smart Previews and not the Nikon NEFS for developing, the speed should be the same whether or not LR can see the raw files.

The speed difference is roughly 10x.

Here is another clue I just discovered: when I paste and have "Auto Sync" turned off it will paste at normal speed (with the external drive connected). If I paste and have "Auto Sync" turned on, the previously described behaviour shows up. I wonder if having Auto Sync engaged is causing LR to sync on all selected images for each image it is pasting? ie. it would end up pasting/syncing n^squared times where n is the number of images selected for which I am pasting the develop settings on to.




Photo of Olivier MULLIE

Olivier MULLIE

  • 61 Posts
  • 26 Reply Likes
Peter, if you have « Auto Sync » turned on. Why do you paste, it’s done automatically...