Lightroom: Panorama Merge Stuck at 100%

  • 2
  • Question
  • Updated 2 months ago
  • Answered
  • (Edited)
I have a set of pictures to be stitched to a panorama. I have taken each shot in 3 different exposures, so I have a total of 18 pictures. I first tried the HDR Panorama Merge on these 18 RAW photos, but the process was taking too long. So I did HDR Merge on each of the 6 different shots and from these 6 HDR images, I planned to do a Panorama Merge. However, when the progress bar is always stuck at 100% on Gathering Data, not giving me the preview.

I have tried restarting Lightroom and my desktop but to no avail. I am using iMac (Late-2015). macOS Mojave, Processor 2.8GHz Intel Core i5, 8GB 1867 MHz DDR3.

Not to mention my iMac lags significantly while Lightroom is open. I usually have Google Chrome, Spotify and WhatsApp running in the background but to my knowledge, these are not heavy on processes.
Photo of Pek Jun Rong

Pek Jun Rong

  • 7 Posts
  • 0 Reply Likes

Posted 3 months ago

  • 2
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5595 Posts
  • 1183 Reply Likes
Please go to Help>System Info... in Lightroom and get us your current installed version number please. 
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5595 Posts
  • 1183 Reply Likes
What is the Camera used here?
Photo of Pek Jun Rong

Pek Jun Rong

  • 7 Posts
  • 0 Reply Likes
Canon EOS 80D with EF-S 18-135mm f/3.5-5.6 IS USM kit lens
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5595 Posts
  • 1183 Reply Likes
Given your specs, I would expect a time less than two minutes for a merge of 3 Canon 80D files. 

What is the free space on your drive?
Photo of Pek Jun Rong

Pek Jun Rong

  • 7 Posts
  • 0 Reply Likes
My cloud drive doesn't have free space now
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5595 Posts
  • 1183 Reply Likes
That may be the issue.  Can you free up some space on that drive?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15462 Posts
  • 2292 Reply Likes
Does this happen with all sets of panoramas, or only this set? If it's set specific, can you post a link to your set of files for us to troubleshoot with?
Photo of Pek Jun Rong

Pek Jun Rong

  • 7 Posts
  • 0 Reply Likes
Not just this set. I'm also not able to get the link because Lightroom CC is taking forever to generate the URL for me
Photo of Kirill Konshin

Kirill Konshin

  • 13 Posts
  • 1 Reply Like
I have the same issue with version 2.3. It was merging fine when my library was ~100 pictures, but now when I uploaded the rest of ~4000 images it stopped working.
In my case it is stuck on "Gathering Data... 100%".
(Edited)
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5595 Posts
  • 1183 Reply Likes
I am sorry to hear that the 2.3 update didn't fix the issue for you. At this point, we would need to get a few sample files from you that fail so that we can test with your files. Are you willing to share files with us?
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5595 Posts
  • 1183 Reply Likes
Kirill, 

I tested with your files (thank you for those) using Lightroom Desktop 2.3.  I was able to successfully merge an HDR, a Pano and an HDR/Pano from your files with no issues.

I would recommend you reset your preference file and try again.  If that doesn't cure it you may want to do a clean install of the App. 

Preference File reset:

A Preference File will survive a Lightroom uninstall/reinstall. Sometimes weird behavior is corrected/cured by resetting the preferences. 

Reset Procedure:

1. Close Lightroom.
2. Hold down [Alt/Opt]+[Shift] while restarting Lightroom. 
3. Overwrite the Preferences when prompted by the dialog.
4. Close Lightroom.
5. Restart Lightroom.

Does the behavior continue after resetting the preferences?

Clean Install:

Close Lightroom
Restart the computer
Use the Adobe Creative Cloud App to uninstall Lightroom
Restart the computer
Install Lightroom  via the Creative Cloud App without launching any other programs.
Restart the computer
Launch Lightroom
Wait 5 minutes

I am going to post these same instructions into your other thread.
Photo of Kirill Konshin

Kirill Konshin

  • 13 Posts
  • 1 Reply Like
I have tried both options, it did not help. And as you see, it's not just my problem.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5595 Posts
  • 1183 Reply Likes
Are you by chance clicking on a collapsed stack of images instead of group of individual images?
Photo of Kirill Konshin

Kirill Konshin

  • 13 Posts
  • 1 Reply Like
I am :) holy hell, it works when I selected individual photos!!! Moreover, when I expanded the stack and selected all photos in it and made a panorama it went well too. That's a bummer... not intuitive at all...
(Edited)
Photo of Kirill Konshin

Kirill Konshin

  • 13 Posts
  • 1 Reply Like
Rikk, may I ask you to also take a look at this issue: https://feedback.photoshop.com/photoshop_family/topics/no-star-rating-in-filmstrip-of-lightroom-cc-2-3, I don't know how to mention you there. Seems you are the guy who can assist with it )
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5595 Posts
  • 1183 Reply Likes
I spoke to the engineer regarding stacks and we are looking into that behavior. For now: expand the stack and then click on the individual images. 
Photo of Kirill Konshin

Kirill Konshin

  • 13 Posts
  • 1 Reply Like
Yes, so far this workaround is okay.