Lightroom 6.2/2015.2: Other import issues not commonly listed in the main complaint thread

  • 4
  • Problem
  • Updated 3 years ago
  • (Edited)
I can no longer drag-and-drop onto the Library main window (loupe/grid) area to initiate an Import. This was how I Imported almost everything in the past 8 years. I typically hand-copy everything to separate folders then do an Add import by DnD.

I can no longer successfully select multiple folders from the Browse Computer are in the new import panel to Import multiple folders. The multiple folder names are listed with quotes around each one in the Windows folder selection panel, but only the first one is used by the Import process.

Also Import's Browse Computer doesn't seem to remember where I last imported from and is remembering a different place used some months ago, requiring my having to re-browse several levels up and back down each time even if all the folders I'm trying to import from are peers of each other.

The only way to import from multiple folders, now, seems to be use the tedious LR Import Folders area of the Import panel, itself, having to expand and expand each level down to the correct parent folder.

Seeing as I've just copied one or more folders to my HD and have Explorer open in that parent folder, it would be the quickest if I could just DnD from where I am.

There is more to the Import process than the selections that can be made, there is also how it's worked for years and years, so besides restoring the various options that were removed, please also restore the ways it has worked in the past, like DnD import and multiple-folders allowed to be selected and used from the OS folder-selection dialog like before.
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2611 Posts
  • 333 Reply Likes

Posted 3 years ago

  • 4
Photo of Julie Kmoch

Julie Kmoch, Sr. Development Manager

  • 99 Posts
  • 34 Reply Likes
Thanks for the feedback, Steve. We'll take a look at the drag and drop issue.

Regarding selection of multiple folders, do you prefer using the new, simple OS dialog (the oval "Browse Computer" button, in English) or our older style custom tree view under "My Computer"? I believe multiple folder selection still works there.
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2611 Posts
  • 333 Reply Likes
I would prefer DnD, but if Explorer isn't open or LR has been enhanced to disallow it, I'd prefer the use a method that allows selecting of more than one folder at a time and also allows me to copy/paste a path into the Select Path (or whatever it's called) box. I generally detest having to expand folder trees one at a time, either in the OS panel or in LR. My photos are usually about 6 folders down from the root of my external drive. Having used DnD for the last however many years, I am not sure which folder-selection dialog you're talking about, but if it's the one I'm thinking of, I dislike it immensely.

Additionally, I use the date-created on the HD folder to tell me which one(s) I've just created and need to be added to LR so any method that doesn't let me see this date is bad. The Details view in Explorer sorted by date is what I normally use. There is no date on the LR folder tree, certainly, and maybe not on the OS dialog your referring to.

My use case is that I've just copied multiple folders from my camera memory card(s) and if I feel like it, I've also gone to my phone and found images from the last few days or weeks and also copied them into folders named using the date and the subject/event/location, and these folders are in a year-month parent folder or two.

I have explorer open on the parent folder and have LR open as well. How do I import these efficiently.

In the past I'd reverse sort folder date-subject folders in the parent folder by date created so the ones I've just copied are at the top, I'd click-shift-click to highlight the folder names, and drag-and-drop onto LR's main Library area, where the Import panel pops up and I click the Import button and wait a few minutes and then everything is ready. Now I have to cross-reference my folders in LR or Browse Computer with a sorted list of folders in another Explorer window and pay attention that I've not importing one that's already in LR or miss one. Because I don't offload things that often, my phone photo folders are likely interspersed back in time with the DSLR folders so I can't just choose the last however many folders sorted by folder name and know I'm importing the correct set.

The bottom line is that I have multiple folders and know which ones I want to Add based on the folder creation date. DnD allows me to import efficiently while the new methods do not.
Photo of Jim Wilde

Jim Wilde, Champion

  • 269 Posts
  • 82 Reply Likes
Drag and Drop from Explorer or Finder (using single or multiple selected folders) works without problem on my Win10 desktop and my OSX 10.9.5 MBP, using the LR2015.2.1 build. To be precise, dragging from Explorer/Finder and dropping onto the loupe or grid window in the Library module will initiate the Import dialog (main screen) with the selected folder(s) highlighted in the My Computer section of the left-hand panel, and all the eligible photos in the folder(s) showing and selected in the centre window. Just need to make whatever selections from the right-hand panel and click on the Import button.

So as far as I can see, the Drag and Drop process works pretty much the same as it always did....but as I don't use that import method very often, I may be missing some crucial aspect that's making it unworkable for you.
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2611 Posts
  • 333 Reply Likes
I have been able to get DnD Import to work if I double-click on an .lrcat file and let Windows start up LR as the defaut opener of such a file, but DnD Import doesn't work if I open LR via a program shortcut and let LR open its MRU catalog like I always used to do.
Photo of SteveMVP Sprengel

SteveMVP Sprengel

  • 2 Posts
  • 1 Reply Like
I have been unable to get DnD Import to work by selecting a previous catalog for at least a week. So something iffy is still occurring. This is on Windows 10 with LR 2015.2.1. In the past it used to matter whether I ran LR with Run As Administrator or not, but now changing that doesn't matter, anymore, either.

I wish DnD Import worked more reliably. It sure is a bear to get the new way to work, having to expand so many folders and not being able to select more than one from the OS dialog.
Photo of Ann Shelbourne

Ann Shelbourne

  • 149 Posts
  • 109 Reply Likes
The Lr 6.1.1 way is the only method for Importing into Lr which is acceptable to me.

I have reverted to Lr 6.1.1 and will not be upgrading beyond 6.1.1 until later versions of Lr return to using that method.