Lightroom CC: Option-delete only deletes the last selected photo, not all selected photos

  • 1
  • Problem
  • Updated 10 months ago
  • Solved
  • (Edited)
After selecting multiple photos in the strip at the bottom, I can delete them all by control-clicking and selecting "Delete 4 Items...", but if I try to do the same with the keyboard using option-delete then only the last photo is deleted.

This is my first time using Lightroom and I have to say I'm pretty shocked. This is the gold standard of photo editing? An incredibly common command flat-out doesn't work in a product that should be very mature. There are things to like but I don't want to get into this expensive ecosystem if this is the level of quality to expect. Is this sort of thing normal in the Adobe world?
Photo of Sami Samhuri

Sami Samhuri

  • 2 Posts
  • 2 Reply Likes
  • unimpressed

Posted 10 months ago

  • 1
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 5167 Posts
  • 2018 Reply Likes
Switch to Grid view then try it.

There's a basic principle involved here, that once you understand it makes much more sense:

In Grid view, a command affects every photo, because LR knows you're looking at multiple photos.

In Loupe/Detail view, a command only affects the main photo you're looking at, because Lightroom isn't sure whether you're looking at that one photo or the filmstrip, and you might not realize you have more than one photo selected.

If you right-click on the filmstrip, it'll apply to all selected because again, you're clearly looking at multiple photos.
Photo of Sami Samhuri

Sami Samhuri

  • 2 Posts
  • 2 Reply Likes
Thanks Victoria! I feel a bit sheepish now as that makes perfect sense. I still find the UI a bit strange but that’s not a big deal.