Photoshop Elements: Warning when opening CS5 PSD file in Photoshop Elements 6. Are they compatible?

  • 1
  • Question
  • Updated 7 years ago
  • Answered
  • (Edited)
Can someone please help? I have CS5 files from a designer that I'm trying to open in Photoshop elements 6. They open but throw errors that data is missing and formatting is off.

One error says: Some text layers might need to be updated before they can be used for vector based output...Some text layers contain fonts that are missing.

Are CS5 PSD files compatible with PSE6? If not, do I have to BUY CS5 to open the files correctly
Photo of Kelly mantia

Kelly mantia

  • 2 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 766 Reply Likes
Photoshop PSD files are compatible all the way back to Photoshop 3.0.

What you received is a warning, not an error. It's telling you that some features used in the file are from a much newer version of Photoshop, and that some of the data will be ignored because your older version can't read the newer features. Text especially will change formatting because CS5 has a newer version of the text engine than PSE6.

Even with the warnings, you should be able to open the file.
Photo of Kelly mantia

Kelly mantia

  • 2 Posts
  • 0 Reply Likes
I am able to open files. I'm concerned that the formatting is mess up. If I upgrade to PSE10, will this solve the problem?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 766 Reply Likes
Yes, PSE 10 should be more compatible with newer features (especially text) from Photoshop CS5.