Lightroom 6.7: Opening photos in Photoshop from Lightroom using Edit In does not work correctly for some operations

  • 30
  • Problem
  • Updated 1 year ago
  • Solved
  • (Edited)
Using Lightroom CC2015.7 and Photoshop CC2015.5.1

1 )If Photoshop is CLOSED and then I "Open as Layers ....." the computer will just sit there doing nothing.  If I click Photoshop to open it then the operation will complete and the photos will be layered.  I THINK THIS IS BUGGY BEHAVIOR

 As a side note, this BUG affects the Panorama and HDR the same way.   Photoshop has to be opened manually.  The "Open as Smart Object works correctly.

 2) If Photoshop is OPEN and then I "Open as Layers ...." the photos will open as layers in Photoshop

 3 )If Photoshop is CLOSED and I  "Edit in Adobe Photoshop ..." Photoshop will open and the two photos are loaded as separate objects.  This is the expected behavior.

I think this is a change in behavior in Lightroom CC2015.7

Photo of Robert Somrak

Robert Somrak, Champion

  • 353 Posts
  • 117 Reply Likes

Posted 3 years ago

  • 30
Photo of dbur

dbur

  • 35 Posts
  • 2 Reply Likes
I think I see it still happen randomly.
Photo of Christopher Gordon

Christopher Gordon

  • 2 Posts
  • 0 Reply Likes
What have you been doing for a fix?
Photo of dbur

dbur

  • 35 Posts
  • 2 Reply Likes
The last updates seemed to fix it for a while, but the same work arounds still work.  Try again or open PS first.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15462 Posts
  • 2293 Reply Likes
Which behavior are you seeing? This specific issue was fixed in 6.8. Are you seeing this issue instead?: https://feedback.photoshop.com/photoshop_family/topics/lightroom-cc-2015-8-edit-in-photoshop-cc-2017...
Photo of dbur

dbur

  • 35 Posts
  • 2 Reply Likes
No.  Not that.  For me it seems to be the same issue this thread is about but less often.
Photo of Bill Lackey

Bill Lackey

  • 1 Post
  • 0 Reply Likes
Has this issue ever been resolved. I am having the same problem and none of the workarounds mentioned work.
Photo of Naomi Lessels

Naomi Lessels

  • 1 Post
  • 0 Reply Likes
I’m having the issue where I can’t open an image from LR in to PS. When I click edit in PS it opens desktop assuming I want to edit an image from there.
I spent 45 mins on hold with adobe yesterday then was told I’d get a phone back. 90mins later I tried again and again I was told I’d get a phone back within 2-4 hours. I’ve heard nothing after spending 6 hours at home on my day off. I have the latest versions of PS and LR, LR classics and the LR cloud version but it’s not syncing ... very frustrated. I did also uninstall PS and reinstall but this didn’t help either. Thoughts ??