OpenCl Unavailable in PS CC 2014

  • 2
  • Problem
  • Updated 4 years ago
Just updated to Photoshop CC 2014 and the Liquify Filter is more or less unusable(esecially with my Wacom Tabet/Pen).

I am pretty sure this is because I cannot enable OpenCL in Preferences>Performance>Use Graphic Processor>Advanced settings. The checkbox for "Use OpenCL" in that dialog is disabled/greyed out.

This is not the case for my Photoshop CC installation on my same PC where "Use OpenCL" is checked and my liquify filter works fine.

See below for my video card info. And yes, I do have the latest greatest driver.

Anybody have any clue as to what's going on here?

Running Windows 8

Video Card
Card name: NVIDIA GeForce GT 625
Manufacturer: NVIDIA
Chip type: GeForce GT 625
DAC type: Integrated RAMDAC
Device Type: Full Device
Device Key: Enum\PCI\VEN_10DE&DEV_104B&SUBSYS_844C1043&REV_A1
Display Memory: 4047 MB
Dedicated Memory: 1999 MB
Photo of Timothy Heffernan

Timothy Heffernan

  • 2 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 2
Photo of Steve Slapahoe

Steve Slapahoe

  • 1 Post
  • 0 Reply Likes
I have the exact same issue on my Alienware m17x r4 Intel hd 4000 - GTX660m... Greyed out in 2014 but not in the older CC version. It was also crashing constantly. Updated both card drivers and the crashing has slowed but still no "opencl" option available.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 823 Reply Likes
Most likely there is still a problem with the driver code.
And make sure you update the driver from the GPU maker's website, not Microsoft or a system builder.