Lightroom Classic 8.4: Online sharing broken

  • 1
  • Problem
  • Updated 2 months ago
  • (Edited)
I thought I understood how sharing to the cloud (and other Lightroom versions and devices) works, but it appears to be broken with Lightroom version 8.4. At least for sharing collections (and working on or posting them), if they originate with Lightroom Classic. Creating a collection in LR Classic no longer makes those images available to my version of LR CC (on the PC) nor to LR iOS (iPad or iPhone) or LR Web. Once I reverted to 8.3.1, everything works correctly (or at least as expected). Note that when importing with LR Classic, only smart previews are uploaded to the cloud, and then shared to the other versions and devices, and that’s what my workflow expects (otherwise I would soon run out of the 1T storage space.). I’m running on a 4K Lenovo Laptop (2018) with a current version of Windows 10. Anyone else have this problem, or is it just my particular configuration? This also means the files are not accessible to Adobe Portfolio
Photo of Robert Ikenberry

Robert Ikenberry

  • 6 Posts
  • 1 Reply Like

Posted 2 months ago

  • 1
Photo of Edmund Gall

Edmund Gall

  • 63 Posts
  • 19 Reply Likes
Hi Robert! Syncing is working as it was before for me (well, actually better**), so I can recommend checking the following:
  • Is syncing paused (i.e. all syncing, via a toggle play/pause button hidden near the identity plate in the Library Module)?
  • Is syncing enabled for the new collection (i.e. the double-arrow sync icon appears to the left of the collection's name on the left-side Collections panel in the Library Module)?
  • When creating a new collection, did you tick the box next to the option to automatically sync the new collection? If you untick that, then the next time you create a collection it remains unticked (it's a 'sticky' tick-box) so new collections won't be automatically synced.
Hope this helps!
Ed

** Syncing is working better for me because for the last year LR CC on my Android tablet stopped syncing new photos & collections (after about 2,300 photos out of 2,500+). However, it suddenly started working after 3 things happened earlier this week (so I'm not sure which one, or if all, of the following caused it):
  • My broadband was upgraded from slow copper-based ADSL to FTTC (fibre+copper-based) ADSL, boosting my bandwidth significantly.
  • I updated LR Classic on my iMac to latest version & purged the video and Camera Raw caches.
  • I updated LR CC on my tablet to the latest version: it spent a very long time upgrading the database on the tablet (in fact, I think it hung - I killed the app after giving it the better part of a few hours), but I got back nearly 1GB of storage space afterwards. After restarting LR CC on the tablet, the missing photos & collections got fully synced.
Photo of Robert Ikenberry

Robert Ikenberry

  • 6 Posts
  • 1 Reply Like
Thanks Ed.  I have checked/tried those suggestions.  Also turned the flags on and off several times and restarted LR Classic and LR CC as well as rebooting the computer...  Still no joy.  The Preferences page showed some of the files as preparing to sync, but they never did.  I appreciate your suggestions. I have also had 550 files trying to sync for a year or so (obviously this is from long before 8.3, let alone 8.4) I assumed this is because I inadvertently had numerous files with the same file names (one of my Nikons had turned over 10,000 and started duplicating files with a new camera), I foolishly started deleting some of the "duplicates" on the primary drive, then had to copy most of them back when I figured out what was happening.  The sync on those never did get straightened out and I don't know which files LR is still trying to sync there.  But this is a completely new issue and only started with 8.4...
(Edited)
Photo of Edmund Gall

Edmund Gall

  • 51 Posts
  • 18 Reply Likes
As far as I know, if image files have the same name then they must reside in different physical folders (as the operating systems - Windows & macOS - don't allow files with the same name to reside in the same folder). So, LR should be able to sync those fine. I think that risk (the automatic reuse of old image numbers by cameras) was partly why I chose early on to use a default naming convention during import into LR that adds the YYYYMMDD date to the name (so there's no risk of duplicate names).

Have you ever logged into your Lightroom for Web account to see if the 550 files missing from your tablet ever made it to your Adobe CreativeCloud storage? If they haven't then the root cause may lie with LR Classic. Just right-click on any of your synced collections and choose Lightroom Links -> View on Web option (you'll need to login with your AdobeID).

Also, if you go to the Lightroom Sync tab in LR's Preferences, click on the Sync Activity triangle at the bottom of that tab to view any sync errors. Double-click on each line with the status Error to have LR Classic automatically switch to that photo in the Library Module's Collection Panel's grid view. The sync icon in the upper right corner of the photo's thumbnail will look slightly different and hovering the mouse over it will show a popup tooltip that says there's been an error syncing the photo. Click on that icon on the thumbnail to force LR Classic to resync the photo: hopefully that works and then that photo's record in the Sync Activity list will disappear. Repeat for each unsynced photo (I know, it's slow for 550+ photos).

The ultimate solution to stagnant syncing problems, if the above doesn't work (or if you don't want to sort each photo individually), involves going to the Lightroom Sync tab in LR's Preferences, and clicking the Delete All Synced Data button: this deletes all synced data from Adobe's CreativeCloud storage and re-syncs it from the catalog. However, I considered this to be the option of last resort for me because in the early days when this was provided, it used to delete any comments/likes added via online proofing with clients via Lightroom for Web. I don't know if that behaviour has changed, but if you don't have any comments/likes that you need to keep, then it's an option for you to consider. It does not delete any data already in your LR Classic catalog (but, as with any major change to important data, ensure you make a copy of the catalog before)...

Photo of Suhas

Suhas, Employee

  • 17 Posts
  • 4 Reply Likes
Hi Robert, Sorry about the issue. Please send us the Diagnostic report to analyse the problem further. You can generate diagnostic report by following below steps.

1. Go to preferences -> Lightroom Sync
2. Press and Hold alt/option.
3. Generate Diagnostic Report.
Please share the zipped file after that. 

Thanks