Olympus E-PL7 demosaic problem

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)
See this screenshot: http://i.imgur.com/Wia6xSn.jpg
It's a 400% close-up of an .orf raw file. Note the indicated area (and elsewhere) where 2x2 pixels are nearly the same colour and produce blocking artifacts. Lightroom version is 6.6, image was only imported with no additional adjustments.

Edit: Capture One and Olympus Viewer don't have the same problem. Here's a screenshot from Olympus Viewer: http://i.imgur.com/n3QXKJl.png
Photo of zqtxyunx

zqtxyunx

  • 5 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2611 Posts
  • 333 Reply Likes
Having a raw file to experiment with would be helpful.  Use dropbox.com or similar.
Photo of zqtxyunx

zqtxyunx

  • 5 Posts
  • 0 Reply Likes
Sounds cool. I've found a public raw file with similar issues. See http://i.imgur.com/w6oH1jP.png and http://i.imgur.com/38aAA6X.png for some indicated trouble areas. I can't direct link to the raw file, but it's on this page: http://www.photographyblog.com/reviews/olympus_epl7_review/sample_images/ and the file name is olympus_epl7_14.orf. I've indicated which thumbnail to choose here: http://i.imgur.com/IQgN4YJ.png

Hope that helps, please pass the information along to your Adobe contacts so they can hopefully fix it!
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2611 Posts
  • 333 Reply Likes

As further reference...

Here are a few of the trouble spots as indicated with sampler droppers on the lower half of the raw:


Here is a magnified area of the first three droppers in the green-red encircled area:


Here is the same area in Raw Digger RGB Render which is smoother:


Here is a Raw Digger composite where you can see the actual RGBG pixels before demosaicing with nothing obviously different in the problem areas:


The artifacts are there even with Detail - Sharpening turned off.

(Edited)
Photo of zqtxyunx

zqtxyunx

  • 5 Posts
  • 0 Reply Likes
Thanks, interesting to see the actual mosaic as well! Please let me know what Adobe's comments are.
Photo of Chris Castleberry

Chris Castleberry, Camera Raw Engineer

  • 345 Posts
  • 97 Reply Likes
Logged bug #4164422 for reference.
Photo of zqtxyunx

zqtxyunx

  • 5 Posts
  • 0 Reply Likes
Any news on this, Chris? Is the bug number internal, or is there somewhere pubilc I can check out the progress?