Lightroom: Off center printing and no leading edge stroke pixels when printing to an Epson 3880 since installing MacOS 10.10 Yosemite

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
I have been printing from the same preset to print from LR5 since moving to it. I recently upgraded to Yosemite on the OS X side. Since doing this my prints no longer center on the paper and the leading edge no longer has the stroke on it. I am printing to an Epson 3880 with the latest driver installed. The preview in the printing panel looks perfect.
Photo of Doug Parks

Doug Parks

  • 4 Posts
  • 1 Reply Like

Posted 4 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 823 Reply Likes
The printer driver controls where the print goes, and the page layout information that it gives to the application.
Double check all your settings in the Epson driver controls, and if you can't solve it there you'll need to talk to Epson and see if they have an update for MacOS 10.10.
Photo of Doug Parks

Doug Parks

  • 4 Posts
  • 1 Reply Like
Thanks. The driver I have is suppose to be 10.10 compatible. I have the latest. I do not know where you are talking about in the driver controls. Is this a separate application in OS X?

I do have a trouble ticket open with the folks at Epson, and they are not nearly as responsive to say the least.

Thanks for the prompt response, and any info on the driver controls appreciated.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 823 Reply Likes
The Epson/driver specific controls appear under the Print Settings button.
Photo of Doug Parks

Doug Parks

  • 4 Posts
  • 1 Reply Like
I found that the update to the driver did not take. I needed to delete the driver, delete the printer, install the driver (ver 9.33) then install the printer. All is good in the world again! Thanks for the pointer.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 823 Reply Likes
Glad to hear that you got it working.