Photoshop: Intel and Nvidia GeForce GTX 980 on same system not allowing GPU acceleration

  • 1
  • Problem
  • Updated 4 months ago
  • (Edited)
Hi, I'm running the most recent version of Photoshop CC2018, and I've updated my GeForce drivers, so far nothing I do will allow me to use the GPU accelration. 

Photoshop appears to be regonizesing the graphics card, but not allowing it.
Occasionaly the GPU acceraltion box will be checked and not greyed out, but upon enabling 3-D mode it become greyed out.

System Info:
Adobe Photoshop Version: 19.1.2 20180302.r.277 2018/03/02: 1160083  x64
Number of Launches: 163
Operating System: Windows 10 64-bit
Version: 10 or greater 10.0.16299.15
System architecture: Intel CPU Family:6, Model:12, Stepping:3 with MMX, SSE Integer, SSE FP, SSE2, SSE3, SSE4.1, SSE4.2, AVX, AVX2, HyperThreading
Physical processor count: 4
Logical processor count: 8
Processor speed: 4000 MHz
Built-in memory: 16245 MB
Free memory: 2 MB
Memory available to Photoshop: 14321 MB
Memory used by Photoshop: 60 %
Alias Layers: Disabled.
Modifier Palette: Enabled.
Highbeam: Enabled.
Image tile size: 1024K
Image cache levels: 4
Font Preview: Medium
TextComposer: Latin
Display: 1
Display Bounds: top=0, left=0, bottom=1440, right=2560
Display: 2
Display Bounds: top=0, left=2560, bottom=800, right=3840
OpenGL Drawing: Enabled.
OpenGL Allow Old GPUs: Not Detected.
OpenGL Drawing Mode: Advanced
OpenGL Allow Normal Mode: True.
OpenGL Allow Advanced Mode: True.
AIFCoreInitialized=1
AIFOGLInitialized=1
OGLContextCreated=1
NumGLGPUs=1
NumCLGPUs=2
NumNativeGPUs=0
glgpu[0].GLVersion="4.1"
glgpu[0].IsIntegratedGLGPU=0
glgpu[0].GLMemoryMB=4096
glgpu[0].GLName="NVIDIA GeForce GTX 980"
glgpu[0].GLVendor="NVIDIA Corporation"
glgpu[0].GLVendorID=4318
glgpu[0].GLDriverVersion="23.21.13.9077"
glgpu[0].GLRectTextureSize=16384
glgpu[0].GLRenderer="GeForce GTX 980/PCIe/SSE2"
glgpu[0].GLRendererID=5056
glgpu[0].HasGLNPOTSupport=1
glgpu[0].GLDriver="C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_258f7a4f413a360c\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_258f7a4f413a360c\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_258f7a4f413a360c\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_258f7a4f413a360c\nvldumdx.dll"
glgpu[0].GLDriverDate="20180123000000.000000-000"
glgpu[0].CanCompileProgramGLSL=1
glgpu[0].GLFrameBufferOK=1
glgpu[0].glGetString[GL_SHADING_LANGUAGE_VERSION]="4.60 NVIDIA"
glgpu[0].glGetProgramivARB[GL_FRAGMENT_PROGRAM_ARB][GL_MAX_PROGRAM_INSTRUCTIONS_ARB]=[65536]
glgpu[0].glGetIntegerv[GL_MAX_TEXTURE_UNITS]=[4]
glgpu[0].glGetIntegerv[GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS]=[192]
glgpu[0].glGetIntegerv[GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS]=[32]
glgpu[0].glGetIntegerv[GL_MAX_TEXTURE_IMAGE_UNITS]=[32]
glgpu[0].glGetIntegerv[GL_MAX_DRAW_BUFFERS]=[8]
glgpu[0].glGetIntegerv[GL_MAX_VERTEX_UNIFORM_COMPONENTS]=[4096]
glgpu[0].glGetIntegerv[GL_MAX_FRAGMENT_UNIFORM_COMPONENTS]=[4096]
glgpu[0].glGetIntegerv[GL_MAX_VARYING_FLOATS]=[124]
glgpu[0].glGetIntegerv[GL_MAX_VERTEX_ATTRIBS]=[16]
glgpu[0].extension[AIF::OGL::GL_ARB_VERTEX_PROGRAM]=1
glgpu[0].extension[AIF::OGL::GL_ARB_FRAGMENT_PROGRAM]=1
glgpu[0].extension[AIF::OGL::GL_ARB_VERTEX_SHADER]=1
glgpu[0].extension[AIF::OGL::GL_ARB_FRAGMENT_SHADER]=1
glgpu[0].extension[AIF::OGL::GL_EXT_FRAMEBUFFER_OBJECT]=1
glgpu[0].extension[AIF::OGL::GL_ARB_TEXTURE_RECTANGLE]=1
glgpu[0].extension[AIF::OGL::GL_ARB_TEXTURE_FLOAT]=1
glgpu[0].extension[AIF::OGL::GL_ARB_OCCLUSION_QUERY]=1
glgpu[0].extension[AIF::OGL::GL_ARB_VERTEX_BUFFER_OBJECT]=1
glgpu[0].extension[AIF::OGL::GL_ARB_SHADER_TEXTURE_LOD]=1
clgpu[0].CLPlatformVersion="1.2"
clgpu[0].CLDeviceVersion="1.2 CUDA"
clgpu[0].IsIntegratedCLGPU=0
clgpu[0].CLMemoryMB=4096
clgpu[0].CLName="GeForce GTX 980"
clgpu[0].CLVendor="NVIDIA Corporation"
clgpu[0].CLVendorID=4318
clgpu[0].CLDriverVersion="390.77"
clgpu[0].CLBandwidth=1.63932e+11
clgpu[0].CLCompute=1989.54
clgpu[1].CLPlatformVersion="1.2 "
clgpu[1].CLDeviceVersion="1.2 "
clgpu[1].IsIntegratedCLGPU=1
clgpu[1].CLMemoryMB=1629
clgpu[1].CLName="Intel(R) HD Graphics 4600"
clgpu[1].CLVendor="Intel(R) Corporation"
clgpu[1].CLVendorID=32902
clgpu[1].CLDriverVersion="20.19.15.4835"
clgpu[1].CLBandwidth=1.8925e+10
clgpu[1].CLCompute=190.856
License Type: Subscription


I
Photo of Amanda

Amanda

  • 1 Post
  • 0 Reply Likes

Posted 4 months ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14094 Posts
  • 1748 Reply Likes
Looks like you have two cards from two different manufactures. See step 7 under troubleshooting here to either disable the lowered powered, integrated Intel card, or explicitly select the dedicated graphics card: https://helpx.adobe.com/photoshop/kb/troubleshoot-gpu-graphics-card.html