Lightroom: Not able to move or delete pictures or folders... Sometimes

  • 3
  • Problem
  • Updated 3 years ago
  • (Edited)
Not able to move or delete pictures or folders... Sometimes

See this post I created. It explains as perfectly as I possibly can what the problem is, etc.
http://www.lightroomforums.net/showth...

I don't care about votes or anything, it just needs fixing. And not for LR6, but for a maintenance release. This problem has been going on for far too long, and enough is enough.
Photo of thany81

thany81

  • 26 Posts
  • 2 Reply Likes

Posted 5 years ago

  • 3
Photo of thany81

thany81

  • 26 Posts
  • 2 Reply Likes
Who added "LIGHTROOM?"
I see it's been posted in Photoshop Family, but it applies to Lightroom indeed.

Oh and Adobe: fix this already, will ya? It's been around for more than long enough.
Photo of martijn Saly

martijn Saly

  • 194 Posts
  • 22 Reply Likes
Still happening in LR6. Less oftenly, but still.

When I try again, magically it works. Can't LR try again by itself?

Does Adobe not care that when this happens to a photo in a stack, that stack is broken?
Photo of Aidan Wojtas

Aidan Wojtas

  • 57 Posts
  • 21 Reply Likes
This happens to me too, LR CC. Mostly it happens if I try to do actions too quickly, like I've just been tagging photos and then I want to rename or move the folder.
But sometimes a photo gets tied up and that folder can't be moved. Videos can be worse.

If I wait 10 seconds and I'm sure all background activity then 95% of the time it will succeed.

Adobe, would it work to:
- Make renames/moves happen as a queued task so that they complete when the IO operation has a higher chance of being successful
- OR, prevent the interface from allowing renames/deletes when Lightroom knows the IO operation would likely fail due to another competing process using the same files
Photo of Aidan Wojtas

Aidan Wojtas

  • 57 Posts
  • 21 Reply Likes
Added note: On Windows 10 platform and it doesn't matter if they're photos on local SSD or NAS mapped as network drive